aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-30 20:37:48 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-30 20:37:48 +0000
commiteb176a659d2d2f0666ec4acef2fec47bbce15feb (patch)
treefe48e69672a3a8232dc7127aa5a5dc6dd60eddfa
parent82dff0bafefb9ea59af7104c2dab3de237f81cc2 (diff)
downloadports-eb176a659d2d2f0666ec4acef2fec47bbce15feb.tar.gz
ports-eb176a659d2d2f0666ec4acef2fec47bbce15feb.zip
audio/ardour6: fix build on powerpc
ld: error: can't create dynamic relocation R_PPC_ADDR32 against local symbol in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output >>> defined in libs/ardour/cycle_timer.cc.1.o >>> referenced by cycle_timer.cc >>> libs/ardour/cycle_timer.cc.1.o:(__ftr_fixup+0x1C)
-rw-r--r--audio/ardour6/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/audio/ardour6/Makefile b/audio/ardour6/Makefile
index 7b79edd21da5..b02beff079fa 100644
--- a/audio/ardour6/Makefile
+++ b/audio/ardour6/Makefile
@@ -61,6 +61,8 @@ CONFIGURE_ARGS_amd64= --arch='-msse -mfpmath=sse -DARCH_X86' --dist-target=x86_6
# only support for i686 or better
CONFIGURE_ARGS_i386= --arch='-msse -mfpmath=sse -march=i686 -DARCH_X86' --dist-target=i686
+LDFLAGS_powerpc= -Wl,-z,notext
+
post-patch:
@${REINPLACE_CMD} -e 's/obj\.use = '\''libsmf libpbd'\''/obj\.use = '\''libsmf_internal libpbd'\''/g' ${WRKSRC}/libs/evoral/wscript
@${REINPLACE_CMD} -e 's/libsmf\.name = '\''libsmf'\''/libsmf\.name = '\''libsmf_internal'\''/g' ${WRKSRC}/libs/evoral/wscript