aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-03-20 13:55:30 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-03-20 13:55:30 +0000
commiteb212b0bbae4d993eef29df8df1bb63ca8290b56 (patch)
treea1761145c0c82cc4188f6ace4437e4e5446b2379
parent4082f0b6dba043fe86d64e243da1aa668a9d4622 (diff)
downloadports-eb212b0bbae4d993eef29df8df1bb63ca8290b56.tar.gz
ports-eb212b0bbae4d993eef29df8df1bb63ca8290b56.zip
- Resolve build when COMPRESSED_FOLDERS is enabled
- Bump PORTREVISION PR: ports/187629 Submitted by: Simeon Simeonov <blackmore@pichove.org> Approved by: "Schweigert, Udo" <Udo.Schweigert@siemens.com> (maintainer)
Notes
Notes: svn path=/head/; revision=348686
-rw-r--r--mail/mutt/Makefile45
-rw-r--r--mail/mutt/pkg-plist26
2 files changed, 35 insertions, 36 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index d75f2a9af1bf..707ffb7e6c92 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mutt
PORTVERSION= 1.5.23
+PORTREVISION= 1
CATEGORIES+= mail ipv6
MASTER_SITES= ftp://ftp.mutt.org/mutt/ \
ftp://ftp.mutt.org/mutt/devel/ \
@@ -58,13 +59,15 @@ USE_OPENSSL= yes
.if defined (MUTT_LITE)
LITE= YES
.endif
-.if !defined (LITE)
+.if defined (LITE)
+OPTIONS_UNSET= NLS DOCS EXAMPLES
+.else
OPTIONS_DEFINE= COMPRESSED_FOLDERS SASL DEBUG FLOCK \
GPGME GREETING_PATCH GSSAPI HTML ICONV IDN IFDEF_PATCH \
IMAP_HEADER_CACHE LOCALES_FIX MAILBOX_MANPAGES \
MAILDIR_HEADER_CACHE MAILDIR_MTIME_PATCH \
- NNTP PARENT_CHILD_MATCH_PATCH \
- QUOTE_PATCH REVERSE_REPLY_PATCH SGMLFORMAT SIDEBAR_PATCH \
+ NLS NNTP PARENT_CHILD_MATCH_PATCH \
+ QUOTE_PATCH REVERSE_REPLY_PATCH SIDEBAR_PATCH \
SIGNATURE_MENU SMART_DATE SMIME_OUTLOOK_COMPAT SMTP \
TOKYOCABINET TRASH_PATCH XML
@@ -89,10 +92,10 @@ MAILDIR_HEADER_CACHE_DESC= Maildir header cache
MAILDIR_MTIME_PATCH_DESC= Maildir mtime patch
MBOX_HOOK_PATCH_DESC= Enhanced mbox-hook
NCURSES_DESC= Ncurses support
+NLS_DESC= Native language support
PARENT_CHILD_MATCH_PATCH_DESC= Parent/child match
QUOTE_PATCH_DESC= Extended quoting
REVERSE_REPLY_PATCH_DESC= Reverse_reply
-SGMLFORMAT_DESC= SGML support
SIDEBAR_PATCH_DESC= Sidebar support
SIGNATURE_MENU_DESC= Signature menu
SLANG_DESC= SLANG support
@@ -101,11 +104,13 @@ SMIME_OUTLOOK_COMPAT_DESC= SMIME outlook compatibility
SMTP_DESC= SMTP relay support
TOKYOCABINET_DESC= Use tokyocabinet instead of Berkley DB
TRASH_PATCH_DESC= Trash folder support
-XML_DESC= Use XML tools for building documentation
+XML_DESC= Use XML tools for rebuilding documentation
-OPTIONS_DEFAULT= COMPRESSED_FOLDERS HTML ICONV MAILBOX_MANPAGES \
- NCURSES QUOTE_PATCH SGMLFORMAT SMIME_OUTLOOK_COMPAT \
- NLS XML SMTP
+OPTIONS_DEFAULT= COMPRESSED_FOLDERS HTML ICONV IFDEF_PATCH \
+ IMAP_HEADER_CACHE MAILBOX_MANPAGES MAILDIR_HEADER_CACHE \
+ MAILDIR_MTIME_PATCH NLS NCURSES PARENT_CHILD_MATCH_PATCH \
+ QUOTE_PATCH REVERSE_REPLY_PATCH SMART_DATE \
+ SMIME_OUTLOOK_COMPAT SMTP XML
.endif
.include <bsd.port.options.mk>
@@ -137,7 +142,7 @@ PLIST_SUB+= MBOXMAN=""
# XXX
# this should be done automagically by aclocal but ....
# for now, this will have to do
-pre-build:
+pre-build::
@${REINPLACE_CMD} -E -e "s|^(ACLOCAL = ).+|\1${ACLOCAL}|" \
-e "s|^(AUTOCONF = ).+|\1${AUTOCONF}|" \
-e "s|^(AUTOMAKE = ).+|\1${AUTOMAKE}|" \
@@ -169,11 +174,6 @@ LIB_DEPENDS+= libslang.so:${PORTSDIR}/devel/libslang2
USES+= ncurses
.endif
-.if ! ${PORT_OPTIONS:MSGMLFORMAT} || ! ${PORT_OPTIONS:MXML} || !defined(XML_USED) \
- || ! ${PORT_OPTIONS:MDOCS}
-XML_USED= no
-.endif
-
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
@@ -403,13 +403,6 @@ CONFIGURE_ARGS+= --disable-hcache
CONFIGURE_ARGS+= --without-qdbm
.endif
-.if defined (XML_NEEDED) && ${PORT_OPTIONS:MXML}
-XML_USED= yes
-.endif
-.if ${PORT_OPTIONS:MHTML}
-XML_USED= yes
-.endif
-
.if ${PORT_OPTIONS:MMAILBOX_MANPAGES}
PLIST_SUB+= MBOXMAN=""
.else
@@ -421,7 +414,7 @@ PLIST_SUB+= HTML=""
.else
PLIST_SUB+= HTML="@comment "
.endif
-.if ${PORT_OPTIONS:MDOCS} || ${XML_USED} == yes
+.if ${PORT_OPTIONS:MDOCS}
post-build:
@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-doc-ref
@${REINPLACE_CMD} -E -e 's|\$$\{PREFIX\}|${PREFIX}|g' \
@@ -434,10 +427,16 @@ post-build:
${WRKSRC}/doc/muttrc.man
.endif
-.if ${XML_USED} == yes
+.if defined (XML_NEEDED) && ${PORT_OPTIONS:MXML}
+PLIST_SUB+= XML=""
BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl \
lynx:${PORTSDIR}/www/lynx
+.else
+PLIST_SUB+= XML="@comment "
+pre-build::
+ @${REINPLACE_CMD} -E -e 's|-xsltproc|@-true xsltproc|g' \
+ ${WRKSRC}/doc/Makefile
.endif
.if ${PORT_OPTIONS:MSLANG}
diff --git a/mail/mutt/pkg-plist b/mail/mutt/pkg-plist
index 4327f4981830..5d9e05545752 100644
--- a/mail/mutt/pkg-plist
+++ b/mail/mutt/pkg-plist
@@ -38,19 +38,19 @@ man/man5/muttrc.5.gz
%%PORTDOCS%%%%DOCSDIR%%/patch-notes.txt
%%PORTDOCS%%%%DOCSDIR%%/smime-notes.txt
%%NNTP%%%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.nntp
-%%PORTDOCS%%%%DOCSDIR%%/advancedusage.html
-%%PORTDOCS%%%%DOCSDIR%%/configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/gettingstarted.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/intro.html
-%%PORTDOCS%%%%DOCSDIR%%/manual.html
-%%PORTDOCS%%%%DOCSDIR%%/mimesupport.html
-%%PORTDOCS%%%%DOCSDIR%%/miscellany.html
-%%PORTDOCS%%%%DOCSDIR%%/optionalfeatures.html
-%%PORTDOCS%%%%DOCSDIR%%/reference.html
-%%PORTDOCS%%%%DOCSDIR%%/security.html
-%%PORTDOCS%%%%DOCSDIR%%/tuning.html
-%%COMPRESS%%%%PORTDOCS%%%%DOCSDIR%%/compressed-folders.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/advancedusage.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/configuration.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/gettingstarted.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/intro.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/mimesupport.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/miscellany.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/optionalfeatures.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/reference.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/security.html
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/tuning.html
+%%XML%%%%HTML%%%%COMPRESS%%%%PORTDOCS%%%%DOCSDIR%%/compressed-folders.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Mush.rc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Pine.rc