aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-02 06:15:24 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-02 20:11:33 +0000
commitecc6daf598b26b1b3a2e4e48b26d55c1e3636437 (patch)
tree168a3f742b4e2625cb25a465940c3dfcaf9fd687
parent0662f002d0262a06ccc8092c366e2f5a119acae2 (diff)
downloadports-ecc6daf598b26b1b3a2e4e48b26d55c1e3636437.tar.gz
ports-ecc6daf598b26b1b3a2e4e48b26d55c1e3636437.zip
x11/xscreensaver: Remove PAM option
Upstream ./configure now fails with --without-pam if PAM is found on the build system with this message: Your system seems to have PAM, but PAM is not being used. That is probably not going to work out well. We have PAM in base and can't build base without it any more (WITHOUT_PAM is deprecated), so let's just remove that port option and always build xscreensaver with PAM (previously enabled by default). With PAM enforced, support for shadow passwords is not needed. Forcing it to off, we can avoid installing xscreensaver-auth suid root. PR: 264361 Approved by: x11 (cy, manu), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36425
-rw-r--r--x11/xscreensaver/Makefile16
-rw-r--r--x11/xscreensaver/files/patch-driver_Makefile.in13
-rw-r--r--x11/xscreensaver/pkg-plist2
3 files changed, 10 insertions, 21 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index ff132c3b7dc4..390990542eeb 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -1,5 +1,6 @@
PORTNAME= xscreensaver
PORTVERSION= 6.04
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/
@@ -10,7 +11,8 @@ LICENSE= MIT
RUN_DEPENDS= giftopnm:graphics/netpbm \
p5-libwww>0:www/p5-libwww \
- p5-LWP-Protocol-https>0:www/p5-LWP-Protocol-https
+ p5-LWP-Protocol-https>0:www/p5-LWP-Protocol-https \
+ unix-selfauth-helper>0:security/unix-selfauth-helper
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgle.so:graphics/gle \
@@ -35,6 +37,7 @@ CONFIGURE_ARGS= --enable-locking \
--with-gtk \
--with-hackdir=${PREFIX}/bin/xscreensaver-hacks/ \
--with-jpeg=${LOCALBASE} \
+ --with-pam \
--with-pixbuf \
--with-randr-ext \
--with-xdbe-ext \
@@ -43,18 +46,15 @@ CONFIGURE_ARGS= --enable-locking \
--with-xft \
--with-xinerama-ext \
--with-xshm-ext \
- --without-kerberos
+ --without-kerberos \
+ --without-shadow
MAKE_ARGS+= install_prefix=${STAGEDIR}
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= FIREF NLS NSFW PAM SETUID_HACKS XAOS1 XDALI XEARTH \
+OPTIONS_DEFINE= FIREF NLS NSFW SETUID_HACKS XAOS1 XDALI XEARTH \
XMOUN XPLANET XSNOW
-OPTIONS_DEFAULT= PAM
OPTIONS_SUB= yes
-PAM_CONFIGURE_WITH= pam
-PAM_RUN_DEPENDS= unix-selfauth-helper>0:security/unix-selfauth-helper
-
SETUID_HACKS_DESC= Install sonar hack suid so it can ping
SETUID_HACKS_CONFIGURE_WITH= setuid-hacks
@@ -104,8 +104,6 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/x*.xml ${STAGEDIR}${DATADIR}/config/
${INSTALL_DATA} ${WRKDIR}/*.desktop ${STAGEDIR}${PREFIX}/share/applications/
${RM} ${STAGEDIR}${PREFIX}/etc/pam.d/xscreensaver.pam
-
-post-install-PAM-on:
${INSTALL_DATA} ${WRKDIR}/xscreensaver.pam ${STAGEDIR}${PREFIX}/etc/pam.d/xscreensaver
.include <bsd.port.mk>
diff --git a/x11/xscreensaver/files/patch-driver_Makefile.in b/x11/xscreensaver/files/patch-driver_Makefile.in
index 828a4f48818a..c70eddfd7d92 100644
--- a/x11/xscreensaver/files/patch-driver_Makefile.in
+++ b/x11/xscreensaver/files/patch-driver_Makefile.in
@@ -1,15 +1,6 @@
---- driver/Makefile.in.orig 2021-10-12 01:04:31 UTC
+--- driver/Makefile.in.orig 2022-09-02 09:08:36 UTC
+++ driver/Makefile.in
-@@ -46,7 +46,7 @@ DEPEND_FLAGS = @DEPEND_FLAGS@
- DEPEND_DEFINES = @DEPEND_DEFINES@
-
- INSTALL = @INSTALL@
--SUID_FLAGS = -o root -m 4755
-+SUID_FLAGS = -m 4555
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
- INSTALL_SETUID = $(INSTALL_PROGRAM) $(SUID_FLAGS)
- INSTALL_DATA = @INSTALL_DATA@
-@@ -76,7 +76,7 @@ INTL_LIBS = @INTLLIBS@
+@@ -78,7 +78,7 @@ INTL_LIBS = @INTLLIBS@
AD_DIR = @APPDEFAULTS@
# $(sysconfdir) is either /usr/local/etc or /usr/etc but this must be /etc.
diff --git a/x11/xscreensaver/pkg-plist b/x11/xscreensaver/pkg-plist
index 06caa646c362..f3982b76e38f 100644
--- a/x11/xscreensaver/pkg-plist
+++ b/x11/xscreensaver/pkg-plist
@@ -258,7 +258,7 @@ bin/xscreensaver-hacks/xrayswarm
bin/xscreensaver-hacks/xspirograph
bin/xscreensaver-hacks/zoom
bin/xscreensaver-settings
-%%PAM%%etc/pam.d/xscreensaver
+etc/pam.d/xscreensaver
lib/X11/app-defaults/XScreenSaver
man/man1/xscreensaver-command.1.gz
man/man1/xscreensaver-demo.1.gz