aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-24 00:53:18 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-24 00:53:18 +0000
commited05eef8e8d23b5a00b8ff7f5f2fd43b6ea4ea37 (patch)
tree19eb832dd19f9f0bd36c2496bdfce94f60f54f40
parent9549788da83bf042355a2f7a4f127461bf99fbd6 (diff)
downloadports-ed05eef8e8d23b5a00b8ff7f5f2fd43b6ea4ea37.tar.gz
ports-ed05eef8e8d23b5a00b8ff7f5f2fd43b6ea4ea37.zip
Add voipong.
VoIPong is an utility which detects all Voice Over IP calls on a pipeline, and dumps those which are G711-encoded to separate wave files. It supports SIP, H323, Cisco's Skinny Client Protocol, RTP and RTCP. For performance reasons, it is written in the C programming language. WWW: http://www.enderunix.org/voipong/ PR: ports/81326 Submitted by: Necati Ersen SISECI <siseci@enderunix.org>
Notes
Notes: svn path=/head/; revision=136002
-rw-r--r--audio/Makefile1
-rw-r--r--audio/voipong/Makefile31
-rw-r--r--audio/voipong/distinfo2
-rw-r--r--audio/voipong/files/pkg-message.in7
-rw-r--r--audio/voipong/pkg-descr6
-rw-r--r--audio/voipong/pkg-plist7
6 files changed, 54 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index af98dd6603cf..435acd210fa9 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -468,6 +468,7 @@
SUBDIR += twolame
SUBDIR += ufmcontrol-i18n
SUBDIR += umix
+ SUBDIR += voipong
SUBDIR += vorbis-tools
SUBDIR += vorbisgain
SUBDIR += vsound
diff --git a/audio/voipong/Makefile b/audio/voipong/Makefile
new file mode 100644
index 000000000000..ab3492bb7c7d
--- /dev/null
+++ b/audio/voipong/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: voipong
+# Date created: 20 May 2005
+# Whom: Necati Ersen SISECI <siseci@enderunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= voipong
+PORTVERSION= 1.1
+CATEGORIES= audio
+MASTER_SITES= http://www.enderunix.org/voipong/
+
+MAINTAINER= siseci@enderunix.org
+COMMENT= Detect Voice Over IP calls and dump them to separate wave files
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+SUB_FILES= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS=""||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|$${prefix}/share/voipong|${DOCSDIR}|; \
+ s|COPYING||; s|LICENSE||' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/voipong/distinfo b/audio/voipong/distinfo
new file mode 100644
index 000000000000..14809a40f40a
--- /dev/null
+++ b/audio/voipong/distinfo
@@ -0,0 +1,2 @@
+MD5 (voipong-1.1.tar.gz) = f068c0554ef7bb89ae82f9c5ab66c2e5
+SIZE (voipong-1.1.tar.gz) = 156577
diff --git a/audio/voipong/files/pkg-message.in b/audio/voipong/files/pkg-message.in
new file mode 100644
index 000000000000..562bd5c99e98
--- /dev/null
+++ b/audio/voipong/files/pkg-message.in
@@ -0,0 +1,7 @@
+---------------------------------------------------------------------
+You should now copy
+ %%PREFIX%%/etc/voipong.conf-dist
+to
+ %%PREFIX%%/etc/voipong.conf
+and edit it as appropriate.
+---------------------------------------------------------------------
diff --git a/audio/voipong/pkg-descr b/audio/voipong/pkg-descr
new file mode 100644
index 000000000000..08126eeb2d13
--- /dev/null
+++ b/audio/voipong/pkg-descr
@@ -0,0 +1,6 @@
+VoIPong is an utility which detects all Voice Over IP calls on a pipeline, and
+dumps those which are G711-encoded to separate wave files. It supports SIP,
+H323, Cisco's Skinny Client Protocol, RTP and RTCP. For performance reasons,
+it is written in the C programming language.
+
+WWW: http://www.enderunix.org/voipong/
diff --git a/audio/voipong/pkg-plist b/audio/voipong/pkg-plist
new file mode 100644
index 000000000000..c2ee134b05d6
--- /dev/null
+++ b/audio/voipong/pkg-plist
@@ -0,0 +1,7 @@
+bin/voipong
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/README
+%%DOCSDIR%%/THANKS
+etc/voipong.conf-dist
+@dirrm %%DOCSDIR%%