aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2017-09-12 19:22:01 +0000
committerCy Schubert <cy@FreeBSD.org>2017-09-12 19:22:01 +0000
commited06a7905ef84206eb9fd6b7b7d4ea55625bff19 (patch)
tree1c89c204b48cf6a407a1883f628f24d520c5eab1
parent110c7009fe1faf552e1fcaf231d9f5454303dfb9 (diff)
downloadports-ed06a7905ef84206eb9fd6b7b7d4ea55625bff19.tar.gz
ports-ed06a7905ef84206eb9fd6b7b7d4ea55625bff19.zip
This is the functional update of xpdf to xpdf 4.00.
graphics/xpdf is renamed (actually copied) to xpdf3. Those who want to continue to use xpdf with a Motif interface can either install xpdf3 or set XPDF_VERSION=3 in make.conf and continue to install graphics/xpdf. This works around any POLA issues people might have between the old and the new. PR: 222002
Notes
Notes: svn path=/head/; revision=449705
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xpdf/Makefile67
-rw-r--r--graphics/xpdf3/Makefile67
-rw-r--r--graphics/xpdf3/distinfo (renamed from graphics/xpdf/distinfo)0
-rw-r--r--graphics/xpdf3/files/patch-Makefile.in (renamed from graphics/xpdf/files/patch-Makefile.in)0
-rw-r--r--graphics/xpdf3/files/patch-splash_Makefile.in (renamed from graphics/xpdf/files/patch-splash_Makefile.in)0
-rw-r--r--graphics/xpdf3/files/patch-splash_SplashFTFont.cc (renamed from graphics/xpdf/files/patch-splash_SplashFTFont.cc)0
-rw-r--r--graphics/xpdf3/files/patch-xfont (renamed from graphics/xpdf/files/patch-xfont)0
-rw-r--r--graphics/xpdf3/files/patch-xpdf_GlobalParams.cc (renamed from graphics/xpdf/files/patch-xpdf_GlobalParams.cc)0
-rw-r--r--graphics/xpdf3/files/patch-xpdf_GlobalParams.h (renamed from graphics/xpdf/files/patch-xpdf_GlobalParams.h)0
-rw-r--r--graphics/xpdf3/files/patch-xpdf_Stream.cc (renamed from graphics/xpdf/files/patch-xpdf_Stream.cc)0
-rw-r--r--graphics/xpdf3/files/patch-xpdf_XPDFViewer.cc (renamed from graphics/xpdf/files/patch-xpdf_XPDFViewer.cc)0
-rw-r--r--graphics/xpdf3/files/patch-xpdf__Makefile.in (renamed from graphics/xpdf/files/patch-xpdf__Makefile.in)0
-rw-r--r--graphics/xpdf3/files/xpdf-man.conf.in (renamed from graphics/xpdf/files/xpdf-man.conf.in)0
-rw-r--r--graphics/xpdf3/pkg-descr (renamed from graphics/xpdf/pkg-descr)0
-rw-r--r--graphics/xpdf3/pkg-message (renamed from graphics/xpdf/pkg-message)0
-rw-r--r--graphics/xpdf3/pkg-plist (renamed from graphics/xpdf/pkg-plist)0
17 files changed, 72 insertions, 63 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f209718031be..dc745b2744f3 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1095,6 +1095,7 @@
SUBDIR += xournal
SUBDIR += xpaint
SUBDIR += xpdf
+ SUBDIR += xpdf3
SUBDIR += xpdf4
SUBDIR += xpeps
SUBDIR += xpx
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index b319e43d141b..33919e0c5e59 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -1,67 +1,8 @@
# $FreeBSD$
-PORTNAME= xpdf
-PORTVERSION= 3.04
-PORTREVISION= 8
-CATEGORIES= graphics print
-MASTER_SITES= http://mirrors.rit.edu/zi/ \
- ftp://ftp.foolabs.com/pub/xpdf/ \
- TEX_CTAN/support/xpdf \
- http://komquats.com/distfiles/
+VERSIONS= 3 4
+XPDF_VERSION?= 4
-MAINTAINER= cy@FreeBSD.org
-COMMENT= Display PDF files and convert them to other formats
+MASTERDIR= ${.CURDIR}/../xpdf${XPDF_VERSION}
-LICENSE= GPLv2
-
-LIB_DEPENDS= libfreetype.so:print/freetype2 \
- libpng.so:graphics/png
-
-GNU_CONFIGURE= yes
-USES= gmake cpe localbase
-CPE_VENDOR= foolabs
-CONFIGURE_ARGS= --enable-opi \
- --with-freetype2-library="${LOCALBASE}/lib" \
- --with-freetype2-includes="${LOCALBASE}/include/freetype2" \
- --bindir="${PREFIX}/libexec/xpdf" \
- --mandir="${PREFIX}/share/xpdf/man"
-
-MANPREFIX= ${PREFIX}/share/xpdf
-
-OPTIONS_DEFINE= LIBPAPER TYPE1 X11 DOCS
-LIBPAPER_DESC= Enable libpaper
-TYPE1_DESC= Ghostscript type1 fonts
-OPTIONS_DEFAULT= TYPE1 X11
-OPTIONS_SUB= yes
-
-SUB_FILES= xpdf-man.conf
-
-TYPE1_RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/n021003l.pfb:print/gsfonts
-
-LIBPAPER_LIB_DEPENDS= libpaper.so:print/libpaper
-LIBPAPER_CONFIGURE_ON=--with-libpaper-library="${LOCALBASE}/lib" \
- --with-libpaper-includes="${LOCALBASE}/include"
-LIBPAPER_CONFIGURE_OFF=--without-libpaper-library
-
-.if defined(A4)
-CONFIGURE_ARGS+= --enable-a4-paper
-.endif
-
-X11_CONFIGURE_WITH= x
-X11_USES= motif
-
-post-patch:
- ${REINPLACE_CMD} -e 's|undef USE_COMBO_BOX|define USE_COMBO_BOX 1|' \
- ${WRKSRC}/xpdf/XPDFViewer.h
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for file in ANNOUNCE CHANGES README misc/hello.pdf
- ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
-.endfor
- @cd ${STAGEDIR}${PREFIX}; \
- ${LN} -sf libexec/xpdf/xpdf bin/xpdf
- ${INSTALL_DATA} ${WRKDIR}/xpdf-man.conf \
- ${STAGEDIR}${PREFIX}/etc/man.d/xpdf.conf
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/xpdf3/Makefile b/graphics/xpdf3/Makefile
new file mode 100644
index 000000000000..b319e43d141b
--- /dev/null
+++ b/graphics/xpdf3/Makefile
@@ -0,0 +1,67 @@
+# $FreeBSD$
+
+PORTNAME= xpdf
+PORTVERSION= 3.04
+PORTREVISION= 8
+CATEGORIES= graphics print
+MASTER_SITES= http://mirrors.rit.edu/zi/ \
+ ftp://ftp.foolabs.com/pub/xpdf/ \
+ TEX_CTAN/support/xpdf \
+ http://komquats.com/distfiles/
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Display PDF files and convert them to other formats
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libpng.so:graphics/png
+
+GNU_CONFIGURE= yes
+USES= gmake cpe localbase
+CPE_VENDOR= foolabs
+CONFIGURE_ARGS= --enable-opi \
+ --with-freetype2-library="${LOCALBASE}/lib" \
+ --with-freetype2-includes="${LOCALBASE}/include/freetype2" \
+ --bindir="${PREFIX}/libexec/xpdf" \
+ --mandir="${PREFIX}/share/xpdf/man"
+
+MANPREFIX= ${PREFIX}/share/xpdf
+
+OPTIONS_DEFINE= LIBPAPER TYPE1 X11 DOCS
+LIBPAPER_DESC= Enable libpaper
+TYPE1_DESC= Ghostscript type1 fonts
+OPTIONS_DEFAULT= TYPE1 X11
+OPTIONS_SUB= yes
+
+SUB_FILES= xpdf-man.conf
+
+TYPE1_RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/n021003l.pfb:print/gsfonts
+
+LIBPAPER_LIB_DEPENDS= libpaper.so:print/libpaper
+LIBPAPER_CONFIGURE_ON=--with-libpaper-library="${LOCALBASE}/lib" \
+ --with-libpaper-includes="${LOCALBASE}/include"
+LIBPAPER_CONFIGURE_OFF=--without-libpaper-library
+
+.if defined(A4)
+CONFIGURE_ARGS+= --enable-a4-paper
+.endif
+
+X11_CONFIGURE_WITH= x
+X11_USES= motif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|undef USE_COMBO_BOX|define USE_COMBO_BOX 1|' \
+ ${WRKSRC}/xpdf/XPDFViewer.h
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for file in ANNOUNCE CHANGES README misc/hello.pdf
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
+.endfor
+ @cd ${STAGEDIR}${PREFIX}; \
+ ${LN} -sf libexec/xpdf/xpdf bin/xpdf
+ ${INSTALL_DATA} ${WRKDIR}/xpdf-man.conf \
+ ${STAGEDIR}${PREFIX}/etc/man.d/xpdf.conf
+
+.include <bsd.port.mk>
diff --git a/graphics/xpdf/distinfo b/graphics/xpdf3/distinfo
index 8e5c949df70a..8e5c949df70a 100644
--- a/graphics/xpdf/distinfo
+++ b/graphics/xpdf3/distinfo
diff --git a/graphics/xpdf/files/patch-Makefile.in b/graphics/xpdf3/files/patch-Makefile.in
index 6df513c49f4d..6df513c49f4d 100644
--- a/graphics/xpdf/files/patch-Makefile.in
+++ b/graphics/xpdf3/files/patch-Makefile.in
diff --git a/graphics/xpdf/files/patch-splash_Makefile.in b/graphics/xpdf3/files/patch-splash_Makefile.in
index 280cadcca468..280cadcca468 100644
--- a/graphics/xpdf/files/patch-splash_Makefile.in
+++ b/graphics/xpdf3/files/patch-splash_Makefile.in
diff --git a/graphics/xpdf/files/patch-splash_SplashFTFont.cc b/graphics/xpdf3/files/patch-splash_SplashFTFont.cc
index 48049df5edc6..48049df5edc6 100644
--- a/graphics/xpdf/files/patch-splash_SplashFTFont.cc
+++ b/graphics/xpdf3/files/patch-splash_SplashFTFont.cc
diff --git a/graphics/xpdf/files/patch-xfont b/graphics/xpdf3/files/patch-xfont
index 57a127450f3a..57a127450f3a 100644
--- a/graphics/xpdf/files/patch-xfont
+++ b/graphics/xpdf3/files/patch-xfont
diff --git a/graphics/xpdf/files/patch-xpdf_GlobalParams.cc b/graphics/xpdf3/files/patch-xpdf_GlobalParams.cc
index ceab23673ba1..ceab23673ba1 100644
--- a/graphics/xpdf/files/patch-xpdf_GlobalParams.cc
+++ b/graphics/xpdf3/files/patch-xpdf_GlobalParams.cc
diff --git a/graphics/xpdf/files/patch-xpdf_GlobalParams.h b/graphics/xpdf3/files/patch-xpdf_GlobalParams.h
index 9d6349e4d487..9d6349e4d487 100644
--- a/graphics/xpdf/files/patch-xpdf_GlobalParams.h
+++ b/graphics/xpdf3/files/patch-xpdf_GlobalParams.h
diff --git a/graphics/xpdf/files/patch-xpdf_Stream.cc b/graphics/xpdf3/files/patch-xpdf_Stream.cc
index 0804c26b55bc..0804c26b55bc 100644
--- a/graphics/xpdf/files/patch-xpdf_Stream.cc
+++ b/graphics/xpdf3/files/patch-xpdf_Stream.cc
diff --git a/graphics/xpdf/files/patch-xpdf_XPDFViewer.cc b/graphics/xpdf3/files/patch-xpdf_XPDFViewer.cc
index 65c3faca7da6..65c3faca7da6 100644
--- a/graphics/xpdf/files/patch-xpdf_XPDFViewer.cc
+++ b/graphics/xpdf3/files/patch-xpdf_XPDFViewer.cc
diff --git a/graphics/xpdf/files/patch-xpdf__Makefile.in b/graphics/xpdf3/files/patch-xpdf__Makefile.in
index 756c8da6e991..756c8da6e991 100644
--- a/graphics/xpdf/files/patch-xpdf__Makefile.in
+++ b/graphics/xpdf3/files/patch-xpdf__Makefile.in
diff --git a/graphics/xpdf/files/xpdf-man.conf.in b/graphics/xpdf3/files/xpdf-man.conf.in
index a7e2ad6b6dca..a7e2ad6b6dca 100644
--- a/graphics/xpdf/files/xpdf-man.conf.in
+++ b/graphics/xpdf3/files/xpdf-man.conf.in
diff --git a/graphics/xpdf/pkg-descr b/graphics/xpdf3/pkg-descr
index b6a0b3056a0b..b6a0b3056a0b 100644
--- a/graphics/xpdf/pkg-descr
+++ b/graphics/xpdf3/pkg-descr
diff --git a/graphics/xpdf/pkg-message b/graphics/xpdf3/pkg-message
index e8baf67674ee..e8baf67674ee 100644
--- a/graphics/xpdf/pkg-message
+++ b/graphics/xpdf3/pkg-message
diff --git a/graphics/xpdf/pkg-plist b/graphics/xpdf3/pkg-plist
index 724f3f9360bc..724f3f9360bc 100644
--- a/graphics/xpdf/pkg-plist
+++ b/graphics/xpdf3/pkg-plist