aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Burdett <mfburdett@gmail.com>2022-01-25 09:17:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-25 09:21:38 +0000
commited26168a5c8380b2bc81ff3cd460f7ff44458ebf (patch)
tree4288c49870340a16546a44474c36e3730435d75b
parentcd0d83cd41c67a7c33f1c64bcd9e6faa7aafabd1 (diff)
downloadports-ed26168a5c8380b2bc81ff3cd460f7ff44458ebf.tar.gz
ports-ed26168a5c8380b2bc81ff3cd460f7ff44458ebf.zip
Fix libphp name in php.mk
- From php80 and onwards libphp name is libphp.so without the major version number. Add a check to fix the RUN_DEPENDS. PR: 251252 Reported by: jonaspalm@posteo.de Approved by: ale (maintainer) Sponsored by: Bounce Experts
-rw-r--r--Mk/Uses/php.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index 8f1dd7cc6375..bf3a48b3bd71 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -275,8 +275,12 @@ RUN_DEPENDS+= ${PHPBASE}/include/php/main/php.h:${PHP_PORT}
. if ${php_ARGS:Mmod} || (${php_ARGS:Mweb} && defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == "" && ${PHP_SAPI:Mfpm} == "")
USE_APACHE_RUN= 22+
.include "${PORTSDIR}/Mk/Uses/apache.mk"
+. if ${PHP_VER} < 80
# libphpX.so only has the major version number in it, so remove the last digit of PHP_VER to get it.
RUN_DEPENDS+= ${PHPBASE}/${APACHEMODDIR}/libphp${PHP_VER:C/.$//}.so:${MOD_PHP_PORT}
+. else
+RUN_DEPENDS+= ${PHPBASE}/${APACHEMODDIR}/libphp.so:${MOD_PHP_PORT}
+. endif
. endif
PLIST_SUB+= PHP_EXT_DIR=${PHP_EXT_DIR}