aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-06-14 13:22:42 +0000
committerCy Schubert <cy@FreeBSD.org>2021-06-14 16:04:00 +0000
commited47e1ecc5db5576f6a2d4a47e083b2366bd65cc (patch)
treed8855c464138a3c4f81eee0025928aa57be510fa
parentc6f1867664d5ee44132e12d8ec53412b35754248 (diff)
downloadports-ed47e1ecc5db5576f6a2d4a47e083b2366bd65cc.tar.gz
ports-ed47e1ecc5db5576f6a2d4a47e083b2366bd65cc.zip
*/*: Sync hostapd* and wpa_supplicant* with base ce276fe26d92010776
Use IFM_IEEE80211_ADHOC for now on FreeBSD for IBSS operation. Base commit by adrian@ on Nov 26, 2015. This commit syncs ports with base. PR: 203086 Submitted by: avos MFH: 2020Q2
-rw-r--r--net/hostapd-devel/Makefile1
-rw-r--r--net/hostapd-devel/files/patch-src_drivers_driver__bsd.c21
-rw-r--r--net/hostapd/Makefile2
-rw-r--r--net/hostapd/files/patch-src_drivers_driver__bsd.c19
-rw-r--r--security/wpa_supplicant-devel/Makefile1
-rw-r--r--security/wpa_supplicant-devel/files/patch-src_drivers_driver__bsd.c21
-rw-r--r--security/wpa_supplicant/Makefile2
-rw-r--r--security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c19
8 files changed, 74 insertions, 12 deletions
diff --git a/net/hostapd-devel/Makefile b/net/hostapd-devel/Makefile
index 1df73b906760..2a4fbbd9500d 100644
--- a/net/hostapd-devel/Makefile
+++ b/net/hostapd-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hostapd
PORTVERSION= ${COMMIT_DATE}
CATEGORIES= net
+PORTREVISION= 1
PKGNAMESUFFIX= -devel
MAINTAINER= cy@FreeBSD.org
diff --git a/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c b/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c
index 4192741b5a70..9a37a1de0174 100644
--- a/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c
+++ b/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c
@@ -1,6 +1,6 @@
---- src/drivers/driver_bsd.c.orig 2019-08-07 06:25:25.000000000 -0700
-+++ src/drivers/driver_bsd.c 2021-01-20 08:00:59.210974000 -0800
-@@ -1336,14 +1336,18 @@
+--- src/drivers/driver_bsd.c.orig 2021-06-02 14:11:18.000000000 -0700
++++ src/drivers/driver_bsd.c 2021-06-13 23:11:15.089256000 -0700
+@@ -853,14 +853,18 @@
drv = bsd_get_drvindex(global, ifm->ifm_index);
if (drv == NULL)
return;
@@ -22,3 +22,18 @@
wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' UP",
drv->ifname);
wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_ENABLED,
+@@ -1220,7 +1224,14 @@
+ mode = 0 /* STA */;
+ break;
+ case IEEE80211_MODE_IBSS:
++ /*
++ * Ref bin/203086 - FreeBSD's net80211 currently uses
++ * IFM_IEEE80211_ADHOC.
++ */
++#if 0
+ mode = IFM_IEEE80211_IBSS;
++#endif
++ mode = IFM_IEEE80211_ADHOC;
+ break;
+ case IEEE80211_MODE_AP:
+ mode = IFM_IEEE80211_HOSTAP;
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index 1e70b2d5f2b2..f16516da9e6a 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hostapd
PORTVERSION= 2.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= https://w1.fi/releases/
diff --git a/net/hostapd/files/patch-src_drivers_driver__bsd.c b/net/hostapd/files/patch-src_drivers_driver__bsd.c
index 0a6812c26946..fe3064586710 100644
--- a/net/hostapd/files/patch-src_drivers_driver__bsd.c
+++ b/net/hostapd/files/patch-src_drivers_driver__bsd.c
@@ -1,5 +1,5 @@
--- src/drivers/driver_bsd.c.orig 2019-08-07 06:25:25.000000000 -0700
-+++ src/drivers/driver_bsd.c 2021-01-20 08:04:07.589603000 -0800
++++ src/drivers/driver_bsd.c 2021-06-13 23:10:12.570253000 -0700
@@ -649,7 +649,7 @@
len = 2048;
}
@@ -21,7 +21,22 @@
ether_sprintf(const u8 *addr)
{
static char buf[sizeof(MACSTR)];
-@@ -1336,14 +1340,18 @@
+@@ -1080,7 +1084,14 @@
+ mode = 0 /* STA */;
+ break;
+ case IEEE80211_MODE_IBSS:
++ /*
++ * Ref bin/203086 - FreeBSD's net80211 currently uses
++ * IFM_IEEE80211_ADHOC.
++ */
++#if 0
+ mode = IFM_IEEE80211_IBSS;
++#endif
++ mode = IFM_IEEE80211_ADHOC;
+ break;
+ case IEEE80211_MODE_AP:
+ mode = IFM_IEEE80211_HOSTAP;
+@@ -1336,14 +1347,18 @@
drv = bsd_get_drvindex(global, ifm->ifm_index);
if (drv == NULL)
return;
diff --git a/security/wpa_supplicant-devel/Makefile b/security/wpa_supplicant-devel/Makefile
index 6026d15038b6..c5b86916ea04 100644
--- a/security/wpa_supplicant-devel/Makefile
+++ b/security/wpa_supplicant-devel/Makefile
@@ -1,6 +1,7 @@
PORTNAME= wpa_supplicant
PORTVERSION= ${COMMIT_DATE}
CATEGORIES= security net
+PORTREVISION= 1
PKGNAMESUFFIX= -devel
MAINTAINER= cy@FreeBSD.org
diff --git a/security/wpa_supplicant-devel/files/patch-src_drivers_driver__bsd.c b/security/wpa_supplicant-devel/files/patch-src_drivers_driver__bsd.c
index 4192741b5a70..702e60d3b95c 100644
--- a/security/wpa_supplicant-devel/files/patch-src_drivers_driver__bsd.c
+++ b/security/wpa_supplicant-devel/files/patch-src_drivers_driver__bsd.c
@@ -1,6 +1,6 @@
---- src/drivers/driver_bsd.c.orig 2019-08-07 06:25:25.000000000 -0700
-+++ src/drivers/driver_bsd.c 2021-01-20 08:00:59.210974000 -0800
-@@ -1336,14 +1336,18 @@
+--- src/drivers/driver_bsd.c.orig 2021-06-02 14:11:18.000000000 -0700
++++ src/drivers/driver_bsd.c 2021-06-13 23:08:54.275496000 -0700
+@@ -853,14 +853,18 @@
drv = bsd_get_drvindex(global, ifm->ifm_index);
if (drv == NULL)
return;
@@ -22,3 +22,18 @@
wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' UP",
drv->ifname);
wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_ENABLED,
+@@ -1220,7 +1224,14 @@
+ mode = 0 /* STA */;
+ break;
+ case IEEE80211_MODE_IBSS:
++ /*
++ * Ref bin/203086 - FreeBSD's net80211 currently uses
++ * IFM_IEEE80211_ADHOC.
++ */
++#if 0
+ mode = IFM_IEEE80211_IBSS;
++#endif
++ mode = IFM_IEEE80211_ADHOC;
+ break;
+ case IEEE80211_MODE_AP:
+ mode = IFM_IEEE80211_HOSTAP;
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
index bb7dcc3cd6c7..7b23c34cd7cb 100644
--- a/security/wpa_supplicant/Makefile
+++ b/security/wpa_supplicant/Makefile
@@ -1,6 +1,6 @@
PORTNAME= wpa_supplicant
PORTVERSION= 2.9
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= security net
MASTER_SITES= https://w1.fi/releases/
diff --git a/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c b/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c
index 4f81ba0eaaea..7c452ece7476 100644
--- a/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c
+++ b/security/wpa_supplicant/files/patch-src_drivers_driver__bsd.c
@@ -1,5 +1,5 @@
--- src/drivers/driver_bsd.c.orig 2019-08-07 06:25:25.000000000 -0700
-+++ src/drivers/driver_bsd.c 2021-01-20 08:00:59.210974000 -0800
++++ src/drivers/driver_bsd.c 2021-06-13 23:07:14.016849000 -0700
@@ -649,7 +649,7 @@
len = 2048;
}
@@ -9,7 +9,22 @@
}
#ifdef HOSTAPD
-@@ -1336,14 +1336,18 @@
+@@ -1080,7 +1080,14 @@
+ mode = 0 /* STA */;
+ break;
+ case IEEE80211_MODE_IBSS:
++ /*
++ * Ref bin/203086 - FreeBSD's net80211 currently uses
++ * IFM_IEEE80211_ADHOC.
++ */
++#if 0
+ mode = IFM_IEEE80211_IBSS;
++#endif
++ mode = IFM_IEEE80211_ADHOC;
+ break;
+ case IEEE80211_MODE_AP:
+ mode = IFM_IEEE80211_HOSTAP;
+@@ -1336,14 +1343,18 @@
drv = bsd_get_drvindex(global, ifm->ifm_index);
if (drv == NULL)
return;