aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Certner <olce.freebsd@certner.fr>2023-08-25 11:06:31 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2024-01-18 23:44:50 +0000
commited633bad445cb49e524aab1cb11a2cbf17364a5c (patch)
tree4d6e9b10188f7cb3045328bbde93e16610775a5e
parent64e2b0206e4b53515059207935091b9ed1c49a21 (diff)
downloadports-ed633bad445cb49e524aab1cb11a2cbf17364a5c.tar.gz
ports-ed633bad445cb49e524aab1cb11a2cbf17364a5c.zip
textproc/enchant: Fix build with ISPELL option
clang++ 16 defaults to C++17 causing errors with the codebase when the ISPELL option is turned on. Switching back to C++11 (what upstream did for 1.6.1) makes it build correctly. PR: 273649
-rw-r--r--textproc/enchant/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index 6b87664386c6..daaa569a8735 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -13,6 +13,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= gmake gnome libtool pathfix pkgconfig
USE_GNOME= glib20
+USE_CXXSTD= c++11
CONFIGURE_ARGS= --disable-uspell \
--disable-voikko