aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2024-10-16 15:10:04 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2024-10-16 15:10:04 +0000
commited6ff40a4da9fbffbb5d93e6cc1f4e891a0e7c2f (patch)
treee03ee60b7a7c7162ec80849fc30a74439a91a865
parent3216d83912531463ed8f8f0ee134b57bc8cb338c (diff)
downloadports-ed6ff40a4da9fbffbb5d93e6cc1f4e891a0e7c2f.tar.gz
ports-ed6ff40a4da9fbffbb5d93e6cc1f4e891a0e7c2f.zip
net-im/telegram-desktop: update 5.6.1 -> 5.6.3
Removed the compilatation support for legacy 13.2, that helps do not compile llvm16, so significantly reduce the build time. Discussed with: fluffy
-rw-r--r--net-im/telegram-desktop/Makefile11
-rw-r--r--net-im/telegram-desktop/distinfo6
-rw-r--r--net-im/telegram-desktop/files/patch-cmake_external_qt_CMakeLists.txt12
-rw-r--r--net-im/telegram-desktop/files/patch-cmake_external_qt_package.cmake4
4 files changed, 13 insertions, 20 deletions
diff --git a/net-im/telegram-desktop/Makefile b/net-im/telegram-desktop/Makefile
index b1eb8565e61c..7ecc52236a63 100644
--- a/net-im/telegram-desktop/Makefile
+++ b/net-im/telegram-desktop/Makefile
@@ -1,5 +1,5 @@
PORTNAME= telegram-desktop
-DISTVERSION= 5.6.1
+DISTVERSION= 5.6.3
CATEGORIES= net-im
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
DISTNAME= tdesktop-${DISTVERSION}-full
@@ -110,18 +110,11 @@ TELEGRAM_API_ID= 601761
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD
-#EXTRA_PATCHES= ${PATCHDIR}/extra-patch-CMakeLists.txt
-USES+= llvm:min=16,build
-USES:= ${USES:Ncompiler\:*} # XXX avoid warnings
-.if defined(WITH_CCACHE_BUILD) && !defined(NO_CCACHE)
+.if ${OPSYS} == FreeBSD && defined(WITH_CCACHE_BUILD) && !defined(NO_CCACHE)
CMAKE_ARGS+= -DCMAKE_CC_COMPILER_LAUNCHER="${LOCALBASE}/bin/ccache" \
-DCMAKE_CPP_COMPILER_LAUNCHER="${LOCALBASE}/bin/ccache" \
-DCMAKE_CXX_COMPILER_LAUNCHER="${LOCALBASE}/bin/ccache"
.endif
-#.else
-#USES+= compiler:c++20-lang
-.endif
post-extract:
# Some of the third-party components already built, and
diff --git a/net-im/telegram-desktop/distinfo b/net-im/telegram-desktop/distinfo
index 15291e94a95b..3f88b7a823c0 100644
--- a/net-im/telegram-desktop/distinfo
+++ b/net-im/telegram-desktop/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1728332320
-SHA256 (tdesktop-5.6.1-full.tar.gz) = 3c32836361eb9d2d058ba8590c038281bd8a2196be93706484287a44d2b5d582
-SIZE (tdesktop-5.6.1-full.tar.gz) = 70325495
+TIMESTAMP = 1729038898
+SHA256 (tdesktop-5.6.3-full.tar.gz) = e32628184aa571f1051e1f8ac75a67455a07c1753a3be47bfb013994c941db15
+SIZE (tdesktop-5.6.3-full.tar.gz) = 70333924
diff --git a/net-im/telegram-desktop/files/patch-cmake_external_qt_CMakeLists.txt b/net-im/telegram-desktop/files/patch-cmake_external_qt_CMakeLists.txt
index 861c87c155fa..89ab8b613ef6 100644
--- a/net-im/telegram-desktop/files/patch-cmake_external_qt_CMakeLists.txt
+++ b/net-im/telegram-desktop/files/patch-cmake_external_qt_CMakeLists.txt
@@ -1,6 +1,6 @@
---- cmake/external/qt/CMakeLists.txt.orig 2024-07-06 19:02:01.004763000 +0000
-+++ cmake/external/qt/CMakeLists.txt 2024-07-06 19:02:09.327771000 +0000
-@@ -16,6 +16,8 @@
+--- cmake/external/qt/CMakeLists.txt.orig 2024-10-11 07:45:28 UTC
++++ cmake/external/qt/CMakeLists.txt
+@@ -16,6 +16,8 @@ if (DESKTOP_APP_USE_PACKAGED)
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
@@ -9,7 +9,7 @@
$<TARGET_NAME_IF_EXISTS:Qt::OpenGL>
Qt::Widgets
Qt::WidgetsPrivate
-@@ -36,6 +38,7 @@
+@@ -36,6 +38,7 @@ INTERFACE
${qt_loc}/include
${qt_loc}/include/QtCore
${qt_loc}/include/QtGui
@@ -17,7 +17,7 @@
$<$<TARGET_EXISTS:Qt::OpenGL>:${qt_loc}/include/QtOpenGL>
${qt_loc}/include/QtWidgets
$<$<TARGET_EXISTS:Qt::OpenGLWidgets>:${qt_loc}/include/QtOpenGLWidgets>
-@@ -46,9 +49,11 @@
+@@ -46,9 +49,11 @@ INTERFACE
$<$<TARGET_EXISTS:Qt::WaylandCompositor>:${qt_loc}/include/QtWaylandCompositor>
${qt_loc}/include/QtCore/${QT_VERSION}
${qt_loc}/include/QtGui/${QT_VERSION}
@@ -29,7 +29,7 @@
${qt_loc}/include/QtWidgets/${QT_VERSION}/QtWidgets
)
-@@ -97,6 +102,12 @@
+@@ -97,6 +102,12 @@ set(common_qt_libs
lib/${qt_lib_prefix}Qt${QT_VERSION_MAJOR}Gui
lib/${qt_lib_prefix}Qt${QT_VERSION_MAJOR}Core
)
diff --git a/net-im/telegram-desktop/files/patch-cmake_external_qt_package.cmake b/net-im/telegram-desktop/files/patch-cmake_external_qt_package.cmake
index a8a901c443d5..aa1b987526cb 100644
--- a/net-im/telegram-desktop/files/patch-cmake_external_qt_package.cmake
+++ b/net-im/telegram-desktop/files/patch-cmake_external_qt_package.cmake
@@ -1,6 +1,6 @@
---- cmake/external/qt/package.cmake.orig 2024-05-16 08:52:10 UTC
+--- cmake/external/qt/package.cmake.orig 2024-10-11 07:45:28 UTC
+++ cmake/external/qt/package.cmake
-@@ -41,6 +41,8 @@ find_package(Qt${QT_VERSION_MAJOR} OPTIONAL_COMPONENTS
+@@ -66,6 +66,8 @@ if (QT_VERSION_MAJOR GREATER_EQUAL 6)
if (QT_VERSION_MAJOR GREATER_EQUAL 6)
find_package(Qt${QT_VERSION_MAJOR} COMPONENTS OpenGL OpenGLWidgets REQUIRED)