aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-08-03 13:51:13 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-08-03 13:59:19 +0000
commitede4dd761078a3da30f65c3f6eb55f27af51ea26 (patch)
treed1b022411b09bcabb402902c6f857b8c9a0b9545
parent5bd35cab6094012b3c0d9e2cfefc2cba8af595c3 (diff)
downloadports-ede4dd761078a3da30f65c3f6eb55f27af51ea26.tar.gz
ports-ede4dd761078a3da30f65c3f6eb55f27af51ea26.zip
shells/zsh: remove the modification of the configure script
We used to modify the configure script to avoid zsh to link against librt because clock_gettime on FreeBSD is in libc not librt. It's been a while that we are configuring zsh with the --as-needed linker flag which means now even if -lrt is passed we will not end up linked to it librt anymore. besides, modifying the configure script at the patch phase makes it newer than stamp.h.in which results in the build system triggering a regeneration of itself (hence the USES= autoreconf we had), not touching anymore that script can remove the need for USES=autoreconf and the load if build dependencies it drags in Removing the USES=autoreconf highlights also the lack of build dependency on perl which is needed to be able to the help files for run-help to work on builtins. this is fixed now
-rw-r--r--shells/zsh/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 3abedb61bf6b..e38568d9cbda 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -17,8 +17,9 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
MAKE_JOBS_UNSAFE= yes
-USES= autoreconf cpe iconv localbase:ldflags ncurses shebangfix tar:xz
+USES= cpe iconv localbase:ldflags ncurses perl5 shebangfix tar:xz
+USE_PERL5= build
SHEBANG_LANG= zsh
zsh_OLD_CMD= zsh # shebang appears as /bin/zsh and just zsh
SHEBANG_FILES= Functions/Calendar/* \
@@ -86,8 +87,6 @@ CONFIGURE_ENV+= ac_cv_lib_iconv_libiconv=no
.endif
post-patch:
-# FreeBSD's clock_gettime(2) is in libc, not librt; see PR 167857
- @${REINPLACE_CMD} -e '/LIBS/s|-lrt||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|/etc/|${LOCALBASE}/etc/|" \
${WRKSRC}/Functions/MIME/zsh-mime-setup
${RM} ${WRKSRC}/Doc/help.txt