aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-23 16:06:30 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-23 16:06:30 +0000
commitedf1c8e035f7ac5b40f1c34d3d494ba7e3cadc52 (patch)
treed21cfd7411a8c99b181843f2137a5da4720e987a
parentf541f93a14832821a44634e36bf4ee8e526c0bd4 (diff)
downloadports-edf1c8e035f7ac5b40f1c34d3d494ba7e3cadc52.tar.gz
ports-edf1c8e035f7ac5b40f1c34d3d494ba7e3cadc52.zip
Adding port devel/p5-Expect-Simple, a wrapper around the lang/p5-Expect module.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163181
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Expect-Simple/Makefile31
-rw-r--r--devel/p5-Expect-Simple/distinfo3
-rw-r--r--devel/p5-Expect-Simple/pkg-descr27
-rw-r--r--devel/p5-Expect-Simple/pkg-plist5
5 files changed, 67 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8e41bf6589d0..e58fdc5abfda 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -950,6 +950,7 @@
SUBDIR += p5-Event
SUBDIR += p5-Event-RPC
SUBDIR += p5-Exception-Class
+ SUBDIR += p5-Expect-Simple
SUBDIR += p5-Exporter-Lite
SUBDIR += p5-Exporter-Tidy
SUBDIR += p5-ExtUtils-AutoInstall
diff --git a/devel/p5-Expect-Simple/Makefile b/devel/p5-Expect-Simple/Makefile
new file mode 100644
index 000000000000..af7a75ec0f30
--- /dev/null
+++ b/devel/p5-Expect-Simple/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Expect-Simple
+# Date created: 23 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Expect-Simple
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/D/DJ/DJERIUS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Wrapper around the Expect module
+
+BUILD_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Expect::Simple.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8.0. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Expect-Simple/distinfo b/devel/p5-Expect-Simple/distinfo
new file mode 100644
index 000000000000..f7c847b718c8
--- /dev/null
+++ b/devel/p5-Expect-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Expect-Simple-0.02.tar.gz) = 23c72fa4461f07522eb8c8511bad5d43
+SHA256 (Expect-Simple-0.02.tar.gz) = 562ac17b70f140f793cf08333a4da0e11f2bf6ee19ce297125aefb29ef8940ef
+SIZE (Expect-Simple-0.02.tar.gz) = 11100
diff --git a/devel/p5-Expect-Simple/pkg-descr b/devel/p5-Expect-Simple/pkg-descr
new file mode 100644
index 000000000000..218fb266b742
--- /dev/null
+++ b/devel/p5-Expect-Simple/pkg-descr
@@ -0,0 +1,27 @@
+Expect::Simple is a wrapper around the Expect module which should suffice
+for simple applications. It hides most of the Expect machinery; the Expect
+object is available for tweaking if need be.
+
+Generally, one starts by creating an Expect::Simple object using new. This
+will start up the target program, and will wait until one of the specified
+prompts is output by the target. At that point the caller should send()
+commands to the program; the results are available via the before, after,
+match_str, and match_idx methods. Since Expect simulates a terminal, there
+will be extra \r characters at the end of each line in the result (on UNIX
+at least). This is easily fixed:
+
+ ($res = $obj->before) =~ tr/\r//d;
+ @lines = split( "\n", $res );
+
+This is not done automatically.
+
+Exceptions will be thrown on error (match with /Expect::Simple/). Errors
+from Expect are available via the error_expect method. More human readable
+errors are available via the error method.
+
+The connection is automatically broken (by sending the specified
+disconnect command to the target) when the Expect::Simple object is
+destroyed.
+
+WWW: http://search.cpan.org/dist/Expect-Simple
+Author: Diab Jerius <djerius@cpan.org>
diff --git a/devel/p5-Expect-Simple/pkg-plist b/devel/p5-Expect-Simple/pkg-plist
new file mode 100644
index 000000000000..b97920ea585a
--- /dev/null
+++ b/devel/p5-Expect-Simple/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Expect/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Expect/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Expect/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Expect
+@dirrmtry %%SITE_PERL%%/Expect