aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-01-07 19:32:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-01-07 19:32:00 +0000
commitee1e583c052fe0d178e8494a879abe85659c1b87 (patch)
tree2c73aa636ff4f320decc900a218ac8005a74c17d
parentf242edea8a93853db6a78d51adccaf773aa79500 (diff)
downloadports-ee1e583c052fe0d178e8494a879abe85659c1b87.tar.gz
ports-ee1e583c052fe0d178e8494a879abe85659c1b87.zip
deskutils/mindforger: update the port to version 1.53.0
GC most of the patches that had been integrated upstream.
-rw-r--r--deskutils/mindforger/Makefile14
-rw-r--r--deskutils/mindforger/distinfo10
-rw-r--r--deskutils/mindforger/files/patch-app_app.pro17
-rw-r--r--deskutils/mindforger/files/patch-lib_lib.pro31
-rw-r--r--deskutils/mindforger/files/patch-lib_src_mind_ai_autolinking_naive__autolinking__preprocessor.cpp23
-rw-r--r--deskutils/mindforger/files/patch-lib_src_mind_mind.cpp30
6 files changed, 29 insertions, 96 deletions
diff --git a/deskutils/mindforger/Makefile b/deskutils/mindforger/Makefile
index ff215988020e..cf5df8b3c2aa 100644
--- a/deskutils/mindforger/Makefile
+++ b/deskutils/mindforger/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= mindforger
-PORTVERSION= 1.52.0
+PORTVERSION= 1.53.0
CATEGORIES= deskutils
MAINTAINER= danfe@FreeBSD.org
@@ -9,13 +9,15 @@ COMMENT= Thinking notebook and markdown editor
LICENSE= GPLv2+
-USES= qmake qt:5
+LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell
+
+USES= pkgconfig qmake qt:5
USE_QT= buildtools_build core declarative gui location network \
printsupport webchannel widgets
USE_GITHUB= yes
GH_ACCOUNT= dvorka
GH_PROJECT= cmark:cm
-GH_TAGNAME= f06d944:cm
+GH_TAGNAME= 4ca8688:cm
GH_SUBDIR= deps/cmark-gfm:cm
QMAKE_ARGS= CONFIG+="mfnocxx"
@@ -46,9 +48,7 @@ post-patch:
${WRKSRC}/app/src/qt/note_view_presenter.cpp \
${WRKSRC}/app/src/qt/note_view_presenter.h \
${WRKSRC}/app/src/qt/outline_header_view_presenter.cpp
- @${REINPLACE_CMD} -e '/#include <sys\/dir\.h>/d' \
- ${WRKSRC}/lib/src/config/config.h
- @${REINPLACE_CMD} -e '/path = /s,/usr,$$$$PREFIX,' \
- ${WRKSRC}/app/app.pro ${WRKSRC}/mindforger.pro
+ @${REINPLACE_CMD} -e 's/_current_dir_name(/cwd(nullptr, 0/' \
+ ${WRKSRC}/lib/src/gear/file_utils.cpp
.include <bsd.port.mk>
diff --git a/deskutils/mindforger/distinfo b/deskutils/mindforger/distinfo
index 34ac782baf2b..277f63fcc09e 100644
--- a/deskutils/mindforger/distinfo
+++ b/deskutils/mindforger/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1583687032
-SHA256 (dvorka-mindforger-1.52.0_GH0.tar.gz) = d0fc9469e932a27f93b13acb6b708e2cfac37858083e0572a4c39b01b8202773
-SIZE (dvorka-mindforger-1.52.0_GH0.tar.gz) = 1775600
-SHA256 (dvorka-cmark-f06d944_GH0.tar.gz) = 7793cd6f1904a7674f9830985ded7c096e8edfdfd2f21c7127213ffffa56fe6d
-SIZE (dvorka-cmark-f06d944_GH0.tar.gz) = 279633
+TIMESTAMP = 1640528172
+SHA256 (dvorka-mindforger-1.53.0_GH0.tar.gz) = a8a917c4b6eb28b16ab09322108049408c9bcb897baeba786042c1bcb1389ce7
+SIZE (dvorka-mindforger-1.53.0_GH0.tar.gz) = 2137346
+SHA256 (dvorka-cmark-4ca8688_GH0.tar.gz) = 8486c44ed23ae3865f5ebba034e319ed9e65340ffca1df09a4edd4b4677ab6cb
+SIZE (dvorka-cmark-4ca8688_GH0.tar.gz) = 288979
diff --git a/deskutils/mindforger/files/patch-app_app.pro b/deskutils/mindforger/files/patch-app_app.pro
new file mode 100644
index 000000000000..07e4ced9de25
--- /dev/null
+++ b/deskutils/mindforger/files/patch-app_app.pro
@@ -0,0 +1,17 @@
+--- app/app.pro.orig 2021-12-26 14:16:12 UTC
++++ app/app.pro
+@@ -137,12 +137,8 @@ macx {
+ ./src/qt/spelling/dictionary_provider_voikko.cpp
+
+ } else:unix {
+- # pkgconfig-based configuration does not work @ Ubuntu distribution build
+- # CONFIG += link_pkgconfig
+- # PKGCONFIG += hunspell
+- # hardcoded paths are unfortunately more robust:
+- INCLUDEPATH += /usr/include/hunspell
+- LIBS += -lhunspell
++ CONFIG += link_pkgconfig
++ PKGCONFIG += hunspell
+
+ HEADERS += \
+ ./src/qt/spelling/dictionary_provider_hunspell.h \
diff --git a/deskutils/mindforger/files/patch-lib_lib.pro b/deskutils/mindforger/files/patch-lib_lib.pro
deleted file mode 100644
index 8661ce6487d3..000000000000
--- a/deskutils/mindforger/files/patch-lib_lib.pro
+++ /dev/null
@@ -1,31 +0,0 @@
---- lib/lib.pro.orig 2020-03-08 17:03:52 UTC
-+++ lib/lib.pro
-@@ -136,9 +136,13 @@ SOURCES += \
- src/mind/ai/autolinking/naive_autolinking_preprocessor.cpp \
- src/representations/markdown/cmark_gfm_markdown_transcoder.cpp \
- src/mind/ai/autolinking/autolinking_mind.cpp \
-- src/mind/ai/autolinking/cmark_aho_corasick_block_autolinking_preprocessor.cpp \
- src/mind/limbo.cpp
-
-+!mfnomd2html {
-+ SOURCES += \
-+ src/mind/ai/autolinking/cmark_aho_corasick_block_autolinking_preprocessor.cpp
-+}
-+
- mfner {
- SOURCES += \
- src/mind/ai/nlp/named_entity_recognition.cpp \
-@@ -256,8 +260,12 @@ HEADERS += \
- src/config/config.h \
- src/representations/markdown/cmark_gfm_markdown_transcoder.h \
- src/mind/ai/autolinking/autolinking_mind.h \
-- src/mind/ai/autolinking/cmark_aho_corasick_block_autolinking_preprocessor.h \
- src/mind/limbo.h
-+
-+!mfnomd2html {
-+ HEADERS += \
-+ src/mind/ai/autolinking/cmark_aho_corasick_block_autolinking_preprocessor.h
-+}
-
- mfner {
- HEADERS += \
diff --git a/deskutils/mindforger/files/patch-lib_src_mind_ai_autolinking_naive__autolinking__preprocessor.cpp b/deskutils/mindforger/files/patch-lib_src_mind_ai_autolinking_naive__autolinking__preprocessor.cpp
deleted file mode 100644
index c71c909f5a64..000000000000
--- a/deskutils/mindforger/files/patch-lib_src_mind_ai_autolinking_naive__autolinking__preprocessor.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
---- lib/src/mind/ai/autolinking/naive_autolinking_preprocessor.cpp.orig 2020-03-08 17:03:52 UTC
-+++ lib/src/mind/ai/autolinking/naive_autolinking_preprocessor.cpp
-@@ -60,6 +60,11 @@ bool NaiveAutolinkingPreprocessor::containsLinkCodeMat
- return false;
- }
-
-+static bool aliasSizeComparator(const Thing* t1, const Thing* t2)
-+{
-+ return t1->getAutolinkingAlias().size() > t2->getAutolinkingAlias().size();
-+}
-+
- void NaiveAutolinkingPreprocessor::updateThingsIndex()
- {
- // IMPROVE update indices only if an O/N is modified (except writing read timestamps)
-@@ -145,7 +150,7 @@ void NaiveAutolinkingPreprocessor::process(const vecto
- // IMPROVE loop to be changed to Aho-Corasic trie
-
- // inject Os, then Ns
-- for(Thing* t:mind.autolink()->getThings()) {
-+ for(Thing* t:things) {
- size_t found;
- bool match, insensitiveMatch;
- string lowerAlias{};
diff --git a/deskutils/mindforger/files/patch-lib_src_mind_mind.cpp b/deskutils/mindforger/files/patch-lib_src_mind_mind.cpp
deleted file mode 100644
index 8fbd1b81fcde..000000000000
--- a/deskutils/mindforger/files/patch-lib_src_mind_mind.cpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- lib/src/mind/mind.cpp.orig 2020-03-08 17:03:52 UTC
-+++ lib/src/mind/mind.cpp
-@@ -43,7 +43,7 @@ Mind::Mind(Configuration &configuration)
- #ifdef MF_MD_2_HTML_CMARK
- autolinking{new AutolinkingMind{*this}},
- #else
-- autolinking{nullptr}
-+ autolinking{nullptr},
- #endif
- exclusiveMind{},
- timeScopeAspect{},
-@@ -279,7 +279,7 @@ bool Mind::autolinkFindLongestPrefixWord(std::string&
- {
- #ifdef MF_MD_2_HTML_CMARK
- return autolinking->findLongestPrefixWord(s, r);
--#elif
-+#else
- return false;
- #endif
- }
-@@ -1079,7 +1079,9 @@ void Mind::noteDemote(Note* note, Outline::Patch* patc
-
- void Mind::noteOnRename(const std::string& oldName, const std::string& newName)
- {
-+#ifdef MF_MD_2_HTML_CMARK
- autolinking->update(oldName, newName);
-+#endif
- }
-
- void Mind::onRemembering()