aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-05-30 14:28:40 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-05-30 14:34:45 +0000
commitee340a5981cbffb4f0334c33e2495cba10322eb3 (patch)
tree683acf1936f41490315322ee0e242ea6c8fcc3c7
parentd00f19675f28e63aefed456dc34eb415a3ac1c1b (diff)
downloadports-ee340a5981cbffb4f0334c33e2495cba10322eb3.tar.gz
ports-ee340a5981cbffb4f0334c33e2495cba10322eb3.zip
games/jumpy: mark BROKEN with unsigned char after ead5b0f5fcd7
error[E0308]: mismatched types --> cargo-crates/netdev-0.25.0/src/bpf/unix.rs:122:29 | 122 | iface.ifr_name[i] = c as i8; | ----------------- ^^^^^^^ expected `u8`, found `i8` | | | expected due to the type of this binding error[E0308]: mismatched types --> cargo-crates/netdev-0.25.0/src/interface/unix.rs:167:28 | 167 | let nlen: i8 = (*sa).sa_data[3]; | -- ^^^^^^^^^^^^^^^^ expected `i8`, found `u8` | | | expected due to this | help: you can convert a `u8` to an `i8` and panic if the converted value doesn't fit | 167 | let nlen: i8 = (*sa).sa_data[3].try_into().unwrap(); | ++++++++++++++++++++ error[E0308]: mismatched types --> cargo-crates/netdev-0.25.0/src/interface/unix.rs:168:28 | 168 | let alen: i8 = (*sa).sa_data[4]; | -- ^^^^^^^^^^^^^^^^ expected `i8`, found `u8` | | | expected due to this | help: you can convert a `u8` to an `i8` and panic if the converted value doesn't fit | 168 | let alen: i8 = (*sa).sa_data[4].try_into().unwrap(); | ++++++++++++++++++++ For more information about this error, try `rustc --explain E0308`. Reported by: pkg-fallout
-rw-r--r--games/jumpy/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/jumpy/Makefile b/games/jumpy/Makefile
index 070d5c208894..132349bf34da 100644
--- a/games/jumpy/Makefile
+++ b/games/jumpy/Makefile
@@ -12,6 +12,9 @@ LICENSE_COMB= multi
LICENSE_FILE_MIT= ${WRKSRC}/licenses/LICENSE-MIT
LICENSE_DISTFILES_CC-BY-NC-4.0= ${DISTNAME}${EXTRACT_SUFX}
+BROKEN_aarch64= need https://github.com/shellrow/netdev/pull/71
+BROKEN_armv7= need https://github.com/shellrow/netdev/pull/71
+
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libudev.so:devel/libudev-devd
RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-plugins \