aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-10-04 17:03:36 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-10-04 17:22:59 +0000
commitee7505c37fb104cb87243002f42fa9505d42924e (patch)
treecd0a2f2be95dd70e27d9b7ac955baf2c2dc45b67
parent3a52ab2dd381ec8a557015321567499b48dda3be (diff)
downloadports-ee7505c37fb104cb87243002f42fa9505d42924e.tar.gz
ports-ee7505c37fb104cb87243002f42fa9505d42924e.zip
security/py-netbox-secretstore: Add new port
With NetBox 3.0 the secrets are no longer managed by NetBox itself. This is the continuation of the secrets app. WWW: https://github.com/dansheps/netbox-secretstore
-rw-r--r--security/Makefile1
-rw-r--r--security/py-netbox-secretstore/Makefile25
-rw-r--r--security/py-netbox-secretstore/distinfo3
-rw-r--r--security/py-netbox-secretstore/files/pkg-message.in20
-rw-r--r--security/py-netbox-secretstore/pkg-descr4
5 files changed, 53 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ad8779c1e1e4..4d193e0074f1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -931,6 +931,7 @@
SUBDIR += py-mnemonic
SUBDIR += py-msoffcrypto-tool
SUBDIR += py-muacrypt
+ SUBDIR += py-netbox-secretstore
SUBDIR += py-netmiko
SUBDIR += py-ntlm-auth
SUBDIR += py-oauth2client
diff --git a/security/py-netbox-secretstore/Makefile b/security/py-netbox-secretstore/Makefile
new file mode 100644
index 000000000000..98fa6207cc85
--- /dev/null
+++ b/security/py-netbox-secretstore/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= netbox-secretstore
+DISTVERSION= 1.0.8
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Secret store for NetBox
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= netbox>=3.0.0:net-mgmt/netbox \
+ ${PYTHON_PKGNAMEPREFIX}pycryptodome>0:security/py-pycryptodome@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netbox-plugin-extensions>0:net-mgmt/py-netbox-plugin-extensions@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+SUB_FILES= pkg-message
+SUB_LIST= PYTHON_VER=${PYTHON_VER}
+
+.include <bsd.port.mk>
diff --git a/security/py-netbox-secretstore/distinfo b/security/py-netbox-secretstore/distinfo
new file mode 100644
index 000000000000..fc54499f15ea
--- /dev/null
+++ b/security/py-netbox-secretstore/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633174085
+SHA256 (netbox-secretstore-1.0.8.tar.gz) = 48ce9a84846cab8b2f17be5fc36b221921ddedfa6e4ca49b0c089ea23bb4bb58
+SIZE (netbox-secretstore-1.0.8.tar.gz) = 46237
diff --git a/security/py-netbox-secretstore/files/pkg-message.in b/security/py-netbox-secretstore/files/pkg-message.in
new file mode 100644
index 000000000000..fa0bbe235174
--- /dev/null
+++ b/security/py-netbox-secretstore/files/pkg-message.in
@@ -0,0 +1,20 @@
+[
+{ type: install
+ message: <<EOD
+To enable the plugin please do the following steps:
+
+1. Add/update the following line in the netbox configuration (usually
+ %%LOCALBASE%%/share/netbox/netbox/configuration.py):
+
+ PLUGINS = ['netbox_secretstore']
+
+2. Run NetBox migrations and collect static files:
+
+ # cd %%LOCALBASE%%/share/netbox
+ # python%%PYTHON_VER%% manage.py migrate
+ # python%%PYTHON_VER%% manage.py collectstatic --no-input
+
+3. Restart WSGI/httpd environment (supervisord/apache/nginx/etc.)
+EOD
+}
+]
diff --git a/security/py-netbox-secretstore/pkg-descr b/security/py-netbox-secretstore/pkg-descr
new file mode 100644
index 000000000000..7b4b838f3ca6
--- /dev/null
+++ b/security/py-netbox-secretstore/pkg-descr
@@ -0,0 +1,4 @@
+With NetBox 3.0 the secrets are no longer managed by NetBox itself. This is
+the continuation of the secrets app.
+
+WWW: https://github.com/dansheps/netbox-secretstore