aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:58:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:58:16 +0000
commitef098521b38e6a98016425f0d8bd3029ef0f6533 (patch)
tree84d97ff899f36f82636c05facea7a4b833f11c07
parent65deee0449e417e9b3e9fdab3222646249de1646 (diff)
downloadports-ef098521b38e6a98016425f0d8bd3029ef0f6533.tar.gz
ports-ef098521b38e6a98016425f0d8bd3029ef0f6533.zip
devel/py-jaraco.timing: Convert to USE_PYTHON=pytest
-rw-r--r--devel/py-jaraco.timing/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/devel/py-jaraco.timing/Makefile b/devel/py-jaraco.timing/Makefile
index b22f405b6cd2..a1ae21bd721b 100644
--- a/devel/py-jaraco.timing/Makefile
+++ b/devel/py-jaraco.timing/Makefile
@@ -15,11 +15,10 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.15.0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco>=0:devel/py-jaraco@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tempora>=1.5:devel/py-tempora@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.5:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-flake8>=0:devel/py-pytest-flake8@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-flake8>=0:devel/py-pytest-flake8@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
@@ -33,7 +32,4 @@ post-install:
trim-jaraco-namespace:
@${REINPLACE_CMD} '/jaraco\/__init__\./d; /jaraco\/__pycache__\/__init__\./d' ${TMPPLIST}
-do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
-
.include <bsd.port.mk>