aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-04-14 15:44:51 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-04-14 15:52:19 +0000
commitef24a782a2a4f9dce3b37ecbbb6aa1f798cc96b3 (patch)
tree2ee166cfe4c993f3fe2ada0f6096440b64a0b1b7
parentfec4067ebfc6bf0ad48527e4698f27d67d7a9f78 (diff)
downloadports-ef24a782a2a4f9dce3b37ecbbb6aa1f798cc96b3.tar.gz
ports-ef24a782a2a4f9dce3b37ecbbb6aa1f798cc96b3.zip
textproc/aspell: fix a bad regexp after location specifier
PR: 253774
-rw-r--r--textproc/aspell/Makefile1
-rw-r--r--textproc/aspell/files/patch-configure6
-rw-r--r--textproc/aspell/files/patch-interfaces__cc__aspell.h8
-rw-r--r--textproc/aspell/files/patch-modules__speller__default__affix.cpp6
-rw-r--r--textproc/aspell/files/patch-modules_filter_modes_perl.amf11
-rw-r--r--textproc/aspell/files/patch-prog__aspell.cpp8
-rw-r--r--textproc/aspell/files/patch-prog__checker_string.cpp10
-rw-r--r--textproc/aspell/files/patch-prog__checker_string.hpp4
8 files changed, 33 insertions, 21 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index e8b3ad1ae2ba..8d5eb089b5e2 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -2,6 +2,7 @@
PORTNAME= aspell
PORTVERSION= 0.60.8
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc
MASTER_SITES= GNU/aspell
diff --git a/textproc/aspell/files/patch-configure b/textproc/aspell/files/patch-configure
index bc76a92d3af9..af634ec94d2a 100644
--- a/textproc/aspell/files/patch-configure
+++ b/textproc/aspell/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-07-29 06:38:03 UTC
+--- configure.orig 2019-10-12 22:20:32 UTC
+++ configure
-@@ -18289,7 +18289,7 @@ _ACEOF
+@@ -18309,7 +18309,7 @@ _ACEOF
if ac_fn_cxx_try_link "$LINENO"; then :
CURSES_LIB=-lncurses
@@ -9,7 +9,7 @@
$as_echo "#define TERM_HEADER <ncurses/term.h>" >>confdefs.h
-@@ -18401,8 +18401,8 @@ $as_echo "#define TERM_HEADER <term.h>" >>confdefs.h
+@@ -18421,8 +18421,8 @@ $as_echo "#define TERM_HEADER <term.h>" >>confdefs.h
if test "$enable_wide_curses" != "no"
then
diff --git a/textproc/aspell/files/patch-interfaces__cc__aspell.h b/textproc/aspell/files/patch-interfaces__cc__aspell.h
index 08f34e68a879..2d425d7c9a0b 100644
--- a/textproc/aspell/files/patch-interfaces__cc__aspell.h
+++ b/textproc/aspell/files/patch-interfaces__cc__aspell.h
@@ -1,6 +1,6 @@
---- interfaces/cc/aspell.h.orig 2011-07-02 23:53:27.000000000 +0200
-+++ interfaces/cc/aspell.h 2014-02-11 22:40:16.000000000 +0100
-@@ -236,7 +236,7 @@
+--- interfaces/cc/aspell.h.orig 2019-10-12 22:20:26 UTC
++++ interfaces/cc/aspell.h
+@@ -245,7 +245,7 @@ void delete_aspell_can_have_error(struct AspellCanHave
/******************************** errors ********************************/
@@ -9,7 +9,7 @@
extern const struct AspellErrorInfo * const aerror_other;
extern const struct AspellErrorInfo * const aerror_operation_not_supported;
extern const struct AspellErrorInfo * const aerror_cant_copy;
-@@ -322,7 +322,7 @@
+@@ -331,7 +331,7 @@ extern const struct AspellErrorInfo * const aerror_m
extern const struct AspellErrorInfo * const aerror_bad_magic;
extern const struct AspellErrorInfo * const aerror_expression;
extern const struct AspellErrorInfo * const aerror_invalid_expression;
diff --git a/textproc/aspell/files/patch-modules__speller__default__affix.cpp b/textproc/aspell/files/patch-modules__speller__default__affix.cpp
index 4959b4089f72..f36093c08244 100644
--- a/textproc/aspell/files/patch-modules__speller__default__affix.cpp
+++ b/textproc/aspell/files/patch-modules__speller__default__affix.cpp
@@ -1,6 +1,6 @@
---- modules/speller/default/affix.cpp.orig 2012-01-25 19:46:47.684690459 +0200
-+++ modules/speller/default/affix.cpp 2012-01-25 19:46:56.385691084 +0200
-@@ -796,7 +796,10 @@ bool AffixMgr::suffix_check (const Looku
+--- modules/speller/default/affix.cpp.orig 2019-10-08 00:15:21 UTC
++++ modules/speller/default/affix.cpp
+@@ -798,7 +798,10 @@ bool AffixMgr::suffix_check (const LookupInfo & linf,
if (se->check(linf, word, ci, gi, sfxopts, ppfx)) return true;
se = se->next;
}
diff --git a/textproc/aspell/files/patch-modules_filter_modes_perl.amf b/textproc/aspell/files/patch-modules_filter_modes_perl.amf
new file mode 100644
index 000000000000..d3e3290752f1
--- /dev/null
+++ b/textproc/aspell/files/patch-modules_filter_modes_perl.amf
@@ -0,0 +1,11 @@
+--- modules/filter/modes/perl.amf.orig 2019-10-08 00:15:21 UTC
++++ modules/filter/modes/perl.amf
+@@ -2,7 +2,7 @@ MODE perl
+
+ ASPELL >=0.60.1
+
+-MAGIC /0:256:^[ \t]*\#!((\/\w*)+)\/perl/pl/pm
++MAGIC /0:256:^[ \t]*\#!((\/[[:alnum:]_]*)+)\/perl/pl/pm
+ MAGIC /<noregex>/pl/pm
+
+ DESCRIPTION mode for checking Perl comments and string literals
diff --git a/textproc/aspell/files/patch-prog__aspell.cpp b/textproc/aspell/files/patch-prog__aspell.cpp
index 0425babf35dc..882a8fb43231 100644
--- a/textproc/aspell/files/patch-prog__aspell.cpp
+++ b/textproc/aspell/files/patch-prog__aspell.cpp
@@ -1,5 +1,5 @@
---- prog/aspell.cpp.orig 2011-07-04 11:13:58.000000000 +0200
-+++ prog/aspell.cpp 2014-02-11 22:42:04.000000000 +0100
+--- prog/aspell.cpp.orig 2019-10-08 00:15:21 UTC
++++ prog/aspell.cpp
@@ -25,6 +25,7 @@
# include <langinfo.h>
#endif
@@ -7,8 +7,8 @@
+#include "errors.hpp"
#include "aspell.h"
- #ifdef USE_FILE_INO
-@@ -40,7 +41,6 @@
+ #include <sys/types.h>
+@@ -41,7 +42,6 @@
#include "convert.hpp"
#include "document_checker.hpp"
#include "enumeration.hpp"
diff --git a/textproc/aspell/files/patch-prog__checker_string.cpp b/textproc/aspell/files/patch-prog__checker_string.cpp
index 1a2c186186b0..962fc0ea2cb0 100644
--- a/textproc/aspell/files/patch-prog__checker_string.cpp
+++ b/textproc/aspell/files/patch-prog__checker_string.cpp
@@ -1,8 +1,8 @@
---- prog/checker_string.cpp.orig Thu Jul 17 19:39:02 2003
-+++ prog/checker_string.cpp Thu Jul 17 19:39:09 2003
-@@ -4,6 +4,7 @@
- // license along with this library if you did not you can find
- // it at http://www.gnu.org/.
+--- prog/checker_string.cpp.orig 2019-10-08 00:15:21 UTC
++++ prog/checker_string.cpp
+@@ -6,6 +6,7 @@
+
+ #include <assert.h>
+#include <assert.h>
#include "checker_string.hpp"
diff --git a/textproc/aspell/files/patch-prog__checker_string.hpp b/textproc/aspell/files/patch-prog__checker_string.hpp
index b202f5f26d76..b5fb3ae0bc5c 100644
--- a/textproc/aspell/files/patch-prog__checker_string.hpp
+++ b/textproc/aspell/files/patch-prog__checker_string.hpp
@@ -1,5 +1,5 @@
---- prog/hecker_string.hpp.orig 2011-07-02 23:09:09.000000000 +0200
-+++ prog/checker_string.hpp 2014-02-11 22:42:24.000000000 +0100
+--- prog/checker_string.hpp.orig 2019-10-08 00:15:21 UTC
++++ prog/checker_string.hpp
@@ -6,6 +6,7 @@
#include <stdio.h>