aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-04 16:19:31 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-04 16:21:45 +0000
commitefc656517495adffd7398d02ed01455f32bdf3b9 (patch)
tree8487c599fe54770770f9e5baeb4c5116bc2a472d
parentbd8b68e6415a3671c144baa10871ef3f19f26eab (diff)
downloadports-efc656517495adffd7398d02ed01455f32bdf3b9.tar.gz
ports-efc656517495adffd7398d02ed01455f32bdf3b9.zip
biology/hhsuite: Fix build on some architectures
... by removing -march=native. Reported by: fallout
-rw-r--r--biology/hhsuite/files/patch-src_CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/biology/hhsuite/files/patch-src_CMakeLists.txt b/biology/hhsuite/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..a073eb7f342c
--- /dev/null
+++ b/biology/hhsuite/files/patch-src_CMakeLists.txt
@@ -0,0 +1,32 @@
+- remove -mcpu=native based on fallout messages from armv7
+
+--- src/CMakeLists.txt.orig 2022-08-04 16:05:31 UTC
++++ src/CMakeLists.txt
+@@ -53,17 +53,17 @@ if (NATIVE_ARCH AND (ARCH_FLAGS STREQUAL ""))
+ message(WARNING "At least SSE4.1 is needed for best performance")
+ endif ()
+ # clang has a problem with march=native on travis
+- if (CMAKE_CXX_COMPILER_ID MATCHES "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS "4.0.0")
+- set(ARCH_FLAGS "${SSE_FLAGS}")
+- else()
+- set(ARCH_FLAGS "-march=native")
+- endif()
++ #if (CMAKE_CXX_COMPILER_ID MATCHES "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS "4.0.0")
++ # set(ARCH_FLAGS "${SSE_FLAGS}")
++ #else()
++ # set(ARCH_FLAGS "-march=native")
++ #endif()
+ else ()
+- if (PPC64)
+- set(ARCH_FLAGS "-mcpu=native")
+- else ()
+- set(ARCH_FLAGS "-march=native")
+- endif ()
++ #if (PPC64)
++ # set(ARCH_FLAGS "-mcpu=native")
++ #else ()
++ # set(ARCH_FLAGS "-march=native")
++ #endif ()
+ endif ()
+ endif ()
+