aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-02-08 00:59:10 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-02-11 11:48:40 +0000
commitf00cad86d8d4463f94e8dc470c297a4ea69c73a2 (patch)
tree867d0d9efb0ded181c9561bf93864e300d442c3c
parentac4a6deabab2ced1623f9d031dc7201283533d76 (diff)
downloadports-f00cad86d8d4463f94e8dc470c297a4ea69c73a2.tar.gz
ports-f00cad86d8d4463f94e8dc470c297a4ea69c73a2.zip
net/py-zope.proxy: fix build on 32-bits
src/zope/proxy/_zope_proxy_proxy.c:887:5: error: incompatible function pointer types initializing 'hashfunc' (aka 'int (*)(struct _object *)') with an expression of type 'long (PyObject *)' (aka 'long (struct _object *)') [-Wincompatible-function-pointer-types]
-rw-r--r--net/py-zope.proxy/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/net/py-zope.proxy/Makefile b/net/py-zope.proxy/Makefile
index 3a3e7db0b0c9..cafb5221f210 100644
--- a/net/py-zope.proxy/Makefile
+++ b/net/py-zope.proxy/Makefile
@@ -16,4 +16,6 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.3.0:devel/py-zope.interf
USES= python
USE_PYTHON= distutils autoplist
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+
.include <bsd.port.mk>