aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-25 07:41:11 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-25 07:55:36 +0000
commitf0362bb2196823d9d009c731b75beb627f185f0b (patch)
treee11ed1e7939c5733ef694fcac50af86a5fcbcf94
parent6f9bdce5b94612e0589f10679c7d5f8b9b987d27 (diff)
downloadports-f0362bb2196823d9d009c731b75beb627f185f0b.tar.gz
ports-f0362bb2196823d9d009c731b75beb627f185f0b.zip
www/lzr: New port: Fast Go application scanner
-rw-r--r--www/Makefile1
-rw-r--r--www/lzr/Makefile28
-rw-r--r--www/lzr/distinfo13
-rw-r--r--www/lzr/pkg-descr4
4 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e8682eecfb61..6a52248091dc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -323,6 +323,7 @@
SUBDIR += lychee
SUBDIR += lynx
SUBDIR += lynx-current
+ SUBDIR += lzr
SUBDIR += madsonic
SUBDIR += man2web
SUBDIR += mathjax
diff --git a/www/lzr/Makefile b/www/lzr/Makefile
new file mode 100644
index 000000000000..cf3a2bdc7176
--- /dev/null
+++ b/www/lzr/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= lzr
+DISTVERSIONPREFIX= v
+DISTVERSION= 1
+CATEGORIES= www
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast Go application scanner
+WWW= https://github.com/stanford-esrg/lzr
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= stanford-esrg
+GH_TUPLE= \
+ go-check:check:10cb98267c6c:go_check_check/vendor/gopkg.in/check.v1 \
+ go-mgo:mgo:a6b53ec6cb22:go_mgo_mgo/vendor/gopkg.in/mgo.v2 \
+ go-yaml:yaml:v2.4.0:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
+ golang:sys:97732733099d:golang_sys/vendor/golang.org/x/sys \
+ google:gopacket:v1.1.19:google_gopacket/vendor/github.com/google/gopacket
+
+GO_TARGET= ./cmd/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/www/lzr/distinfo b/www/lzr/distinfo
new file mode 100644
index 000000000000..3642eb412c61
--- /dev/null
+++ b/www/lzr/distinfo
@@ -0,0 +1,13 @@
+TIMESTAMP = 1687677007
+SHA256 (stanford-esrg-lzr-v1_GH0.tar.gz) = bf76f8e05b031705871429c783f2eec3a70b2982918f219046d787b24cc34340
+SIZE (stanford-esrg-lzr-v1_GH0.tar.gz) = 578065
+SHA256 (go-check-check-10cb98267c6c_GH0.tar.gz) = 0a42d9d5a49ebc30174e5840238e446f5fb16899bfaa6a6f63d12ab9953df293
+SIZE (go-check-check-10cb98267c6c_GH0.tar.gz) = 32375
+SHA256 (go-mgo-mgo-a6b53ec6cb22_GH0.tar.gz) = e3373369ed1eefc88cb2ee55fa8fcb30c988b6979eaf6db0889d1520b83f302c
+SIZE (go-mgo-mgo-a6b53ec6cb22_GH0.tar.gz) = 376779
+SHA256 (go-yaml-yaml-v2.4.0_GH0.tar.gz) = d8e94679e5fff6bd1a35e10241543929a5f3da44f701755babf99b3daf0faac0
+SIZE (go-yaml-yaml-v2.4.0_GH0.tar.gz) = 73209
+SHA256 (golang-sys-97732733099d_GH0.tar.gz) = 8d60fa6ab0c2b099f2c7d6f8c0a5df177c5c524183a2a38e0e8d2d18cde53532
+SIZE (golang-sys-97732733099d_GH0.tar.gz) = 1350239
+SHA256 (google-gopacket-v1.1.19_GH0.tar.gz) = 31efa87cc9d2b41e5e66c7daa8839d841d2a43cc477bf595c9e8c24ef6903830
+SIZE (google-gopacket-v1.1.19_GH0.tar.gz) = 950745
diff --git a/www/lzr/pkg-descr b/www/lzr/pkg-descr
new file mode 100644
index 000000000000..7c60250518f2
--- /dev/null
+++ b/www/lzr/pkg-descr
@@ -0,0 +1,4 @@
+LZR quickly detects and fingerprints unexpected services running on unexpected
+ports by working with ZMap. LZR can detect up to 18 unique protocols
+simultaneously with just two extra packets and can fingerprint over 35 different
+protocols.