aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-08-21 14:15:28 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-08-21 14:24:21 +0000
commitf0f84332284139c74b5ec914154ef0ef6650beb3 (patch)
tree4cb3a135f698c7513b3289c2e048430e0debe8e8
parent3b2ff2ef194c83835fe7dc6618427b8fd50ea31d (diff)
downloadports-f0f84332284139c74b5ec914154ef0ef6650beb3.tar.gz
ports-f0f84332284139c74b5ec914154ef0ef6650beb3.zip
*/*: Move consumers of audio/ebur128 to USES=ebur128
PR: 272843
-rw-r--r--audio/cantata/Makefile2
-rw-r--r--audio/mixxx/Makefile5
-rw-r--r--audio/mixxx22/Makefile3
-rw-r--r--audio/rsgain/Makefile5
-rw-r--r--multimedia/mlt7/Makefile4
5 files changed, 8 insertions, 11 deletions
diff --git a/audio/cantata/Makefile b/audio/cantata/Makefile
index 78a740a8cf5b..d6648501a221 100644
--- a/audio/cantata/Makefile
+++ b/audio/cantata/Makefile
@@ -94,7 +94,7 @@ VLC_CMAKE_BOOL= ENABLE_LIBVLC
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MFFMPEG} || ${PORT_OPTIONS:MMPG123}
-LIB_DEPENDS+= libebur128.so:audio/ebur128
+USES+= ebur128
PLIST_SUB+= REPLAYGAIN=""
.else
PLIST_SUB+= REPLAYGAIN="@comment "
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index 01ba6517621b..613aa71d7b3d 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
libmodplug.so:audio/libmodplug \
libportaudio.so:audio/portaudio \
libSoundTouch.so:audio/soundtouch \
- libebur128.so:audio/ebur128 \
librubberband.so:audio/rubberband \
libsndfile.so:audio/libsndfile \
libogg.so:audio/libogg \
@@ -33,8 +32,8 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
libkeyfinder.so:audio/libkeyfinder \
libmp3lame.so:audio/lame
-USES= cmake compiler:c++11-lang gl iconv ninja qt:5 pkgconfig sqlite \
- ssl xorg
+USES= cmake compiler:c++11-lang ebur128 gl iconv ninja qt:5 pkgconfig \
+ sqlite ssl xorg
USE_XORG= ice sm x11 xext
USE_GL= gl glu
USE_GITHUB= yes
diff --git a/audio/mixxx22/Makefile b/audio/mixxx22/Makefile
index 7fbf676c1f21..86b659498773 100644
--- a/audio/mixxx22/Makefile
+++ b/audio/mixxx22/Makefile
@@ -24,7 +24,6 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
libmodplug.so:audio/libmodplug \
libportaudio.so:audio/portaudio \
libSoundTouch.so:audio/soundtouch \
- libebur128.so:audio/ebur128 \
librubberband.so:audio/rubberband \
libsndfile.so:audio/libsndfile \
libvamp-sdk.so:audio/vamp-plugin-sdk \
@@ -34,7 +33,7 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
libprotobuf.so:devel/protobuf \
liblilv-0.so:audio/lilv
-USES= compiler:c++11-lang gl iconv qt:5 pkgconfig scons xorg
+USES= compiler:c++11-lang ebur128 gl iconv qt:5 pkgconfig scons xorg
USE_XORG= x11
USE_GL= gl glu
USE_GITHUB= yes
diff --git a/audio/rsgain/Makefile b/audio/rsgain/Makefile
index 1ecf33140f36..2be6aa713942 100644
--- a/audio/rsgain/Makefile
+++ b/audio/rsgain/Makefile
@@ -12,13 +12,12 @@ WWW= https://github.com/complexlogic/rsgain
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libebur128.so:audio/ebur128 \
- libtag.so:audio/taglib \
+LIB_DEPENDS= libtag.so:audio/taglib \
libfmt.so:devel/libfmt \
libinih.so:devel/inih \
libavcodec.so:multimedia/ffmpeg
-USES= cmake compiler:c++2b-lang pkgconfig tar:xz
+USES= cmake compiler:c++2b-lang ebur128 pkgconfig tar:xz
CMAKE_ARGS= -DMAXPROGBARWIDTH=80
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
diff --git a/multimedia/mlt7/Makefile b/multimedia/mlt7/Makefile
index b79bd303be1b..5b3103533bd5 100644
--- a/multimedia/mlt7/Makefile
+++ b/multimedia/mlt7/Makefile
@@ -106,8 +106,8 @@ PLUSGPL_DESC= Enable plus GPL module
PLUSGPL_CMAKE_BOOL= MOD_PLUSGPL
PLUS_DESC= Enable plus module
-PLUS_LIB_DEPENDS= libebur128.so:audio/ebur128 \
- libfftw3.so:math/fftw3
+PLUS_USES= ebur128
+PLUS_LIB_DEPENDS= libfftw3.so:math/fftw3
PLUS_CMAKE_BOOL= MOD_PLUS
RESAMPLE_DESC= Enable resample module