aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2024-01-31 17:30:24 +0000
committerDimitry Andric <dim@FreeBSD.org>2024-01-31 18:44:44 +0000
commitf12119e85f5ac711d5a4537687fd924bfaca7692 (patch)
tree2f57e15248fae58aaf6e8df21ff715374ce66cc7
parent0faf1c226014f99d01cd98f525cffb633a9c0b07 (diff)
downloadports-f12119e85f5ac711d5a4537687fd924bfaca7692.tar.gz
ports-f12119e85f5ac711d5a4537687fd924bfaca7692.zip
archivers/arj: fix build with clang 18
Clang 18 no longer accepts -export-dynamic, which is a linker option, resulting in an error building archivers/arj: cc: error: unknown argument: '-export-dynamic' Fix this by using the correct spelling, -Wl,--export-dynamic. PR: 276747 Approved by: garga (maintainer) MFH: 2024Q1
-rw-r--r--archivers/arj/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/archivers/arj/Makefile b/archivers/arj/Makefile
index b3ac16992d56..babaeae0ee45 100644
--- a/archivers/arj/Makefile
+++ b/archivers/arj/Makefile
@@ -1,6 +1,6 @@
PORTNAME= arj
PORTVERSION= 3.10.22
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= archivers
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.78_3.10%20build%2022:source \
DEBIAN_POOL:patch
@@ -61,6 +61,7 @@ post-patch:
${WRKSRC}/arj.c ${WRKSRC}/file_reg.c ${WRKSRC}/rearj.c
@${REINPLACE_CMD} -e 's!-O2!!' -e 's!ALIGN_POINTERS!&,1,desc!' \
-e 's!USE_COLORS!&,1,desc!' -e '/LD_STRIP=/d' \
+ -e 's|-export-dynamic|-Wl,--export-dynamic|' \
${WRKSRC}/gnu/configure.in
@${REINPLACE_CMD} -e 's!^static !!' ${WRKSRC}/integr.c