aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2021-04-24 14:09:54 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2021-04-24 14:09:54 +0000
commitf12a8326669336f899ef689304ffa0c0d72730b9 (patch)
tree0701078c9ac61e4646b04a749d90c2e43102b9a0
parent67db7cdf822cfe765978f8cb0019387b42a42ebf (diff)
downloadports-f12a8326669336f899ef689304ffa0c0d72730b9.tar.gz
ports-f12a8326669336f899ef689304ffa0c0d72730b9.zip
games/devilutionX: update to 1.2.0
While here: - set version correctly with -DVERSION_NUM=${PORTVERSION} (cmake) - pet portclippy by using "_" prefix in local variable "MY_DEPENDS" Changes: https://github.com/diasurgical/devilutionX/releases/tag/1.2.0 Approved by: dbaio (mentor) Differential Revision: https://reviews.freebsd.org/D29638
-rw-r--r--games/devilutionX/Makefile11
-rw-r--r--games/devilutionX/distinfo6
-rw-r--r--games/devilutionX/files/patch-CMakeLists.txt19
-rw-r--r--games/devilutionX/files/patch-Packaging_fedora_devilutionx.desktop12
-rw-r--r--games/devilutionX/pkg-message8
5 files changed, 28 insertions, 28 deletions
diff --git a/games/devilutionX/Makefile b/games/devilutionX/Makefile
index 36c602483d93..a710316d5e4f 100644
--- a/games/devilutionX/Makefile
+++ b/games/devilutionX/Makefile
@@ -1,6 +1,5 @@
PORTNAME= devilutionX
-PORTVERSION= 1.1.0
-PORTREVISION= 2
+PORTVERSION= 1.2.0
CATEGORIES= games
MAINTAINER= eduardo@FreeBSD.org
@@ -9,10 +8,10 @@ COMMENT= Diablo I engine for modern operating systems
LICENSE= UNLICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-MY_DEPENDS= ${LOCALBASE}/share/fonts/CharisSIL/CharisSIL-B.ttf:x11-fonts/charis
-BUILD_DEPENDS= ${MY_DEPENDS}
+_MY_DEPENDS= ${LOCALBASE}/share/fonts/CharisSIL/CharisSIL-B.ttf:x11-fonts/charis
+BUILD_DEPENDS= ${_MY_DEPENDS}
LIB_DEPENDS= libsodium.so:security/libsodium
-RUN_DEPENDS= ${MY_DEPENDS}
+RUN_DEPENDS= ${_MY_DEPENDS}
USES= cmake compiler:c++11-lang dos2unix sdl
DOS2UNIX_GLOB= *.c *.h CMakeLists.txt
@@ -21,7 +20,7 @@ GH_ACCOUNT= diasurgical
USE_SDL= mixer2 sdl2 ttf2
CMAKE_ARGS= -DCMAKE_INSTALL_SHAREDIR:PATH=${PREFIX}/share \
- -DGIT_TAG=${PORTVERSION}
+ -DVERSION_NUM=${PORTVERSION}
.if defined(WITH_DEBUG)
CMAKE_ON= DEBUG
diff --git a/games/devilutionX/distinfo b/games/devilutionX/distinfo
index 198e2787aa51..c60e2a22b9d0 100644
--- a/games/devilutionX/distinfo
+++ b/games/devilutionX/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602752246
-SHA256 (diasurgical-devilutionX-1.1.0_GH0.tar.gz) = 395ec298df5383abe60550d45adba5e5811984589ccb1e504891b267b3c467c1
-SIZE (diasurgical-devilutionX-1.1.0_GH0.tar.gz) = 2271614
+TIMESTAMP = 1617862686
+SHA256 (diasurgical-devilutionX-1.2.0_GH0.tar.gz) = 63a06043b60a5866933eafcc078052e7f6a5878757c451fe74efb141b94386ac
+SIZE (diasurgical-devilutionX-1.2.0_GH0.tar.gz) = 3571940
diff --git a/games/devilutionX/files/patch-CMakeLists.txt b/games/devilutionX/files/patch-CMakeLists.txt
index 590e93bc369b..94b22747cbe4 100644
--- a/games/devilutionX/files/patch-CMakeLists.txt
+++ b/games/devilutionX/files/patch-CMakeLists.txt
@@ -1,23 +1,14 @@
---- CMakeLists.txt.orig 2020-10-15 09:55:17 UTC
+--- CMakeLists.txt.orig 2021-04-08 06:20:26 UTC
+++ CMakeLists.txt
-@@ -513,7 +513,7 @@ if(WIN32)
- endif()
- endif()
-
--if(NOT WIN32 AND NOT APPLE)
-+if(NOT WIN32 AND NOT APPLE AND NOT ${CMAKE_SYSTEM_NAME} STREQUAL FreeBSD)
- # Enable POSIX extensions such as `readlink` and `ftruncate`.
- add_definitions(-D_POSIX_C_SOURCE=200809L)
- endif()
-@@ -651,6 +651,11 @@ if(CPACK)
- set(CPACK_STRIP_FILES TRUE)
+@@ -873,6 +873,11 @@ if(CPACK)
set(CPACK_GENERATOR "DragNDrop")
endif()
-+
+
+install(TARGETS devilutionx DESTINATION ${CMAKE_INSTALL_BINDIR})
+install(FILES Packaging/fedora/devilutionx.desktop DESTINATION ${CMAKE_INSTALL_SHAREDIR}/applications)
+install(FILES Packaging/resources/icon.png DESTINATION ${CMAKE_INSTALL_SHAREDIR}/icons/hicolor/512x512/apps RENAME devilutionx.png)
+install(FILES Packaging/resources/icon_solid.png DESTINATION ${CMAKE_INSTALL_SHAREDIR}/icons/hicolor/512x512/apps RENAME devilutionx_solid.png)
-
++
set(CPACK_PACKAGE_VERSION_MAJOR ${PROJECT_VERSION_MAJOR})
set(CPACK_PACKAGE_VERSION_MINOR ${PROJECT_VERSION_MINOR})
+ set(CPACK_PACKAGE_VERSION_PATCH ${PROJECT_VERSION_PATCH})
diff --git a/games/devilutionX/files/patch-Packaging_fedora_devilutionx.desktop b/games/devilutionX/files/patch-Packaging_fedora_devilutionx.desktop
index 0b54575332f3..46627d9440d7 100644
--- a/games/devilutionX/files/patch-Packaging_fedora_devilutionx.desktop
+++ b/games/devilutionX/files/patch-Packaging_fedora_devilutionx.desktop
@@ -1,15 +1,17 @@
---- Packaging/fedora/devilutionx.desktop.orig 2020-10-10 22:26:16 UTC
+--- Packaging/fedora/devilutionx.desktop.orig 2021-04-06 05:51:05 UTC
+++ Packaging/fedora/devilutionx.desktop
-@@ -1,9 +1,9 @@
+@@ -1,10 +1,10 @@
[Desktop Entry]
- Name=devilutionx
+ Name=DevilutionX
GenericName=DevilutionX
-Comment=Play Diablo I on Linux
-Comment[da]=Spil Diablo I på Linux
-Comment[hr]=Igrajte Diablo I na Linuxu
-+Comment=Play Diablo I
+-Comment[it]=Gioca a Diablo I su Linux
++Comment=Play Diablo
+Comment[da]=Spil Diablo I
+Comment[hr]=Igrajte Diablo I
- Exec=devilutionx
++Comment[it]=Gioca a Diablo I
+ Exec=devilutionx --diablo
Icon=devilutionx
Terminal=false
diff --git a/games/devilutionX/pkg-message b/games/devilutionX/pkg-message
index 72524ec0f3a7..b084bb8cb89f 100644
--- a/games/devilutionX/pkg-message
+++ b/games/devilutionX/pkg-message
@@ -11,4 +11,12 @@ If you have any issues with this game, please file a bug report on the GitHub pa
https://github.com/diasurgical/devilutionX/issues
EOM
}
+{
+type: upgrade
+maximum_version: "1.1.0"
+ message: <<EOM
+Upgrading from before 1.1.0 needs to do remove ~/.local/share/diasurgical/devilution/diablo.ini
+so devilutionX runs correctly
+EOM
+}
]