aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroo Ono <hiroo.ono+freebsd@gmail.com>2023-07-26 07:19:56 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-07-27 06:26:48 +0000
commitf18837e70df5a500af574614840b0ea216d64e21 (patch)
treed0f9fd116ecea5df6789391d87d3596ed39895c8
parent55a4ea2ff3c7dc3846930df1fa3b534c8f9fe86b (diff)
downloadports-f18837e70df5a500af574614840b0ea216d64e21.tar.gz
ports-f18837e70df5a500af574614840b0ea216d64e21.zip
devel/mongo-c-driver: update to 1.24.2
ChangeLog: https://github.com/mongodb/mongo-c-driver/blob/1.24.2/NEWS PR: 272721 Reported by: hiroo.ono+freebsd@gmail.com Approved by: ports@bsdserwis.com (maintainer)
-rw-r--r--devel/mongo-c-driver/Makefile51
-rw-r--r--devel/mongo-c-driver/distinfo6
-rw-r--r--devel/mongo-c-driver/files/extra-patch-src_libmongoc_src_mongoc_mongoc-counters-private.h10
-rw-r--r--devel/mongo-c-driver/pkg-plist54
4 files changed, 75 insertions, 46 deletions
diff --git a/devel/mongo-c-driver/Makefile b/devel/mongo-c-driver/Makefile
index 7fe5ee7b24a9..e6753ad1f9fb 100644
--- a/devel/mongo-c-driver/Makefile
+++ b/devel/mongo-c-driver/Makefile
@@ -1,6 +1,5 @@
PORTNAME= mongo-c-driver
-DISTVERSION= 1.23.2
-PORTREVISION= 3
+DISTVERSION= 1.24.2
CATEGORIES= devel
MASTER_SITES= https://github.com/mongodb/${PORTNAME}/releases/download/${DISTVERSION}/
@@ -18,23 +17,30 @@ USES= cmake cpe pathfix pkgconfig python:env
CPE_VENDOR= mongodb
USE_LDCONFIG= yes
-CMAKE_ARGS= -DENABLE_BSON=SYSTEM \
- -DENABLE_ZLIB=SYSTEM
+CMAKE_ARGS= -DENABLE_ZLIB=SYSTEM
CMAKE_ON= ENABLE_MONGOC \
- ENABLE_ZSTD
+ ENABLE_ZSTD \
+ USE_SYSTEM_LIBBSON
CMAKE_OFF= BUILD_TESTING \
ENABLE_EXAMPLES \
ENABLE_TESTS \
ENABLE_UNINSTALL
-CFLAGS+= -D__BSD_VISIBLE=1
+# CFLAGS+= -D__BSD_VISIBLE=1
-OPTIONS_DEFINE= CRYPTOPROFILE DOCS ICU RDTSCP SASL SNAPPY SSL
+OPTIONS_DEFINE= CRYPTOPROFILE DOCS ICU MONGODBAWS RDTSCP SASL SNAPPY \
+ SRV SSL UTF8PROC ZSTD
OPTIONS_DEFAULT= SSL
OPTIONS_SUB= yes
CRYPTOPROFILE_DESC= Use system crypto profile (requires OpenSSL)
+MONGODBAWS_DESC= Enable support for the MONGODB-AWS authentication mechanism
RDTSCP_DESC= Fast performance counters on Intel using the RDTSCP instruction
+SRV_DESC= Enable support for mongodb+srv URIs
+UTF8PROC_DESC= SCRAM-SHA-256 authentication with non-ASCII passwords
+
+CRYPTOPROFILE_CMAKE_ON= -DENABLE_CRYPTO_SYSTEM_PROFILE=ON
+CRYPTOPROFILE_CMAKE_OFF= -DENABLE_CRYPTO_SYSTEM_PROFILE=OFF
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
DOCS_CMAKE_ON= -DENABLE_HTML_DOCS=ON -DENABLE_MAN_PAGES=ON
@@ -43,6 +49,9 @@ ICU_LIB_DEPENDS= libicudata.so:devel/icu
ICU_CMAKE_ON= -DENABLE_ICU=ON
ICU_CMAKE_OFF= -DENABLE_ICU=OFF
+MONGODBAWS_CMAKE_ON= -DENABLE_MONGODB_AWS_AUTH=ON
+MONGODBAWS_CMAKE_OFF= -DENABLE_MONGODB_AWS_AUTH=OFF
+
RDTSCP_CMAKE_ON= -DENABLE_RDTSCP=ON
RDTSCP_CMAKE_OFF= -DENABLE_RDTSCP=OFF
@@ -54,8 +63,18 @@ SNAPPY_LIB_DEPENDS= libsnappy.so:archivers/snappy
SNAPPY_CMAKE_ON= -DENABLE_SNAPPY=ON
SNAPPY_CMAKE_OFF= -DENABLE_SNAPPY=OFF
+SRV_CMAKE_ON= -DENABLE_SRV=ON
+SRV_CMAKE_OFF= -DENABLE_SRV=OFF
+
SSL_USES= ssl
-SSL_CMAKE_OFF= -DENABLE_SSL=OFF
+SSL_CMAKE_OFF= -DENABLE_SSL=OFF
+
+UTF8PROC_CMAKE_ON= -DUSE_BUNDLED_UTF8PROC=ON
+UTF8PROC_CMAKE_OFF= -DUSE_BUNDLED_UTF8PROC=OFF
+
+ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
+ZSTD_CMAKE_ON= -DENABLE_ZSTD=ON
+ZSTD_CMAKE_OFF= -DENABLE_ZSTD=OFF
.include <bsd.port.options.mk>
@@ -69,9 +88,9 @@ CFLAGS+= -DOPENSSL_API_COMPAT=0x30000000L"
.endif
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300523
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_libmongoc_src_mongoc_mongoc-counters-private.h
-.endif
+# .if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300523
+# EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_libmongoc_src_mongoc_mongoc-counters-private.h
+# .endif
pre-configure-CRYPTOPROFILE-on:
.if ${SSL_DEFAULT:Mlibressl*}
@@ -79,11 +98,13 @@ pre-configure-CRYPTOPROFILE-on:
@${FALSE}
.endif
+pre-configure-MONGODBAWS-on:
+.if !${PORT_OPTIONS:MSSL}
+ @${ECHO_MSG} "MONGODBAWS needs SSL."
+ @${FALSE}
+.endif
+
post-extract:
${ECHO} "${DISTVERSION}" > ${WRKSRC}/VERSION_CURRENT
-post-install:
- ${RM} -r ${STAGEDIR}${PREFIX}/share/${PORTNAME}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mongoc-stat
-
.include <bsd.port.mk>
diff --git a/devel/mongo-c-driver/distinfo b/devel/mongo-c-driver/distinfo
index 554191df12d5..7bf6a88a36a7 100644
--- a/devel/mongo-c-driver/distinfo
+++ b/devel/mongo-c-driver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1676629962
-SHA256 (mongo-c-driver-1.23.2.tar.gz) = 123c358827eea07cd76a31c40281bb1c81b6744f6587c96d0cf217be8b1234e3
-SIZE (mongo-c-driver-1.23.2.tar.gz) = 7781649
+TIMESTAMP = 1690287039
+SHA256 (mongo-c-driver-1.24.2.tar.gz) = 25813a220188d40140ca9c36a4b23abfb68fc7cbb37694187cc9852be470abd2
+SIZE (mongo-c-driver-1.24.2.tar.gz) = 8231535
diff --git a/devel/mongo-c-driver/files/extra-patch-src_libmongoc_src_mongoc_mongoc-counters-private.h b/devel/mongo-c-driver/files/extra-patch-src_libmongoc_src_mongoc_mongoc-counters-private.h
deleted file mode 100644
index a0e02f62e210..000000000000
--- a/devel/mongo-c-driver/files/extra-patch-src_libmongoc_src_mongoc_mongoc-counters-private.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/libmongoc/src/mongoc/mongoc-counters-private.h.orig 2023-01-03 15:52:22 UTC
-+++ src/libmongoc/src/mongoc/mongoc-counters-private.h
-@@ -28,6 +28,7 @@
- #include <sys/sysinfo.h>
- #elif defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__) || \
- defined(__OpenBSD__)
-+#include <sched.h>
- #include <sys/types.h>
- #include <sys/sysctl.h>
- #include <sys/param.h>
diff --git a/devel/mongo-c-driver/pkg-plist b/devel/mongo-c-driver/pkg-plist
index dc966ac5ea8a..9c77e8524dad 100644
--- a/devel/mongo-c-driver/pkg-plist
+++ b/devel/mongo-c-driver/pkg-plist
@@ -1,4 +1,3 @@
-bin/mongoc-stat
include/libmongoc-1.0/mongoc.h
include/libmongoc-1.0/mongoc/mongoc-apm.h
include/libmongoc-1.0/mongoc/mongoc-bulk-operation.h
@@ -95,9 +94,9 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/authentication.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/basic-troubleshooting.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/bulk.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/client-side-field-level-encryption.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/configuring_tls.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/connection-pooling.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/create-indexes.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/cursors.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/debugging.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/distinct-mapreduce.html
@@ -105,12 +104,13 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/full_index.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/gridfs.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/guides.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/in-use-encryption.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/init-cleanup.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/installing.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/lifecycle.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/logging.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/matcher.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/manage-collection-indexes.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc-common-task-examples.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_callbacks_destroy.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_callbacks_new.html
@@ -124,6 +124,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_failed_get_reply.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_failed_get_request_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_failed_get_server_connection_id.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_failed_get_server_connection_id_int64.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_failed_get_server_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_failed_get_service_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_failed_t.html
@@ -135,6 +136,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_started_get_operation_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_started_get_request_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_started_get_server_connection_id.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_started_get_server_connection_id_int64.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_started_get_server_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_started_get_service_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_started_t.html
@@ -146,6 +148,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_succeeded_get_reply.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_succeeded_get_request_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_succeeded_get_server_connection_id.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_succeeded_get_server_connection_id_int64.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_succeeded_get_server_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_succeeded_get_service_id.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_apm_command_succeeded_t.html
@@ -255,6 +258,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_enable_auto_encryption.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_add_key_alt_name.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_create_datakey.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_create_encrypted_collection.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_datakey_opts_destroy.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_datakey_opts_new.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_datakey_opts_set_keyaltnames.html
@@ -265,6 +269,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_delete_key.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_destroy.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_expression.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_opts_destroy.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_opts_new.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_opts_set_algorithm.html
@@ -272,7 +277,15 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_opts_set_keyaltname.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_opts_set_keyid.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_opts_set_query_type.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_opts_set_range_opts.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_opts_t.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_range_opts_destroy.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_range_opts_new.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_range_opts_set_max.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_range_opts_set_min.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_range_opts_set_precision.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_range_opts_set_sparsity.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_encrypt_range_opts_t.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_get_crypt_shared_version.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_get_key.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_encryption_get_key_by_alt_name.html
@@ -302,8 +315,6 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_get_default_database.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_get_gridfs.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_get_handshake_description.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_get_max_bson_size.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_get_max_message_size.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_get_read_concern.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_get_read_prefs.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_client_get_server_description.html
@@ -377,6 +388,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_collection_create_bulk_operation_with_opts.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_collection_create_index.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_collection_create_index_with_opts.html
+%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_collection_create_indexes_with_opts.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_collection_delete.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_collection_delete_many.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_collection_delete_one.html
@@ -563,10 +575,6 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_init.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_insert_flags_t.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_iovec_t.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_matcher_destroy.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_matcher_match.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_matcher_new.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_matcher_t.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_optional_copy.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_optional_init.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/mongoc_optional_is_set.html
@@ -779,7 +787,6 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/search.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/searchindex.js
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/tutorial.html
-%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/using_client_side_encryption.html
%%PORTDOCS%%%%DOCSDIR%%/mongo-c-driver/html/visual-studio-guide.html
%%PORTDOCS%%share/man/man3/mongoc_advanced_connections.3.gz
%%PORTDOCS%%share/man/man3/mongoc_aggregate.3.gz
@@ -795,6 +802,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_apm_command_failed_get_reply.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_failed_get_request_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_failed_get_server_connection_id.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_apm_command_failed_get_server_connection_id_int64.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_failed_get_server_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_failed_get_service_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_failed_t.3.gz
@@ -806,6 +814,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_apm_command_started_get_operation_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_started_get_request_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_started_get_server_connection_id.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_apm_command_started_get_server_connection_id_int64.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_started_get_server_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_started_get_service_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_started_t.3.gz
@@ -817,6 +826,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_apm_command_succeeded_get_reply.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_succeeded_get_request_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_succeeded_get_server_connection_id.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_apm_command_succeeded_get_server_connection_id_int64.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_succeeded_get_server_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_succeeded_get_service_id.3.gz
%%PORTDOCS%%share/man/man3/mongoc_apm_command_succeeded_t.3.gz
@@ -931,6 +941,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_client_enable_auto_encryption.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_add_key_alt_name.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_create_datakey.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_create_encrypted_collection.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_datakey_opts_destroy.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_datakey_opts_new.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_datakey_opts_set_keyaltnames.3.gz
@@ -940,6 +951,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_delete_key.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_destroy.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_expression.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_opts_destroy.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_opts_new.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_opts_set_algorithm.3.gz
@@ -947,7 +959,15 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_opts_set_keyaltname.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_opts_set_keyid.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_opts_set_query_type.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_opts_set_range_opts.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_opts_t.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_range_opts_destroy.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_range_opts_new.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_range_opts_set_max.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_range_opts_set_min.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_range_opts_set_precision.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_range_opts_set_sparsity.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_client_encryption_encrypt_range_opts_t.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_get_crypt_shared_version.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_get_key.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_encryption_get_key_by_alt_name.3.gz
@@ -977,8 +997,6 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_client_get_default_database.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_get_gridfs.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_get_handshake_description.3.gz
-%%PORTDOCS%%share/man/man3/mongoc_client_get_max_bson_size.3.gz
-%%PORTDOCS%%share/man/man3/mongoc_client_get_max_message_size.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_get_read_concern.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_get_read_prefs.3.gz
%%PORTDOCS%%share/man/man3/mongoc_client_get_server_description.3.gz
@@ -1052,6 +1070,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_collection_create_bulk_operation_with_opts.3.gz
%%PORTDOCS%%share/man/man3/mongoc_collection_create_index.3.gz
%%PORTDOCS%%share/man/man3/mongoc_collection_create_index_with_opts.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_collection_create_indexes_with_opts.3.gz
%%PORTDOCS%%share/man/man3/mongoc_collection_delete.3.gz
%%PORTDOCS%%share/man/man3/mongoc_collection_delete_many.3.gz
%%PORTDOCS%%share/man/man3/mongoc_collection_delete_one.3.gz
@@ -1099,7 +1118,6 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_common_task_examples.3.gz
%%PORTDOCS%%share/man/man3/mongoc_configuring_tls.3.gz
%%PORTDOCS%%share/man/man3/mongoc_connection_pooling.3.gz
-%%PORTDOCS%%share/man/man3/mongoc_create_indexes.3.gz
%%PORTDOCS%%share/man/man3/mongoc_cursor_clone.3.gz
%%PORTDOCS%%share/man/man3/mongoc_cursor_current.3.gz
%%PORTDOCS%%share/man/man3/mongoc_cursor_destroy.3.gz
@@ -1250,11 +1268,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_installing.3.gz
%%PORTDOCS%%share/man/man3/mongoc_iovec_t.3.gz
%%PORTDOCS%%share/man/man3/mongoc_logging.3.gz
-%%PORTDOCS%%share/man/man3/mongoc_matcher.3.gz
-%%PORTDOCS%%share/man/man3/mongoc_matcher_destroy.3.gz
-%%PORTDOCS%%share/man/man3/mongoc_matcher_match.3.gz
-%%PORTDOCS%%share/man/man3/mongoc_matcher_new.3.gz
-%%PORTDOCS%%share/man/man3/mongoc_matcher_t.3.gz
+%%PORTDOCS%%share/man/man3/mongoc_manage_collection_indexes.3.gz
%%PORTDOCS%%share/man/man3/mongoc_optional_copy.3.gz
%%PORTDOCS%%share/man/man3/mongoc_optional_init.3.gz
%%PORTDOCS%%share/man/man3/mongoc_optional_is_set.3.gz
@@ -1464,3 +1478,7 @@ libdata/pkgconfig/libmongoc-static-1.0.pc
%%PORTDOCS%%share/man/man3/mongoc_write_concern_set_wtimeout.3.gz
%%PORTDOCS%%share/man/man3/mongoc_write_concern_set_wtimeout_int64.3.gz
%%PORTDOCS%%share/man/man3/mongoc_write_concern_t.3.gz
+%%DATADIR%%/COPYING
+%%DATADIR%%/NEWS
+%%DATADIR%%/README.rst
+%%DATADIR%%/THIRD_PARTY_NOTICES