aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-04-24 10:03:53 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-04-24 11:17:19 +0000
commitf22cc511f32018c8342117e6a6bae7bcc98203c8 (patch)
tree65b21de6a25a6c9e87a3c56d713c5578045ef7d8
parent4c40e59d33927bdb88d5f685df11724e43e5b9fa (diff)
downloadports-f22cc511f32018c8342117e6a6bae7bcc98203c8.tar.gz
ports-f22cc511f32018c8342117e6a6bae7bcc98203c8.zip
emulators/rpcs3: unbreak on aarch64 after 66e5089f6d0d
Utilities/Thread.cpp:1794:51: error: no member named 'pc' in '__mcontext' const bool is_executing = uptr(info->si_addr) == RIP(context); ^~~~~~~~~~~~ Utilities/Thread.cpp:1795:62: error: no member named 'pc' in '__mcontext' const u32 insn = is_executing ? 0 : *reinterpret_cast<u32*>(RIP(context)); ^~~~~~~~~~~~ Utilities/Thread.cpp:1831:90: error: no member named 'pc' in '__mcontext' std::string msg = fmt::format("Segfault %s location %p at %p.\n", cause, info->si_addr, RIP(context)); ^~~~~~~~~~~~ Utilities/Thread.cpp:1225:46: note: expanded from macro 'RIP' #define RIP(context) ((context)->uc_mcontext.pc) ~~~~~~~~~~~~~~~~~~~~~~ ^ Reported by: pkg-fallout (cherry picked from commit 30f587d136d4960d7b214bda0046ff166d5fbaf4)
-rw-r--r--emulators/rpcs3/Makefile3
-rw-r--r--emulators/rpcs3/distinfo2
2 files changed, 5 insertions, 0 deletions
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index a44bf053b1bb..90fa2a22d306 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -4,6 +4,9 @@ DISTVERSION= 0.0.21-13400 # git rev-list --count HEAD
DISTVERSIONSUFFIX= -ge53bbd668b
CATEGORIES= emulators
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 41a05f95a057.patch:-p1 # https://github.com/RPCS3/rpcs3/pull/11868
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= PS3 emulator/debugger
diff --git a/emulators/rpcs3/distinfo b/emulators/rpcs3/distinfo
index b7adc4aa4527..e2a7cdd41fd1 100644
--- a/emulators/rpcs3/distinfo
+++ b/emulators/rpcs3/distinfo
@@ -23,3 +23,5 @@ SHA256 (wolfSSL-wolfssl-v5.2.0-stable-245-gdcaa218ed_GH0.tar.gz) = d5d9d916797dc
SIZE (wolfSSL-wolfssl-v5.2.0-stable-245-gdcaa218ed_GH0.tar.gz) = 20570430
SHA256 (llvm-llvm-project-llvmorg-13.0.1-rc1_GH0.tar.gz) = c9411f1882eaf0c190fd5b412deb0bd7dba61a48df243d3408298cc6f53b6921
SIZE (llvm-llvm-project-llvmorg-13.0.1-rc1_GH0.tar.gz) = 147284646
+SHA256 (41a05f95a057.patch) = 9c67561682211462f9a73069dae54f0c955dafeba69021b44c724423ce2788ef
+SIZE (41a05f95a057.patch) = 1972