aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-05-03 02:51:49 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-05-03 03:29:51 +0000
commitf247211eb747992e0c483dbf02452596d16a7378 (patch)
tree9c84c0c020d56c1cc0f462f336fce01f8bf82dba
parenta3809705cad875bbdafd7aa59fa988220e34c073 (diff)
downloadports-f247211eb747992e0c483dbf02452596d16a7378.tar.gz
ports-f247211eb747992e0c483dbf02452596d16a7378.zip
security/gpgme-qt: Flavorize for new Qt6 bindings
Rename security/gpgme-qt5 to security/gpgme-qt and flavorize to allow building qt5 and qt6 flavors. Adjust dependencies and bump PORTREVISION on consumers. Fix installation of optional Doxgen docs.
-rw-r--r--MOVED1
-rw-r--r--deskutils/akonadi-import-wizard/Makefile4
-rw-r--r--deskutils/akonadiconsole/Makefile4
-rw-r--r--deskutils/akregator/Makefile4
-rw-r--r--deskutils/grantlee-editor/Makefile4
-rw-r--r--deskutils/kaddressbook/Makefile4
-rw-r--r--deskutils/kdepim-addons/Makefile4
-rw-r--r--deskutils/kmail-account-wizard/Makefile4
-rw-r--r--deskutils/kmail/Makefile4
-rw-r--r--deskutils/mbox-importer/Makefile4
-rw-r--r--deskutils/pim-data-exporter/Makefile4
-rw-r--r--net/akonadi-contacts/Makefile4
-rw-r--r--net/kget/Makefile4
-rw-r--r--net/mailcommon/Makefile4
-rw-r--r--net/messagelib/Makefile4
-rw-r--r--security/Makefile2
-rw-r--r--security/gpgme-qt/Makefile (renamed from security/gpgme-qt5/Makefile)10
-rw-r--r--security/gpgme-qt/pkg-plist.qt5 (renamed from security/gpgme-qt5/pkg-plist)0
-rw-r--r--security/gpgme-qt/pkg-plist.qt6105
-rw-r--r--security/gpgme/Makefile29
-rw-r--r--security/kleopatra/Makefile4
-rw-r--r--security/libkleo/Makefile4
-rw-r--r--sysutils/kf5-kwallet/Makefile4
-rw-r--r--sysutils/plasma-pass/Makefile4
24 files changed, 173 insertions, 46 deletions
diff --git a/MOVED b/MOVED
index 88b2fb8ad5fe..37b6d7c68db6 100644
--- a/MOVED
+++ b/MOVED
@@ -12752,3 +12752,4 @@ databases/rocksdb-lite||2023-04-30|Has expired: Removed by upstream, see https:/
textproc/ltxml||2023-04-30|Has expired: Unfetchable
graphics/ImageMagick7-nox11|graphics/ImageMagick7|2023-04-30|Flavorized
graphics/ImageMagick6-nox11|graphics/ImageMagick6|2023-04-30|Flavorized
+security/gpgme-qt5|security/gpgme-qt@qt5|2023-05-02|Flavorized to add Qt6 support
diff --git a/deskutils/akonadi-import-wizard/Makefile b/deskutils/akonadi-import-wizard/Makefile
index 32fe87538e4e..784f5d325ea5 100644
--- a/deskutils/akonadi-import-wizard/Makefile
+++ b/deskutils/akonadi-import-wizard/Makefile
@@ -1,6 +1,6 @@
PORTNAME= akonadi-import-wizard
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +11,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5 \
+ libqgpgme.so:security/gpgme-qt@qt5 \
libqt5keychain.so:security/qtkeychain@qt5
USES= cmake compiler:c++11-lib gettext grantlee:5 kde:5 qt:5 tar:xz
diff --git a/deskutils/akonadiconsole/Makefile b/deskutils/akonadiconsole/Makefile
index 12e4ae2fd4c6..2c021486b461 100644
--- a/deskutils/akonadiconsole/Makefile
+++ b/deskutils/akonadiconsole/Makefile
@@ -1,6 +1,6 @@
PORTNAME= akonadiconsole
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +13,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5 \
+ libqgpgme.so:security/gpgme-qt@qt5 \
libical.so:devel/libical \
libxapian.so:databases/xapian-core
diff --git a/deskutils/akregator/Makefile b/deskutils/akregator/Makefile
index ec0ad47a2de5..d2b127ef1a88 100644
--- a/deskutils/akregator/Makefile
+++ b/deskutils/akregator/Makefile
@@ -1,6 +1,6 @@
PORTNAME= akregator
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +13,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib desktop-file-utils gettext grantlee:5 \
kde:5 qt:5 tar:xz xorg
diff --git a/deskutils/grantlee-editor/Makefile b/deskutils/grantlee-editor/Makefile
index 9c967d63f855..4133c86986f5 100644
--- a/deskutils/grantlee-editor/Makefile
+++ b/deskutils/grantlee-editor/Makefile
@@ -1,6 +1,6 @@
PORTNAME= grantlee-editor
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +13,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib gettext grantlee:5 \
kde:5 qt:5 tar:xz xorg
diff --git a/deskutils/kaddressbook/Makefile b/deskutils/kaddressbook/Makefile
index a5f5aceea2bf..be2b1e5e41e7 100644
--- a/deskutils/kaddressbook/Makefile
+++ b/deskutils/kaddressbook/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kaddressbook
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +11,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib desktop-file-utils gettext grantlee:5 kde:5 \
qt:5 tar:xz xorg
diff --git a/deskutils/kdepim-addons/Makefile b/deskutils/kdepim-addons/Makefile
index 6f493544722e..b5f45a09bc83 100644
--- a/deskutils/kdepim-addons/Makefile
+++ b/deskutils/kdepim-addons/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kdepim-addons
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -15,7 +15,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib gettext grantlee:5 kde:5 \
pkgconfig qt:5 tar:xz xorg
diff --git a/deskutils/kmail-account-wizard/Makefile b/deskutils/kmail-account-wizard/Makefile
index ccc1dcd59fe8..d413af1d97e4 100644
--- a/deskutils/kmail-account-wizard/Makefile
+++ b/deskutils/kmail-account-wizard/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kmail-account-wizard
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +11,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib desktop-file-utils gettext gl kde:5 \
qt:5 shared-mime-info tar:xz
diff --git a/deskutils/kmail/Makefile b/deskutils/kmail/Makefile
index e57f92def651..f3d0bb5f25d7 100644
--- a/deskutils/kmail/Makefile
+++ b/deskutils/kmail/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kmail
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +13,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5 \
+ libqgpgme.so:security/gpgme-qt@qt5 \
libqt5keychain.so:security/qtkeychain@qt5
RUN_DEPENDS= accountwizard:deskutils/kmail-account-wizard \
diff --git a/deskutils/mbox-importer/Makefile b/deskutils/mbox-importer/Makefile
index 562c0cfd04ad..c5c9dc31865c 100644
--- a/deskutils/mbox-importer/Makefile
+++ b/deskutils/mbox-importer/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mbox-importer
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +11,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib desktop-file-utils gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth codecs completion config configwidgets coreaddons \
diff --git a/deskutils/pim-data-exporter/Makefile b/deskutils/pim-data-exporter/Makefile
index a5394c0750d9..6208b4542faa 100644
--- a/deskutils/pim-data-exporter/Makefile
+++ b/deskutils/pim-data-exporter/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pim-data-exporter
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +11,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib gettext grantlee:5 \
kde:5 qt:5 tar:xz xorg
diff --git a/net/akonadi-contacts/Makefile b/net/akonadi-contacts/Makefile
index 8d2e70948856..7842b0c0f1e1 100644
--- a/net/akonadi-contacts/Makefile
+++ b/net/akonadi-contacts/Makefile
@@ -1,6 +1,6 @@
PORTNAME= akonadi-contacts
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +12,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib gettext grantlee:5 kde:5 \
qt:5 tar:xz xorg
diff --git a/net/kget/Makefile b/net/kget/Makefile
index 0e8e85f1e733..3e5cdf582285 100644
--- a/net/kget/Makefile
+++ b/net/kget/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kget
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -14,7 +14,7 @@ LIB_DEPENDS= libKF5Torrent.so:net-p2p/libktorrent \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lang desktop-file-utils kde:5 qca qt:5 \
shebangfix sqlite tar:xz xorg
diff --git a/net/mailcommon/Makefile b/net/mailcommon/Makefile
index f1894e1d9246..4a08826380f4 100644
--- a/net/mailcommon/Makefile
+++ b/net/mailcommon/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mailcommon
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -14,7 +14,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib gettext grantlee:5 kde:5 qt:5 tar:xz xorg
USE_KDE= archive auth codecs completion config configwidgets coreaddons \
diff --git a/net/messagelib/Makefile b/net/messagelib/Makefile
index dd5ac02fd8f7..2e68778bd2dc 100644
--- a/net/messagelib/Makefile
+++ b/net/messagelib/Makefile
@@ -1,6 +1,6 @@
PORTNAME= messagelib
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -14,7 +14,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lib cpe gettext grantlee:5 kde:5 qca \
qt:5 tar:xz xorg
diff --git a/security/Makefile b/security/Makefile
index 95060c3f3de9..02406d834eb4 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -196,7 +196,7 @@
SUBDIR += gpgdir
SUBDIR += gpgme
SUBDIR += gpgme-cpp
- SUBDIR += gpgme-qt5
+ SUBDIR += gpgme-qt
SUBDIR += gsa
SUBDIR += gsad
SUBDIR += gsasl
diff --git a/security/gpgme-qt5/Makefile b/security/gpgme-qt/Makefile
index b12dcd3911c7..017cf7dda006 100644
--- a/security/gpgme-qt5/Makefile
+++ b/security/gpgme-qt/Makefile
@@ -1,14 +1,18 @@
+.if ${FLAVOR:U} == qt5
PORTREVISION= 0
-PKGNAMESUFFIX= -${SLAVEPORT}
COMMENT= Gpgme Qt5 bindings
+.else
+PORTREVISION= 0
+
+COMMENT= Gpgme Qt6 bindings
+.endif
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
MASTERDIR= ${.CURDIR}/../../security/gpgme
-SLAVEPORT= qt5
+SLAVEPORT= qt
BINDING_NAME= qt
-PLIST= ${.CURDIR}/pkg-plist
.include "${MASTERDIR}/Makefile"
diff --git a/security/gpgme-qt5/pkg-plist b/security/gpgme-qt/pkg-plist.qt5
index d10663f13c7f..d10663f13c7f 100644
--- a/security/gpgme-qt5/pkg-plist
+++ b/security/gpgme-qt/pkg-plist.qt5
diff --git a/security/gpgme-qt/pkg-plist.qt6 b/security/gpgme-qt/pkg-plist.qt6
new file mode 100644
index 000000000000..77f12008e497
--- /dev/null
+++ b/security/gpgme-qt/pkg-plist.qt6
@@ -0,0 +1,105 @@
+include/QGpgME/AbstractImportJob
+include/QGpgME/AddExistingSubkeyJob
+include/QGpgME/AddUserIDJob
+include/QGpgME/ChangeExpiryJob
+include/QGpgME/ChangeOwnerTrustJob
+include/QGpgME/ChangePasswdJob
+include/QGpgME/CryptoConfig
+include/QGpgME/DN
+include/QGpgME/DataProvider
+include/QGpgME/Debug
+include/QGpgME/DecryptJob
+include/QGpgME/DecryptVerifyArchiveJob
+include/QGpgME/DecryptVerifyJob
+include/QGpgME/DefaultKeyGenerationJob
+include/QGpgME/DeleteJob
+include/QGpgME/DownloadJob
+include/QGpgME/EncryptArchiveJob
+include/QGpgME/EncryptJob
+include/QGpgME/ExportJob
+include/QGpgME/FileListDataProvider
+include/QGpgME/GpgCardJob
+include/QGpgME/HierarchicalKeyKistJob
+include/QGpgME/ImportFromKeyserverJob
+include/QGpgME/ImportJob
+include/QGpgME/Job
+include/QGpgME/KeyForMailboxJob
+include/QGpgME/KeyGenerationJob
+include/QGpgME/KeyListJob
+include/QGpgME/ListAllKeysJob
+include/QGpgME/MultiDeleteJob
+include/QGpgME/Protocol
+include/QGpgME/QGpgMENewCryptoConfig
+include/QGpgME/QuickJob
+include/QGpgME/ReceiveKeysJob
+include/QGpgME/RefreshKeysJob
+include/QGpgME/RevokeKeyJob
+include/QGpgME/SetPrimaryUserIDJob
+include/QGpgME/SignArchiveJob
+include/QGpgME/SignEncryptArchiveJob
+include/QGpgME/SignEncryptJob
+include/QGpgME/SignJob
+include/QGpgME/SignKeyJob
+include/QGpgME/SpecialJob
+include/QGpgME/TofuPolicyJob
+include/QGpgME/VerifyDetachedJob
+include/QGpgME/VerifyOpaqueJob
+include/QGpgME/WKDLookupJob
+include/QGpgME/WKDLookupResult
+include/QGpgME/WKSPublishJob
+include/qgpgme/abstractimportjob.h
+include/qgpgme/addexistingsubkeyjob.h
+include/qgpgme/adduseridjob.h
+include/qgpgme/changeexpiryjob.h
+include/qgpgme/changeownertrustjob.h
+include/qgpgme/changepasswdjob.h
+include/qgpgme/cryptoconfig.h
+include/qgpgme/dataprovider.h
+include/qgpgme/debug.h
+include/qgpgme/decryptjob.h
+include/qgpgme/decryptverifyarchivejob.h
+include/qgpgme/decryptverifyjob.h
+include/qgpgme/defaultkeygenerationjob.h
+include/qgpgme/deletejob.h
+include/qgpgme/dn.h
+include/qgpgme/downloadjob.h
+include/qgpgme/encryptarchivejob.h
+include/qgpgme/encryptjob.h
+include/qgpgme/exportjob.h
+include/qgpgme/filelistdataprovider.h
+include/qgpgme/gpgcardjob.h
+include/qgpgme/hierarchicalkeylistjob.h
+include/qgpgme/importfromkeyserverjob.h
+include/qgpgme/importjob.h
+include/qgpgme/job.h
+include/qgpgme/keyformailboxjob.h
+include/qgpgme/keygenerationjob.h
+include/qgpgme/keylistjob.h
+include/qgpgme/listallkeysjob.h
+include/qgpgme/multideletejob.h
+include/qgpgme/protocol.h
+include/qgpgme/qgpgme_export.h
+include/qgpgme/qgpgme_version.h
+include/qgpgme/qgpgmenewcryptoconfig.h
+include/qgpgme/quickjob.h
+include/qgpgme/receivekeysjob.h
+include/qgpgme/refreshkeysjob.h
+include/qgpgme/revokekeyjob.h
+include/qgpgme/setprimaryuseridjob.h
+include/qgpgme/signarchivejob.h
+include/qgpgme/signencryptarchivejob.h
+include/qgpgme/signencryptjob.h
+include/qgpgme/signjob.h
+include/qgpgme/signkeyjob.h
+include/qgpgme/specialjob.h
+include/qgpgme/tofupolicyjob.h
+include/qgpgme/verifydetachedjob.h
+include/qgpgme/verifyopaquejob.h
+include/qgpgme/wkdlookupjob.h
+include/qgpgme/wkdlookupresult.h
+include/qgpgme/wkspublishjob.h
+lib/cmake/QGpgmeQt6/QGpgmeQt6Config.cmake
+lib/cmake/QGpgmeQt6/QGpgmeQt6ConfigVersion.cmake
+lib/libqgpgmeqt6.so
+lib/libqgpgmeqt6.so.15
+lib/libqgpgmeqt6.so.15.2.1
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 3b3f4b0384fe..521412d87ebe 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -64,17 +64,34 @@ CONFIGURE_ARGS+=--enable-languages="cpp"
NO_TEST= yes
. endif
-. if ${SLAVEPORT} == "qt5"
+. if ${SLAVEPORT} == "qt"
LIB_DEPENDS+= libgpgmepp.so:security/gpgme-cpp
+
+FLAVORS= qt5 qt6
+FLAVOR?= ${FLAVORS:[1]}
+qt5_PKGNAMESUFFIX= -qt5
+qt6_PKGNAMESUFFIX= -qt6
+qt5_PLIST= ${.CURDIR}/pkg-plist.qt5
+qt6_PLIST= ${.CURDIR}/pkg-plist.qt6
+qt5_CONFLICTS_INSTALL= gpgme-qt6
+qt6_CONFLICTS_INSTALL= gpgme-qt5
+
+. if ${FLAVOR:U} == "qt5"
USES+= compiler:c++11-lib pkgconfig qt:5
-USE_QT= buildtools:build core
-CONFIGURE_ARGS+=--enable-languages="cpp qt"
-DOCSDIR= ${PORTNAME}${PKGNAMESUFFIX}
+USE_QT= buildtools:build core
+TEST_USE= QT=testlib:build
+. else
+USES+= compiler:c++17-lang pkgconfig qt:6
+USE_QT= base
+USE_CXXSTD= c++17
+. endif
+
+CONFIGURE_ARGS+=--enable-languages="cpp ${FLAVOR}"
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
OPTIONS_DEFINE+= DOXYGEN
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
dot:graphics/graphviz
-TEST_USE= QT=testlib:build
. endif
. if ${SLAVEPORT} == "python"
@@ -95,7 +112,7 @@ post-patch:
.if defined(SLAVEPORT)
@${FIND} ${BUILD_WRKSRC} -name "Makefile.in" -type f | ${XARGS} \
${REINPLACE_CMD} -e 's|../../../src/libgpgme.la|-lgpgme|g'
-. if ${SLAVEPORT} == "qt5"
+. if ${SLAVEPORT} == "qt"
@${FIND} ${BUILD_WRKSRC} -name "Makefile.in" -type f | ${XARGS} \
${REINPLACE_CMD} -e 's|../../cpp/src/libgpgmepp.la|-lgpgmepp|g'
. endif
diff --git a/security/kleopatra/Makefile b/security/kleopatra/Makefile
index 890457f82b8b..f52eb85561fc 100644
--- a/security/kleopatra/Makefile
+++ b/security/kleopatra/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kleopatra
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +12,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpgme.so:security/gpgme \
libgpg-error.so:security/libgpg-error \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:5 \
shared-mime-info qt:5 tar:xz xorg
diff --git a/security/libkleo/Makefile b/security/libkleo/Makefile
index c6dd8b1acfca..f54dffb76796 100644
--- a/security/libkleo/Makefile
+++ b/security/libkleo/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libkleo
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +11,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/algorithm.hpp:devel/boost-libs
LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
- libqgpgme.so:security/gpgme-qt5 \
+ libqgpgme.so:security/gpgme-qt@qt5 \
libgpgmepp.so:security/gpgme-cpp
RUN_DEPENDS= ${LOCALBASE}/bin/gmd5sum:sysutils/coreutils
diff --git a/sysutils/kf5-kwallet/Makefile b/sysutils/kf5-kwallet/Makefile
index ee9e4f70d6e4..ca95cd168372 100644
--- a/sysutils/kf5-kwallet/Makefile
+++ b/sysutils/kf5-kwallet/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kwallet
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +10,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
- libqgpgme.so:security/gpgme-qt5 \
+ libqgpgme.so:security/gpgme-qt@qt5 \
libgpgmepp.so:security/gpgme-cpp
USES= cmake compiler:c++11-lib gettext kde:5 qca qt:5 tar:xz xorg
diff --git a/sysutils/plasma-pass/Makefile b/sysutils/plasma-pass/Makefile
index b87e0277d602..85df86f81c97 100644
--- a/sysutils/plasma-pass/Makefile
+++ b/sysutils/plasma-pass/Makefile
@@ -1,7 +1,7 @@
PORTNAME= plasma-pass
DISTVERSION= 1.2.1
MASTER_SITES= KDE/stable/${PORTNAME}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils kde
MAINTAINER= kde@FreeBSD.org
@@ -16,7 +16,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
liboath.so:security/oath-toolkit \
- libqgpgme.so:security/gpgme-qt5
+ libqgpgme.so:security/gpgme-qt@qt5
RUN_DEPENDS= pass:sysutils/password-store
USES= cmake compiler:c++11-lib kde:5 qt:5 tar:xz