aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Hicks <ahicks@p-o.co.uk>2023-07-26 07:23:49 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-07-27 06:24:01 +0000
commitf252b3a865d3476360ee429e0297d589fd94b4fb (patch)
tree8b24d9a29c18e316f988e9bb31dc3c185a998b41
parent02f668c96e01ce05497cf49a3e26594eaca201f8 (diff)
downloadports-f252b3a865d3476360ee429e0297d589fd94b4fb.tar.gz
ports-f252b3a865d3476360ee429e0297d589fd94b4fb.zip
multimedia/dvdstyler: Fix build on FreeBSD 14
Update to C++17. PR: 272680 Reported by: ahicks@p-o.co.uk (maintainer)
-rw-r--r--multimedia/dvdstyler/Makefile4
-rw-r--r--multimedia/dvdstyler/files/patch-wxVillaLib_ThumbnailFactory.cpp11
-rw-r--r--multimedia/dvdstyler/files/patch-wxVillaLib_imagjpg.cpp10
-rw-r--r--multimedia/dvdstyler/files/patch-wxVillaLib_thumb_md5.cpp11
4 files changed, 35 insertions, 1 deletions
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index 1b8fd0f79391..7e8cd9289c21 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dvdstyler
DISTVERSION= 3.3b3
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= multimedia
#MASTER_SITES= SF
@@ -43,6 +43,8 @@ WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_AVCONV_PATH="" OBJCXX="${CXX}"
+CFLAGS+= -std=c17
+CPPFLAGS+= -std=c++17
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/dvdstyler/files/patch-wxVillaLib_ThumbnailFactory.cpp b/multimedia/dvdstyler/files/patch-wxVillaLib_ThumbnailFactory.cpp
new file mode 100644
index 000000000000..d1b28b3d4159
--- /dev/null
+++ b/multimedia/dvdstyler/files/patch-wxVillaLib_ThumbnailFactory.cpp
@@ -0,0 +1,11 @@
+--- wxVillaLib/ThumbnailFactory.cpp 2023-07-24 10:21:13.152544000 +0100
++++ wxVillaLib/ThumbnailFactory.cpp 2023-07-24 10:18:45.440168000 +0100
+@@ -363,7 +363,7 @@
+ img = decoder.GetNextFrame();
+ }
+ if (img.Ok() && decoder.GetFrameAspectRatio() > 0
+- && labs(decoder.GetFrameAspectRatio()*100 - img.GetWidth()*100/img.GetHeight()) >= 5) {
++ && std::abs(decoder.GetFrameAspectRatio()*100 - img.GetWidth()*100/img.GetHeight()) >= 5) {
+ if (lround(img.GetWidth() / decoder.GetFrameAspectRatio()) > img.GetHeight())
+ img.Rescale(img.GetWidth(), lround(img.GetWidth() / decoder.GetFrameAspectRatio()));
+ else
diff --git a/multimedia/dvdstyler/files/patch-wxVillaLib_imagjpg.cpp b/multimedia/dvdstyler/files/patch-wxVillaLib_imagjpg.cpp
new file mode 100644
index 000000000000..feb4c16aa200
--- /dev/null
+++ b/multimedia/dvdstyler/files/patch-wxVillaLib_imagjpg.cpp
@@ -0,0 +1,10 @@
+--- wxVillaLib/imagjpg.cpp 2023-07-24 10:38:58.609790000 +0100
++++ wxVillaLib/imagjpg.cpp 2023-07-24 10:41:28.358164000 +0100
+@@ -1,7 +1,3 @@
+-#ifdef __GNUG__
+-#pragma implementation "imagjpg.h"
+-#endif
+-
+ // For compilers that support precompilation, includes "wx.h".
+ #include "wx/wxprec.h"
+
diff --git a/multimedia/dvdstyler/files/patch-wxVillaLib_thumb_md5.cpp b/multimedia/dvdstyler/files/patch-wxVillaLib_thumb_md5.cpp
new file mode 100644
index 000000000000..6b18f2f1c11a
--- /dev/null
+++ b/multimedia/dvdstyler/files/patch-wxVillaLib_thumb_md5.cpp
@@ -0,0 +1,11 @@
+--- wxVillaLib/thumb_md5.cpp 2023-07-24 10:20:48.138290000 +0100
++++ wxVillaLib/thumb_md5.cpp 2023-07-24 10:02:20.011636000 +0100
+@@ -199,7 +199,7 @@
+ static void
+ thumb_md5_transform (wxUint32 buf[4], wxUint32 const in[16])
+ {
+- register wxUint32 a, b, c, d;
++ wxUint32 a, b, c, d;
+
+ a = buf[0];
+ b = buf[1];