aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-27 20:44:17 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-27 20:44:17 +0000
commitf38dc30d35108e602d56b689b8509d003204e9d1 (patch)
tree88dbb97fdc617ba21e76f0d04014026e2c592a77
parentc9540832a24d7b09b6f76ca47db73f2f35afa352 (diff)
downloadports-f38dc30d35108e602d56b689b8509d003204e9d1.tar.gz
ports-f38dc30d35108e602d56b689b8509d003204e9d1.zip
Add planet - a flexible feed aggregator.
PR: 86613 Submitted by: Alan Snelson <Alan@Wave2.co.uk>
Notes
Notes: svn path=/head/; revision=143650
-rw-r--r--www/Makefile1
-rw-r--r--www/planet/Makefile30
-rw-r--r--www/planet/distinfo2
-rw-r--r--www/planet/files/patch-htmltmpl.py27
-rw-r--r--www/planet/files/pkg-message.in7
-rw-r--r--www/planet/pkg-descr13
-rw-r--r--www/planet/pkg-plist38
7 files changed, 118 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ca1587b6292e..48004c971073 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -679,6 +679,7 @@
SUBDIR += phpsurveyor
SUBDIR += phpwebapp
SUBDIR += phpwiki
+ SUBDIR += planet
SUBDIR += plog
SUBDIR += plone
SUBDIR += plugger
diff --git a/www/planet/Makefile b/www/planet/Makefile
new file mode 100644
index 000000000000..c8de696c21dd
--- /dev/null
+++ b/www/planet/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: planet
+# Date created: 26 September 2005
+# Whom: Alan Snelson <alan@wave2.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= planet
+PORTVERSION= 0.0p22
+CATEGORIES= www
+MASTER_SITES= http://www.wave2.co.uk/freebsd/planet/
+
+MAINTAINER= alan@wave2.co.uk
+COMMENT= Planet is a flexible feed aggregator - and more!
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/Tidy/Tidy.py:${PORTSDIR}/devel/py-mx-experimental
+
+NO_BUILD= yes
+USE_PYTHON= yes
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/planet
+ ${CP} -R ${WRKSRC}/ ${PREFIX}/share/planet
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/planet/distinfo b/www/planet/distinfo
new file mode 100644
index 000000000000..e4a380b561b6
--- /dev/null
+++ b/www/planet/distinfo
@@ -0,0 +1,2 @@
+MD5 (planet-0.0p22.tar.gz) = e755e5fd0f98bdec7e88890612e01f24
+SIZE (planet-0.0p22.tar.gz) = 123705
diff --git a/www/planet/files/patch-htmltmpl.py b/www/planet/files/patch-htmltmpl.py
new file mode 100644
index 000000000000..748b6a59e4e4
--- /dev/null
+++ b/www/planet/files/patch-htmltmpl.py
@@ -0,0 +1,27 @@
+*** htmltmpl.py Mon Sep 26 19:14:38 2005
+--- htmltmpl.py Mon Sep 26 19:00:07 2005
+***************
+*** 267,277 ****
+ fd = file.fileno()
+ if LOCKTYPE == LOCKTYPE_FCNTL:
+ if lock == LOCK_SH:
+! fcntl.fcntl(fd, fcntl.LOCK_SH)
+ elif lock == LOCK_EX:
+! fcntl.fcntl(fd, fcntl.LOCK_EX)
+ elif lock == LOCK_UN:
+! fcntl.fcntl(fd, fcntl.LOCK_UN)
+ else:
+ raise TemplateError, "BUG: bad lock in lock_file"
+ elif LOCKTYPE == LOCKTYPE_MSVCRT:
+--- 267,277 ----
+ fd = file.fileno()
+ if LOCKTYPE == LOCKTYPE_FCNTL:
+ if lock == LOCK_SH:
+! fcntl.flock(fd, fcntl.LOCK_SH)
+ elif lock == LOCK_EX:
+! fcntl.flock(fd, fcntl.LOCK_EX)
+ elif lock == LOCK_UN:
+! fcntl.flock(fd, fcntl.LOCK_UN)
+ else:
+ raise TemplateError, "BUG: bad lock in lock_file"
+ elif LOCKTYPE == LOCKTYPE_MSVCRT:
diff --git a/www/planet/files/pkg-message.in b/www/planet/files/pkg-message.in
new file mode 100644
index 000000000000..0fdf54e8dabf
--- /dev/null
+++ b/www/planet/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+Planet has been installed into %%DATADIR%%
+
+To get started, make a copy of the examples directory and configure to taste.
+
+*** Try to keep your configuration and output files away from the installation folder %%DATADIR%%, the INSTALL doc recommends ~/planet, but %%PREFIX%%/etc/planet is a good choice.***
+
diff --git a/www/planet/pkg-descr b/www/planet/pkg-descr
new file mode 100644
index 000000000000..5c4eb6bd1aba
--- /dev/null
+++ b/www/planet/pkg-descr
@@ -0,0 +1,13 @@
+Planet is a flexible feed aggregator, this means that it downloads feeds
+and aggregates their content together into a single combined feed with
+the latest news first.
+
+It uses Mark Pilgrim's Ultra-liberal feed parser so can read from RDF, RSS
+and Atom feeds and Tomas Styblo's template library to output static files
+in unlimited formats based on a series of templates.
+
+Planet was written for the Planet Debian and Planet GNOME websites by
+Scott James Remnant <scott@netsplit.com> and
+Jeff Waugh <jdub@perkypants.org>. It was originally based on 'spycyroll'.
+
+WWW: http://www.planetplanet.org
diff --git a/www/planet/pkg-plist b/www/planet/pkg-plist
new file mode 100644
index 000000000000..f8d404219424
--- /dev/null
+++ b/www/planet/pkg-plist
@@ -0,0 +1,38 @@
+%%DATADIR%%/AUTHORS
+%%DATADIR%%/ChangeLog
+%%DATADIR%%/INSTALL
+%%DATADIR%%/Makefile
+%%DATADIR%%/README
+%%DATADIR%%/THANKS
+%%DATADIR%%/TODO
+%%DATADIR%%/compat_logging/__init__.py
+%%DATADIR%%/compat_logging/config.py
+%%DATADIR%%/compat_logging/handlers.py
+%%DATADIR%%/examples/config.ini
+%%DATADIR%%/examples/foafroll.xml.tmpl
+%%DATADIR%%/examples/index.html.tmpl
+%%DATADIR%%/examples/opml.xml.tmpl
+%%DATADIR%%/examples/rss10.xml.tmpl
+%%DATADIR%%/examples/rss20.xml.tmpl
+%%DATADIR%%/fancy-examples/config.ini
+%%DATADIR%%/fancy-examples/index.html.tmpl
+%%DATADIR%%/feedparser.py
+%%DATADIR%%/htmltmpl.py
+%%DATADIR%%/htmltmpl.py.orig
+%%DATADIR%%/output/images/edd.png
+%%DATADIR%%/output/images/evolution.png
+%%DATADIR%%/output/images/jdub.png
+%%DATADIR%%/output/images/keybuk.png
+%%DATADIR%%/output/images/logo.png
+%%DATADIR%%/output/images/planet.png
+%%DATADIR%%/output/images/thom.png
+%%DATADIR%%/output/planet.css
+%%DATADIR%%/planet.py
+%%DATADIR%%/planetlib.py
+%%DATADIR%%/timeoutsocket.py
+@dirrm %%DATADIR%%/compat_logging
+@dirrm %%DATADIR%%/examples
+@dirrm %%DATADIR%%/fancy-examples
+@dirrm %%DATADIR%%/output/images
+@dirrm %%DATADIR%%/output
+@dirrm %%DATADIR%%