aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2022-05-07 11:04:13 +0000
committerKai Knoblich <kai@FreeBSD.org>2022-05-07 11:04:13 +0000
commitf38fc1bea7ccf044bd29823744b8da939a257687 (patch)
treea63cecb14806c7402714748945d9728e17132d18
parentcfbf91df2f5cefa89f9a51d036c710dd34cf0c0e (diff)
downloadports-f38fc1bea7ccf044bd29823744b8da939a257687.tar.gz
ports-f38fc1bea7ccf044bd29823744b8da939a257687.zip
www/py-djangorestframework: Update to 3.13.1
* Remove obsolete entries from CONFLICTS_INSTALL. * Update pkg-descr to match reality. Changelog since 3.12.4: https://www.django-rest-framework.org/community/release-notes/#313x-series
-rw-r--r--www/py-djangorestframework/Makefile10
-rw-r--r--www/py-djangorestframework/distinfo6
-rw-r--r--www/py-djangorestframework/pkg-descr17
3 files changed, 22 insertions, 11 deletions
diff --git a/www/py-djangorestframework/Makefile b/www/py-djangorestframework/Makefile
index 8e69f3690ce7..1a1d42072e62 100644
--- a/www/py-djangorestframework/Makefile
+++ b/www/py-djangorestframework/Makefile
@@ -1,6 +1,5 @@
PORTNAME= djangorestframework
-PORTVERSION= 3.12.4
-PORTREVISION= 1
+PORTVERSION= 3.13.1
PORTEPOCH= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
@@ -15,12 +14,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=2.2:www/py-django32@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= distutils autoplist
-CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}djangorestframework3* \
- ${PYTHON_PKGNAMEPREFIX}dj31-djangorestframework \
- ${PYTHON_PKGNAMEPREFIX}dj32-djangorestframework
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}dj32-djangorestframework
+
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/www/py-djangorestframework/distinfo b/www/py-djangorestframework/distinfo
index 01fbb2133c85..adfb1b731aff 100644
--- a/www/py-djangorestframework/distinfo
+++ b/www/py-djangorestframework/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616796749
-SHA256 (djangorestframework-3.12.4.tar.gz) = f747949a8ddac876e879190df194b925c177cdeb725a099db1460872f7c0a7f2
-SIZE (djangorestframework-3.12.4.tar.gz) = 825004
+TIMESTAMP = 1651911373
+SHA256 (djangorestframework-3.13.1.tar.gz) = 0c33407ce23acc68eca2a6e46424b008c9c02eceb8cf18581921d0092bc1f2ee
+SIZE (djangorestframework-3.13.1.tar.gz) = 954950
diff --git a/www/py-djangorestframework/pkg-descr b/www/py-djangorestframework/pkg-descr
index fc24440c9a9b..d478efc8b9a7 100644
--- a/www/py-djangorestframework/pkg-descr
+++ b/www/py-djangorestframework/pkg-descr
@@ -1,4 +1,17 @@
-Django REST framework is a powerful and flexible toolkit that makes
-it easy to build Web APIs.
+Django REST framework is a powerful and flexible toolkit that makes it easy to
+build Web APIs.
+
+Some reasons you might want to use REST framework:
+
+* The Web browsable API is a huge usability win for your developers.
+
+* Authentication policies including optional packages for OAuth1a and OAuth2.
+
+* Serialization that supports both ORM and non-ORM data sources.
+
+* Customizable all the way down - just use regular function-based views if you
+ don't need the more powerful features.
+
+* Extensive documentation, and great community support.
WWW: https://www.django-rest-framework.org/