aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-15 13:32:04 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-03-15 13:32:04 +0000
commitf3e7d87a927699980ee98257e422af8f74453502 (patch)
tree3027cbff4780a252dd02b7829b84d26b95f13c02
parentae618e131ad52fb8e2bb6923cc429c900218d517 (diff)
downloadports-f3e7d87a927699980ee98257e422af8f74453502.tar.gz
ports-f3e7d87a927699980ee98257e422af8f74453502.zip
lang/intel-compute-runtime: update to 21.10.19208
Notes
Notes: svn path=/head/; revision=568456
-rw-r--r--lang/intel-compute-runtime/Makefile3
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-rtld32
3 files changed, 27 insertions, 14 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index 8ae070543f9f..ab579d5a47fc 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= compute-runtime
-DISTVERSION= 21.09.19150
-PORTREVISION= 1
+DISTVERSION= 21.10.19208
CATEGORIES= lang
PKGNAMEPREFIX= intel-
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 32276c5b2ee5..40d93b90607a 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1614027337
-SHA256 (intel-compute-runtime-21.09.19150_GH0.tar.gz) = c38172bc7460cc3ec104ef29a655788cdd8329a62e894ee1ec116e78ebc451a5
-SIZE (intel-compute-runtime-21.09.19150_GH0.tar.gz) = 3780882
+TIMESTAMP = 1614619045
+SHA256 (intel-compute-runtime-21.10.19208_GH0.tar.gz) = 9950fb77c9ce56711d1d4d4554d75406ce53935f954e573d492e2f75c85e7bcf
+SIZE (intel-compute-runtime-21.10.19208_GH0.tar.gz) = 3791111
SHA256 (2a423820aaa4.patch) = dd034e856e75d70bc6b63204aa2c67530a3212d111b67a703e4cbeb84e61685b
SIZE (2a423820aaa4.patch) = 947
SHA256 (76666662c479.patch) = 9513b57fb156aa8394ba9a6311ae055c8bf7f5202ee77e3c90987448836dc26a
diff --git a/lang/intel-compute-runtime/files/patch-rtld b/lang/intel-compute-runtime/files/patch-rtld
index 4487fc0b692b..624554e2c616 100644
--- a/lang/intel-compute-runtime/files/patch-rtld
+++ b/lang/intel-compute-runtime/files/patch-rtld
@@ -1,18 +1,32 @@
RTLD_DEEPBIND isn't available on non-Linux
-core/os_interface/linux/os_library_linux.cpp: In constructor 'NEO::Linux::OsLibrary::OsLibrary(const string&)':
-core/os_interface/linux/os_library_linux.cpp:35:49: error: 'RTLD_DEEPBIND' was not declared in this scope
- 35 | constexpr auto dlopenFlag = RTLD_LAZY | RTLD_DEEPBIND;
- | ^~~~~~~~~~~~~
+shared/source/os_interface/linux/os_library_helper.cpp:17:24: error: use of undeclared identifier 'RTLD_DEEPBIND'
+ dlopenFlag &= ~RTLD_DEEPBIND;
+ ^
+shared/source/os_interface/linux/os_library_linux.cpp:41:39: error: use of undeclared identifier 'RTLD_DEEPBIND'
+ auto dlopenFlag = RTLD_LAZY | RTLD_DEEPBIND;
+ ^
---- shared/source/os_interface/linux/os_library_linux.cpp.orig 2020-02-28 16:16:42 UTC
+--- shared/source/os_interface/linux/os_library_helper.cpp.orig 2021-03-01 17:17:25 UTC
++++ shared/source/os_interface/linux/os_library_helper.cpp
+@@ -14,7 +14,9 @@ namespace NEO {
+ namespace Linux {
+ void adjustLibraryFlags(int &dlopenFlag) {
+ if (DebugManager.flags.DisableDeepBind.get()) {
++#ifdef RTLD_DEEPBIND
+ dlopenFlag &= ~RTLD_DEEPBIND;
++#endif
+ }
+ }
+ } // namespace Linux
+--- shared/source/os_interface/linux/os_library_linux.cpp.orig 2021-03-01 17:17:25 UTC
+++ shared/source/os_interface/linux/os_library_linux.cpp
-@@ -29,7 +29,7 @@ OsLibrary::OsLibrary(const std::string &name) {
+@@ -35,7 +35,7 @@ OsLibrary::OsLibrary(const std::string &name) {
if (name.empty()) {
- this->handle = dlopen(0, RTLD_LAZY);
+ this->handle = SysCalls::dlopen(0, RTLD_LAZY);
} else {
-#ifdef SANITIZER_BUILD
+#if defined(SANITIZER_BUILD) || !defined(RTLD_DEEPBIND)
- constexpr auto dlopenFlag = RTLD_LAZY;
+ auto dlopenFlag = RTLD_LAZY;
#else
- constexpr auto dlopenFlag = RTLD_LAZY | RTLD_DEEPBIND;
+ auto dlopenFlag = RTLD_LAZY | RTLD_DEEPBIND;