aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2024-11-24 13:31:40 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2024-11-24 13:31:40 +0000
commitf488a27c4d56bbdb72b779282ba86402d1699ca1 (patch)
treee2a22f08a2b15bf32101b4344782656cc742122b
parent33610ebde0d5033268c2f299084331aba133324e (diff)
biology/bwa: Update to 0.7.18
Official support for aarch64 (we already had this patched in) A few minor enhancements and fixes Changes: https://github.com/lh3/bwa/releases PR: 282923 Reported by: alster@vinterdalen.se
-rw-r--r--biology/bwa/Makefile26
-rw-r--r--biology/bwa/distinfo8
-rw-r--r--biology/bwa/files/patch-ksw.c12
-rw-r--r--biology/bwa/pkg-descr18
4 files changed, 34 insertions, 30 deletions
diff --git a/biology/bwa/Makefile b/biology/bwa/Makefile
index eef1e1a5948d..11d77f255875 100644
--- a/biology/bwa/Makefile
+++ b/biology/bwa/Makefile
@@ -1,35 +1,29 @@
PORTNAME= bwa
-PORTVERSION= 0.7.17
-DISTVERSIONPREFIX=v
-PORTREVISION= 2
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.7.18
CATEGORIES= biology
-PATCH_SITES= https://github.com/lh3/bwa/commit/
-PATCHFILES= 2a1ae7b6f34a96ea25be007ac9d91e57e9d32284.patch:-p1
-
MAINTAINER= jwb@FreeBSD.org
COMMENT= Burrows-Wheeler sequence aligner
-WWW= https://sourceforge.net/projects/bio-bwa/
+WWW= https://github.com/lh3/bwa/
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_mips= fails to compile: cc1: unrecognized command line option "-msse2"
-BROKEN_mips64= fails to compile: cc1: unrecognized command line option "-msse2"
+# Recheck these after 0.7.18 update
+BROKEN_mips= fails to compile: cc1: unrecognized command line option "-msse2"
+BROKEN_mips64= fails to compile: cc1: unrecognized command line option "-msse2"
BUILD_DEPENDS= simde>0:devel/simde
USES= gmake localbase perl5 shebangfix tar:bzip2
-SHEBANG_FILES= qualfa2fq.pl xa2multi.pl
-USE_PERL5= run
-
USE_GITHUB= yes
GH_ACCOUNT= lh3
+USE_PERL5= run
-PLIST_FILES= bin/bwa bin/qualfa2fq.pl bin/xa2multi.pl share/man/man1/bwa.1.gz
+SHEBANG_FILES= qualfa2fq.pl xa2multi.pl
-# Avoid #error in emmintrin.h
-CFLAGS_i386= -msse2
-CFLAGS_amd64= -msse2
+PLIST_FILES= bin/bwa bin/qualfa2fq.pl bin/xa2multi.pl share/man/man1/bwa.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bwa ${STAGEDIR}${PREFIX}/bin
diff --git a/biology/bwa/distinfo b/biology/bwa/distinfo
index e4f099c0700c..b9b0548bf588 100644
--- a/biology/bwa/distinfo
+++ b/biology/bwa/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1598613295
-SHA256 (lh3-bwa-v0.7.17_GH0.tar.gz) = 980b9591b61c60042c4a39b9e31ccaad8d17ff179d44d347997825da3fdf47fd
-SIZE (lh3-bwa-v0.7.17_GH0.tar.gz) = 232593
-SHA256 (2a1ae7b6f34a96ea25be007ac9d91e57e9d32284.patch) = 15216a79759a2390bda4a4684af34ff3108f63519d2ec3935754507f3c008da0
-SIZE (2a1ae7b6f34a96ea25be007ac9d91e57e9d32284.patch) = 709
+TIMESTAMP = 1732300398
+SHA256 (lh3-bwa-v0.7.18_GH0.tar.gz) = 194788087f7b9a77c0114aa481b2ef21439f6abab72488c83917302e8d0e7870
+SIZE (lh3-bwa-v0.7.18_GH0.tar.gz) = 238036
diff --git a/biology/bwa/files/patch-ksw.c b/biology/bwa/files/patch-ksw.c
index c86cabf2e497..f5314cbe72ce 100644
--- a/biology/bwa/files/patch-ksw.c
+++ b/biology/bwa/files/patch-ksw.c
@@ -1,13 +1,13 @@
---- ksw.c.orig 2021-12-01 13:48:35 UTC
+--- ksw.c.orig 2024-11-22 18:42:53 UTC
+++ ksw.c
-@@ -26,7 +26,9 @@
- #include <stdlib.h>
+@@ -27,7 +27,9 @@
#include <stdint.h>
#include <assert.h>
+ #if defined __SSE2__
-#include <emmintrin.h>
+// #include <emmintrin.h>
+#define SIMDE_ENABLE_NATIVE_ALIASES
+#include <simde/x86/sse2.h>
- #include "ksw.h"
-
- #ifdef USE_MALLOC_WRAPPERS
+ #elif defined __ARM_NEON
+ #include "neon_sse.h"
+ #else
diff --git a/biology/bwa/pkg-descr b/biology/bwa/pkg-descr
index 60f539b01220..e0c3d83a0b28 100644
--- a/biology/bwa/pkg-descr
+++ b/biology/bwa/pkg-descr
@@ -1,3 +1,15 @@
-BWA is a program for aligning sequencing reads against a large reference
-genome (e.g. human genome). It has two major components, one for read shorter
-than 150bp and the other for longer reads.
+BWA is a software package for mapping DNA sequences against a large
+reference genome, such as the human genome. It consists of three
+algorithms: BWA-backtrack, BWA-SW and BWA-MEM. The first algorithm is
+designed for Illumina sequence reads up to 100bp, while the other two
+are for longer sequences ranging from 70bp to a few megabases. BWA-MEM
+and BWA-SW share similar features such as the support of long reads
+and chimeric alignment, but BWA-MEM, which is the latest, is generally
+recommended, as it is faster and more accurate. BWA-MEM also has
+better performance than BWA-backtrack for 70-100bp Illumina reads.
+
+For all algorithms, BWA first needs to construct the FM-index for the
+reference genome (the "bwa index" command). Alignment algorithms are
+invoked with different sub-commands: "bwa aln/samse/sampe" for
+BWA-backtrack, "bwa bwasw" for BWA-SW, and "bwa mem" for the BWA-MEM
+algorithm.