aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-17 10:28:02 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-17 10:28:02 +0000
commitf49ea08b3e5972490fb4861c827a2880f306deea (patch)
treee6ba1617d1027f5ac87799198471e6324f19bf21
parent5e09ee3336ab5db008ff5362d11790c1d057e06e (diff)
downloadports-f49ea08b3e5972490fb4861c827a2880f306deea.tar.gz
ports-f49ea08b3e5972490fb4861c827a2880f306deea.zip
devel/godot: fix build on riscv64
pcre2 currently doesn't support JIT on riscv64. While it's possible to just disable that in godot, this will mean someone will need to remember to enable it when JIT is supported. PR: 256655 Approved by: FreeBSD@ShaneWare.Biz (maintainer)
-rw-r--r--devel/godot/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/godot/Makefile b/devel/godot/Makefile
index 2f99b59d0752..eb818367acaa 100644
--- a/devel/godot/Makefile
+++ b/devel/godot/Makefile
@@ -2,7 +2,7 @@
PORTNAME= godot
DISTVERSION= 3.2.3
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONSUFFIX= -stable
CATEGORIES= devel games
@@ -16,6 +16,7 @@ LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= yasm:devel/yasm
LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libpcre2-8.so:devel/pcre2 \
libpng.so:graphics/png
RUN_DEPENDS= xdg-user-dir:devel/xdg-user-dirs \
xdg-open:devel/xdg-utils \
@@ -28,8 +29,9 @@ USE_GL= gl glew glu
USE_GITHUB= yes
GH_ACCOUNT= godotengine
-MAKE_ARGS+= platform=x11 builtin_libpng=False \
- builtin_freetype=False builtin_zlib=False verbose=True
+MAKE_ARGS+= platform=x11 builtin_freetype=False \
+ builtin_libpng=False builtin_pcre2=False \
+ builtin_zlib=False verbose=True
MAKE_ARGS+= ${MAKE_ARGS_${CHOSEN_COMPILER_TYPE}}
MAKE_ARGS_clang= use_llvm=True use_lld=True
CXXFLAGS_i386= ${CXXFLAGS_i386_${CHOSEN_COMPILER_TYPE}}