aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-11-01 21:51:07 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-11-12 05:54:51 +0000
commitf4ffcdfe611a0e2147bbcb9697ecdffb4538acb7 (patch)
tree7d94bef3f2597ae9fe71a4ed9e740a80cc3999c8
parent46ce086c7130aedb8b349864afaf938489d070de (diff)
downloadports-f4ffcdfe611a0e2147bbcb9697ecdffb4538acb7.tar.gz
ports-f4ffcdfe611a0e2147bbcb9697ecdffb4538acb7.zip
*/*: use new nodejs USES flag
Simply define which nodejs version is required using the nodejs USES flag. PR: 259783 Differential Revision: https://reviews.freebsd.org/D32790
-rw-r--r--devel/node-thrift/Makefile5
-rw-r--r--devel/purescript-language-server/Makefile3
-rw-r--r--devel/rubygem-execjs/Makefile13
-rw-r--r--devel/sonar-scanner-cli/Makefile6
-rw-r--r--lang/coffeescript/Makefile4
-rw-r--r--net/cjdns/Makefile6
-rw-r--r--security/greenbone-security-assistant/Makefile6
-rw-r--r--textproc/kibana6/Makefile5
-rw-r--r--textproc/kibana7/Makefile8
-rw-r--r--textproc/opensearch-dashboards/Makefile7
-rw-r--r--www/Makefile2
-rw-r--r--www/csso/Makefile4
-rw-r--r--www/gitlab-ce/Makefile2
-rw-r--r--www/npm-node14/Makefile5
-rw-r--r--www/npm-node16/Makefile5
-rw-r--r--www/npm-node17/Makefile11
-rw-r--r--www/npm/Makefile17
-rw-r--r--www/yarn-node14/Makefile5
-rw-r--r--www/yarn-node16/Makefile5
-rw-r--r--www/yarn-node17/Makefile11
-rw-r--r--www/yarn/Makefile17
21 files changed, 66 insertions, 81 deletions
diff --git a/devel/node-thrift/Makefile b/devel/node-thrift/Makefile
index 89664c9aa3e8..8b021c979e58 100644
--- a/devel/node-thrift/Makefile
+++ b/devel/node-thrift/Makefile
@@ -2,6 +2,7 @@
PORTNAME= thrift
PORTVERSION= ${THRIFT_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= APACHE/thrift/${PORTVERSION}
PKGNAMEPREFIX= node-
@@ -9,9 +10,7 @@ PKGNAMEPREFIX= node-
MAINTAINER= ports@FreeBSD.org
COMMENT= Node.js bindings for the Apache Thrift RPC system
-RUN_DEPENDS= node:www/node
-
-USES= cpe
+USES= cpe nodejs:run
CPE_VENDOR= apache
NO_BUILD= yes
diff --git a/devel/purescript-language-server/Makefile b/devel/purescript-language-server/Makefile
index 8ef5b131e6f6..6e9889d0ac42 100644
--- a/devel/purescript-language-server/Makefile
+++ b/devel/purescript-language-server/Makefile
@@ -1,5 +1,6 @@
PORTNAME= purescript-language-server
PORTVERSION= 0.15.7
+PORTREVISION= 1
CATEGORIES= devel textproc
MASTER_SITES= https://github.com/nwolverson/${PORTNAME}/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}.js
@@ -11,7 +12,7 @@ COMMENT= LSP provider implementation for PureScript language
LICENSE= MIT
-RUN_DEPENDS= node:www/node
+USES= nodejs:run
NO_BUILD= yes
NO_ARCH= yes
diff --git a/devel/rubygem-execjs/Makefile b/devel/rubygem-execjs/Makefile
index 846fd4683b73..1bb2eacf794b 100644
--- a/devel/rubygem-execjs/Makefile
+++ b/devel/rubygem-execjs/Makefile
@@ -12,22 +12,11 @@ COMMENT= ExecJS lets you run JavaScript code from Ruby
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
-USES= gem
+USES= gem nodejs:run
USE_RUBY= yes
NO_ARCH= yes
-OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE NODE14 NODE16
-OPTIONS_DEFAULT=NODE
-NODE_DESC= Use www/node as backend
-NODE14_DESC= Use www/node14 as backend
-NODE16_DESC= Use www/node16 as backend
-
-NODE_RUN_DEPENDS= node>=0:www/node
-NODE14_RUN_DEPENDS= node14>=0:www/node14
-NODE16_RUN_DEPENDS= node16>=0:www/node16
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/lib/execjs/runtimes.rb
diff --git a/devel/sonar-scanner-cli/Makefile b/devel/sonar-scanner-cli/Makefile
index 06cc26d1b948..7d9183ab9fd5 100644
--- a/devel/sonar-scanner-cli/Makefile
+++ b/devel/sonar-scanner-cli/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sonar-scanner-cli
DISTVERSION= 4.4.0.2170
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel security www java
MASTER_SITES= https://binaries.sonarsource.com/Distribution/${PORTNAME}/
@@ -10,9 +10,7 @@ COMMENT= Scanner component of SonarQube
LICENSE= LGPL3
# node -> JS analysis
-RUN_DEPENDS= node:www/node
-
-USES= cpe zip
+USES= cpe nodejs:run zip
CPE_VENDOR= sonarsource
CPE_PRODUCT= sonarqube_scanner
USE_JAVA= yes
diff --git a/lang/coffeescript/Makefile b/lang/coffeescript/Makefile
index 23c22a7f3d1b..30e1d8781516 100644
--- a/lang/coffeescript/Makefile
+++ b/lang/coffeescript/Makefile
@@ -1,5 +1,6 @@
PORTNAME= coffeescript
DISTVERSION= 2.6.1
+PORTREVISION= 1
CATEGORIES= lang
MAINTAINER= egypcio@FreeBSD.org
@@ -8,8 +9,7 @@ COMMENT= Unfancy JavaScript
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= node:www/node
-
+USES= nodejs:run
USE_GITHUB= yes
GH_ACCOUNT= jashkenas
diff --git a/net/cjdns/Makefile b/net/cjdns/Makefile
index 71b31f5a14d6..c996f1cc1e9c 100644
--- a/net/cjdns/Makefile
+++ b/net/cjdns/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cjdns
DISTVERSIONPREFIX= cjdns-v
DISTVERSION= 21.1
+PORTREVISION= 1
CATEGORIES= net security
MAINTAINER= yuri@FreeBSD.org
@@ -11,10 +12,9 @@ COMMENT= Routing engine designed for security, scalability, speed
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= node:www/node \
- bash:shells/bash
+BUILD_DEPENDS= bash:shells/bash
-USES= gmake python
+USES= gmake nodejs:build python
USE_GITHUB= yes
GH_ACCOUNT= cjdelisle
USE_RC_SUBR= cjdns
diff --git a/security/greenbone-security-assistant/Makefile b/security/greenbone-security-assistant/Makefile
index ca8641f3d6a1..f47352d64783 100644
--- a/security/greenbone-security-assistant/Makefile
+++ b/security/greenbone-security-assistant/Makefile
@@ -1,6 +1,7 @@
PORTNAME= greenbone-security-assistant
DISTVERSIONPREFIX= v
DISTVERSION= 21.4.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= LOCAL/acm/gsa/:yarn_cache
DISTFILES= ${PORTNAME}-cache${EXTRACT_SUFX}:yarn_cache
@@ -10,8 +11,7 @@ COMMENT= Libraries module for the GVM solution
LICENSE= AGPLv3+
-BUILD_DEPENDS= node:www/node16 \
- yarn:www/yarn-node16
+BUILD_DEPENDS= yarn:www/yarn
LIB_DEPENDS= libgvm_base.so:security/gvm-libs \
libgnutls.so:security/gnutls \
libgcrypt.so:security/libgcrypt \
@@ -20,7 +20,7 @@ LIB_DEPENDS= libgvm_base.so:security/gvm-libs \
RUN_DEPENDS= doxygen>0:devel/doxygen \
${PYTHON_PKGNAMEPREFIX}polib>=0:devel/py-polib@${PY_FLAVOR}
-USES= cmake gettext-runtime gnome pkgconfig python
+USES= cmake gettext-runtime gnome nodejs:build pkgconfig python
USE_GNOME= glib20 libxml2
USE_GITHUB= yes
diff --git a/textproc/kibana6/Makefile b/textproc/kibana6/Makefile
index bbe030c9beba..32cc7f02bc8f 100644
--- a/textproc/kibana6/Makefile
+++ b/textproc/kibana6/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kibana
PORTVERSION= 6.8.16
+PORTREVISION= 1
DISTVERSIONSUFFIX= -darwin-x86_64
CATEGORIES= textproc www
MASTER_SITES= https://artifacts.elastic.co/downloads/kibana/ \
@@ -14,9 +15,7 @@ LICENSE= APACHE20
DEPRECATED= Uses EOL Python 2.7 via www/node10
EXPIRATION_DATE= 2021-06-23
-RUN_DEPENDS= node10>=10.15.2:www/node10
-
-USES= cpe
+USES= cpe nodejs:run,10
CPE_VENDOR= elastic
USE_RC_SUBR= ${PORTNAME}
diff --git a/textproc/kibana7/Makefile b/textproc/kibana7/Makefile
index ad61fc51bb79..f70c2b424426 100644
--- a/textproc/kibana7/Makefile
+++ b/textproc/kibana7/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kibana
PORTVERSION= 7.15.1
DISTVERSIONSUFFIX= -darwin-x86_64
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc www
MASTER_SITES= https://artifacts.elastic.co/downloads/kibana/ \
http://artifacts.elastic.co/downloads/kibana/
@@ -15,13 +15,11 @@ COMMENT= Browser based analytics and search interface to ElasticSearch
LICENSE= APACHE20
-BUILD_DEPENDS= node14>=14.17.6:www/node14 \
- npm-node14>0:www/npm-node14
+BUILD_DEPENDS= npm-node14>0:www/npm-node14
LIB_DEPENDS= libre2.so:devel/re2 \
libuv.so:devel/libuv
-RUN_DEPENDS= node14>=14.17.6:www/node14
-USES= compiler:c++14-lang cpe python:build
+USES= compiler:c++14-lang cpe nodejs:14,build,run python:build
CPE_VENDOR= elastic
USE_GITHUB= nodefault
diff --git a/textproc/opensearch-dashboards/Makefile b/textproc/opensearch-dashboards/Makefile
index ae583c47b88f..b0c5963fbe65 100644
--- a/textproc/opensearch-dashboards/Makefile
+++ b/textproc/opensearch-dashboards/Makefile
@@ -1,5 +1,6 @@
PORTNAME= opensearch-dashboards
DISTVERSION= 1.1.0
+PORTREVISION= 1
DISTVERSIONSUFFIX= -linux-x64
CATEGORIES= textproc www
MASTER_SITES= https://artifacts.opensearch.org/releases/bundle/${PORTNAME}/${DISTVERSION}/
@@ -10,11 +11,9 @@ COMMENT= Visualization dashboards for OpenSearch
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= node14>=14.17.0:www/node14 \
- npm-node14>0:www/npm-node14
-RUN_DEPENDS= node14>=14.17.0:www/node14
+BUILD_DEPENDS= npm-node14>0:www/npm-node14
-USES= python:build
+USES= nodejs:14,build,run python:build
USE_RC_SUBR= ${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/www/Makefile b/www/Makefile
index 6f76ea165aa2..6f4c563ce1f5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -466,6 +466,7 @@
SUBDIR += npm
SUBDIR += npm-node14
SUBDIR += npm-node16
+ SUBDIR += npm-node17
SUBDIR += nspluginwrapper
SUBDIR += oauth2-proxy
SUBDIR += obhttpd
@@ -2366,6 +2367,7 @@
SUBDIR += yarn
SUBDIR += yarn-node14
SUBDIR += yarn-node16
+ SUBDIR += yarn-node17
SUBDIR += yarr
SUBDIR += yaws
SUBDIR += you-get
diff --git a/www/csso/Makefile b/www/csso/Makefile
index 4f409d98c185..77536e61eca5 100644
--- a/www/csso/Makefile
+++ b/www/csso/Makefile
@@ -3,7 +3,7 @@
PORTNAME= csso
PORTVERSION= 1.3.9
DISTVERSIONPREFIX= v
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nivit.altervista.org/FreeBSD/ports/distfiles/
@@ -13,7 +13,7 @@ COMMENT= CSS optimizer
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/MIT-LICENSE.txt
-RUN_DEPENDS= node:www/node
+USES= nodejs:run
GH_ACCOUNT= css
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 159e6f139c1b..b0ff3f2691ec 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -21,7 +21,7 @@ MY_DEPENDS= git>=2.32.0:devel/git \
gitlab-shell>=13.21.1:devel/gitlab-shell \
gitlab-workhorse>=${PORTVERSION}:www/gitlab-workhorse \
redis>=6.0.14:databases/redis \
- yarn-node16>=1.10.0:www/yarn-node16 \
+ yarn>=1.10.0:www/yarn \
gtar>0:archivers/gtar \
bash>0:shells/bash \
rubygem-rails61>=6.1.4.1<6.1.4.2:www/rubygem-rails61 \
diff --git a/www/npm-node14/Makefile b/www/npm-node14/Makefile
index 4d78d3e6e2e2..59e32cf752cf 100644
--- a/www/npm-node14/Makefile
+++ b/www/npm-node14/Makefile
@@ -2,10 +2,9 @@
PKGNAMESUFFIX= -node14
-CONFLICTS_INSTALL= npm npm-node16
+CONFLICTS_INSTALL= npm npm-node16 npm-node17
-OPTIONS_EXCLUDE=NODE NODE16
-OPTIONS_SLAVE= NODE14
+USES= nodejs:14,run
MASTERDIR= ${.CURDIR}/../npm
diff --git a/www/npm-node16/Makefile b/www/npm-node16/Makefile
index 3af2c351843c..3116cc72f6d0 100644
--- a/www/npm-node16/Makefile
+++ b/www/npm-node16/Makefile
@@ -2,10 +2,9 @@
PKGNAMESUFFIX= -node16
-CONFLICTS_INSTALL= npm
+CONFLICTS_INSTALL= npm npm-node14 npm-node17
-OPTIONS_EXCLUDE=NODE NODE14
-OPTIONS_SLAVE= NODE16
+USES= nodejs:16,run
MASTERDIR= ${.CURDIR}/../npm
diff --git a/www/npm-node17/Makefile b/www/npm-node17/Makefile
new file mode 100644
index 000000000000..b7ec6ececfde
--- /dev/null
+++ b/www/npm-node17/Makefile
@@ -0,0 +1,11 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PKGNAMESUFFIX= -node17
+
+CONFLICTS_INSTALL= npm npm-node14 npm-node16
+
+USES= nodejs:17,run
+
+MASTERDIR= ${.CURDIR}/../npm
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 24c6ada8b40a..6493e13eac54 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -2,6 +2,7 @@
PORTNAME= npm
PORTVERSION= 6.14.8
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -13,30 +14,20 @@ LICENSE_FILE= ${WRKSRC}/lib/node_modules/npm/LICENSE
RUN_DEPENDS= gmake:devel/gmake
-USES= cpe python:3.5+ shebangfix tar:xz
+USES?= nodejs:run
+USES+= cpe python:3.5+ shebangfix tar:xz
NO_ARCH= yes
NO_BUILD= yes
REINPLACE_ARGS= -i ''
-CONFLICTS_INSTALL?= npm-node14 npm-node16
-
-OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE NODE14 NODE16
-OPTIONS_DEFAULT=NODE
-NODE_DESC= Use www/node as backend
-NODE14_DESC= Use www/node14 as backend
-NODE16_DESC= Use www/node16 as backend
+CONFLICTS_INSTALL?= npm-node14 npm-node16 npm-node17
CPE_VENDOR= npmjs
SHEBANG_GLOB= *.py
SHEBANG_FILES= lib/node_modules/npm/node_modules/node-gyp/gyp/samples/samples
-NODE_RUN_DEPENDS= node>=0.8.0:www/node
-NODE14_RUN_DEPENDS= node14>=0.8.0:www/node14
-NODE16_RUN_DEPENDS= node16>=0.8.0:www/node16
-
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
diff --git a/www/yarn-node14/Makefile b/www/yarn-node14/Makefile
index b5020fea1fea..63095b3354cb 100644
--- a/www/yarn-node14/Makefile
+++ b/www/yarn-node14/Makefile
@@ -2,10 +2,9 @@
PKGNAMESUFFIX= -node14
-CONFLICTS_INSTALL= yarn
+CONFLICTS_INSTALL= yarn yarn-node16 yarn-node17
-OPTIONS_EXCLUDE= NODE NODE16
-OPTIONS_SLAVE= NODE14
+USES= nodejs:14,run
MASTERDIR= ${.CURDIR}/../yarn
diff --git a/www/yarn-node16/Makefile b/www/yarn-node16/Makefile
index a082a498a15d..4864ad171d19 100644
--- a/www/yarn-node16/Makefile
+++ b/www/yarn-node16/Makefile
@@ -2,10 +2,9 @@
PKGNAMESUFFIX= -node16
-CONFLICTS_INSTALL= yarn
+CONFLICTS_INSTALL= yarn yarn-node14 yarn-node17
-OPTIONS_EXCLUDE= NODE NODE14
-OPTIONS_SLAVE= NODE16
+USES= nodejs:16,run
MASTERDIR= ${.CURDIR}/../yarn
diff --git a/www/yarn-node17/Makefile b/www/yarn-node17/Makefile
new file mode 100644
index 000000000000..fcaecbdfef81
--- /dev/null
+++ b/www/yarn-node17/Makefile
@@ -0,0 +1,11 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PKGNAMESUFFIX= -node17
+
+CONFLICTS_INSTALL= yarn yarn-node14 yarn-node16
+
+USES= nodejs:17,run
+
+MASTERDIR= ${.CURDIR}/../yarn
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/yarn/Makefile b/www/yarn/Makefile
index 31a0bac42337..0e45fa1e1982 100644
--- a/www/yarn/Makefile
+++ b/www/yarn/Makefile
@@ -1,7 +1,7 @@
PORTNAME= yarn
DISTVERSIONPREFIX= v
DISTVERSION= 1.22.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://yarnpkg.com/downloads/${PORTVERSION}/
@@ -11,26 +11,17 @@ COMMENT= Package manager for node, alternative to npm
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cpe
+USES?= nodejs:run
+USES+= cpe
CPE_VENDOR= ${PORTNAME}pkg
-CONFLICTS_INSTALL?= yarn-node16 yarn-node14 yarn-node10
+CONFLICTS_INSTALL?= yarn-node17 yarn-node16 yarn-node14
OPTIONS_DEFINE= HADOOPCOMPAT
-OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE16 NODE14 NODE
-OPTIONS_DEFAULT= NODE
HADOOPCOMPAT_DESC= hadoop2 compatibility, the yarn script is excluded
-NODE_DESC= Use www/node as backend
-NODE14_DESC= Use www/node14 as backend
-NODE16_DESC= Use www/node16 as backend
OPTIONS_SUB= yes
-NODE_RUN_DEPENDS= node>=0.8.0:www/node
-NODE14_RUN_DEPENDS= node14>=14.0.0:www/node14
-NODE16_RUN_DEPENDS= node16>=16.0.0:www/node16
-
HADOOPCOMPAT_CONFLICTS_INSTALL_OFF= hadoop2*
NO_ARCH= yes