aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2022-11-28 10:03:43 +0000
committerNicola Vitale <nivit@FreeBSD.org>2022-11-28 10:03:43 +0000
commitf5c0096b9f28798d8a7e469b380d521413746511 (patch)
tree10fb48b73efa2c601d1023bbfe22649289421b2a
parenta439683d94c6b41a8251df30ba6fa55d6e81a79b (diff)
devel/py-virtualenv: Don't use sphinx_build command
- In the next versions of devel/sphinx "The ``build_sphinx`` sub-command for setup.py is marked as deprecated to follow the policy of setuptools team". So prepare the port, and use the executable bin/sphinx-build directly. [1] Refs: https://github.com/sphinx-doc/sphinx/blob/0663602bb95e650975d95b5b87f5f26189b9b27c/sphinx/setup_command.py#L144 https://github.com/sphinx-doc/sphinx/commit/0663602bb95e650975d95b5b87f5f26189b9b27c https://github.com/sphinx-doc/sphinx/issues/9595 - Add a manpage to the documentation - Bump PORTREVISION (pkg-plist changed) PR: 268016 Reported by: Sean Champ <lab+bsd@thinkum.space> [1]
-rw-r--r--devel/py-virtualenv/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/py-virtualenv/Makefile b/devel/py-virtualenv/Makefile
index 3c13b8eebd54..9c42df33ae64 100644
--- a/devel/py-virtualenv/Makefile
+++ b/devel/py-virtualenv/Makefile
@@ -1,6 +1,6 @@
PORTNAME= virtualenv
PORTVERSION= 20.16.7
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -53,7 +53,8 @@ DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click-default-group>0:devel/py-click-
${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}towncrier>=22.8.0:textproc/py-towncrier@${PY_FLAVOR}
DOCS_BINARY_ALIAS= towncrier=towncrier-${PYTHON_VER}
-DOCS_PORTDOCS= *
+DOCS_PLIST_FILES= man/man1/virtualenv.1.gz
+DOCS_PORTDOCS= * .buildinfo
# Note: we install a temporary egg_info so that virtualenv can discover its stuff,
# while sphinx builds docs. Otherwise an Exception occurs:
#
@@ -61,12 +62,11 @@ DOCS_PORTDOCS= *
# default=next(iter(choices)),
# StopIteration
#
-DOCS_VARS= PYDISTUTILS_BUILD_TARGET="build install_egg_info --install-dir build/lib build_sphinx"
+DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="install_egg_info --install-dir build/lib"
post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC}/build/sphinx/html && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -or -name objects.inv")
+ ${LOCALBASE}/bin/sphinx-build -d ${WRKDIR} -b html -n ${WRKSRC}/docs ${STAGEDIR}${DOCSDIR}
+ ${LOCALBASE}/bin/sphinx-build -d ${WRKDIR} -b man -n ${WRKSRC}/docs ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.pre.mk>