aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-09-29 20:11:22 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-09-29 20:11:22 +0000
commitf5ebd23a61c055722b1370d39689c0155750ceae (patch)
tree9f6ee7990156009ac5fb32a1b518a8a838549dbb
parent56b17331ce3b7f9fb6695a743cb32fe5d8692e15 (diff)
downloadports-f5ebd23a61c055722b1370d39689c0155750ceae.tar.gz
ports-f5ebd23a61c055722b1370d39689c0155750ceae.zip
Remove libXp dependency from imake/motif ports
Remove the libXp dependency from a number of ports using imake and/or motif. libXp is being deprecated. The list of ports: audio/xmcd audio/xmmix deskutils/xmdiary ftp/llnlxdir ftp/llnlxftp graphics/SciPlot misc/xtar multimedia/mpeg2play
Notes
Notes: svn path=/head/; revision=513269
-rw-r--r--audio/xmcd/Makefile6
-rw-r--r--audio/xmmix/Makefile6
-rw-r--r--deskutils/xmdiary/Makefile6
-rw-r--r--ftp/llnlxdir/Makefile6
-rw-r--r--ftp/llnlxftp/Makefile6
-rw-r--r--graphics/SciPlot/Makefile6
-rw-r--r--misc/xtar/Makefile6
-rw-r--r--multimedia/mpeg2play/Makefile6
8 files changed, 16 insertions, 32 deletions
diff --git a/audio/xmcd/Makefile b/audio/xmcd/Makefile
index 8687393825aa..94dae87da79b 100644
--- a/audio/xmcd/Makefile
+++ b/audio/xmcd/Makefile
@@ -3,21 +3,19 @@
PORTNAME= xmcd
PORTVERSION= 3.3.2
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= audio
MASTER_SITES= http://freebsd.nsu.ru/distfiles/
MAINTAINER= ports@FreeBSD.org
COMMENT= Motif CD player
-DEPRECATED= Depends on deprecated libXp
-
LIB_DEPENDS+= libvorbis.so:audio/libvorbis \
libFLAC.so:audio/flac
RUN_DEPENDS+= lame:audio/lame
USES= imake motif ncurses xorg
-USE_XORG= x11 xext xaw xmu xp xpm xt sm ice
+USE_XORG= x11 xext xaw xmu xpm xt sm ice
PLIST_SUB+= RELEASE=${OSREL:R:R} ARCH=${ARCH:S/powerpc64/powerpc/} OPSYS=${OPSYS}
SUB_FILES= pkg-message
diff --git a/audio/xmmix/Makefile b/audio/xmmix/Makefile
index d076b91c9848..9312fc33d5e3 100644
--- a/audio/xmmix/Makefile
+++ b/audio/xmmix/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmmix
PORTVERSION= 1.2.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://ftp.twaren.net/BSD/OpenBSD/distfiles/ \
http://freebsd.nsu.ru/distfiles/
@@ -11,12 +11,10 @@ MASTER_SITES= http://ftp.twaren.net/BSD/OpenBSD/distfiles/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Motif-based audio mixer
-DEPRECATED= Depends on deprecated libXp
-
WRKSRC= ${WRKDIR}/xmmix-1.2
USES= imake motif xorg
-USE_XORG= x11 xext sm ice xt xp
+USE_XORG= x11 xext sm ice xt
PLIST_FILES= bin/xmmix lib/X11/app-defaults/XMmix lib/X11/xmmix.hlp \
man/man1/xmmix.1.gz
diff --git a/deskutils/xmdiary/Makefile b/deskutils/xmdiary/Makefile
index b289a10767bb..38aea77ad1c2 100644
--- a/deskutils/xmdiary/Makefile
+++ b/deskutils/xmdiary/Makefile
@@ -3,18 +3,16 @@
PORTNAME= xmdiary
PORTVERSION= 3.0.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= deskutils
MASTER_SITES= XCONTRIB/office
MAINTAINER= mi@aldan.algebra.com
COMMENT= Personal and group calendar utility
-DEPRECATED= Depends on deprecated libXp
-
NO_CDROM= Do not sell for profit
USES= imake motif xorg
-USE_XORG= x11 xext xp xpm xt
+USE_XORG= x11 xext xpm xt
post-patch:
@${REINPLACE_CMD} -e 's/malloc\.h/stdlib.h/' \
diff --git a/ftp/llnlxdir/Makefile b/ftp/llnlxdir/Makefile
index 0cd20b26ab18..5d8ec6c22c32 100644
--- a/ftp/llnlxdir/Makefile
+++ b/ftp/llnlxdir/Makefile
@@ -3,7 +3,7 @@
PORTNAME= llnlxdir
PORTVERSION= 2.1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp
MASTER_SITES= https://computing.llnl.gov/resources/xdir/
DISTNAME= llnlxdir2_1_2
@@ -11,12 +11,10 @@ DISTNAME= llnlxdir2_1_2
MAINTAINER= cy@FreeBSD.org
COMMENT= Motif FTP client with drag-and-drop file transfer
-DEPRECATED= Depends on deprecated libXp
-
PLIST_FILES= bin/xdir lib/X11/app-defaults/XDir man/man1/xdir.1.gz
WRKSRC= ${WRKDIR}/llnlxdir2_1_2/sources
USES= imake motif tar:Z xorg
-USE_XORG= ice sm x11 xext xp xt
+USE_XORG= ice sm x11 xext xt
.include <bsd.port.mk>
diff --git a/ftp/llnlxftp/Makefile b/ftp/llnlxftp/Makefile
index 2dab7cf0a722..6eff69b21888 100644
--- a/ftp/llnlxftp/Makefile
+++ b/ftp/llnlxftp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= llnlxftp
PORTVERSION= 2.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= ftp
MASTER_SITES= https://computing.llnl.gov/resources/xdir/
DISTNAME= llnlxftp2.1
@@ -11,13 +11,11 @@ DISTNAME= llnlxftp2.1
MAINTAINER= cy@FreeBSD.org
COMMENT= Motif FTP client
-DEPRECATED= Depends on deprecated libXp
-
PLIST_FILES= bin/xftp lib/X11/app-defaults/XFtp \
man/man1/xftp.1.gz
WRKSRC= ${WRKDIR}/llnlxftp2.1/sources
USES= imake motif tar:Z xorg
-USE_XORG= ice sm x11 xext xp xt
+USE_XORG= ice sm x11 xext xt
CFLAGS+= -Wno-implicit-int \
-Wno-implicit-function-declaration \
diff --git a/graphics/SciPlot/Makefile b/graphics/SciPlot/Makefile
index 0af5d7878032..2249172b25c0 100644
--- a/graphics/SciPlot/Makefile
+++ b/graphics/SciPlot/Makefile
@@ -3,19 +3,17 @@
PORTNAME= SciPlot
PORTVERSION= 1.36
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics math
MASTER_SITES= XCONTRIB/widgets
MAINTAINER= thierry@FreeBSD.org
COMMENT= Full-featured Xt widget to display 2D data in a graph
-DEPRECATED= Depends on deprecated libXp
-
LICENSE= GPLv2
USES= imake motif xorg
-USE_XORG= xp xt x11
+USE_XORG= xt x11
MAKE_ENV= EXTRA_DEFINES="-fPIC" LIBNAME=${LIBNAME}
USE_LDCONFIG= yes
diff --git a/misc/xtar/Makefile b/misc/xtar/Makefile
index bfdd76a4e93f..afb6114faa64 100644
--- a/misc/xtar/Makefile
+++ b/misc/xtar/Makefile
@@ -3,17 +3,15 @@
PORTNAME= xtar
PORTVERSION= 1.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= misc
MASTER_SITES= XCONTRIB/utilities
MAINTAINER= ports@FreeBSD.org
COMMENT= View and manipulate contents of a tar file
-DEPRECATED= Depends on deprecated libXp
-
USES= motif xorg
-USE_XORG= ice sm x11 xext xp xt
+USE_XORG= ice sm x11 xext xt
MAKEFILE= Makefile.noimake
ALL_TARGET= ${PORTNAME}
MAKE_ARGS= XINC="-I${LOCALBASE}/include" XMLIB="${MOTIFLIB}" \
diff --git a/multimedia/mpeg2play/Makefile b/multimedia/mpeg2play/Makefile
index 6c9840d7dd8e..8bb5b3204820 100644
--- a/multimedia/mpeg2play/Makefile
+++ b/multimedia/mpeg2play/Makefile
@@ -3,17 +3,15 @@
PORTNAME= mpeg2play
PORTVERSION= 1.1b
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.funet.fi/pub/graphics/packages/mpeg/mpeg2play/
MAINTAINER= ports@FreeBSD.org
COMMENT= Program to play mpeg-2 movies on X displays
-DEPRECATED= Depends on deprecated libXp
-
USES= imake motif xorg
-USE_XORG= x11 xext xp xt
+USE_XORG= x11 xext xt
ALL_TARGET= mpeg2play
OPTIONS_DEFINE= DOCS