aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-03 15:39:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-03 19:06:27 +0000
commitf5f6076279efd00a921a3f244f2abce008e0b3be (patch)
tree6fe4b70734f6aa39adb1108aa63280c045ec77bf
parent1f3e72b3f6f9b79ad1aa36881ff1ab8c00daaf83 (diff)
downloadports-f5f6076279efd00a921a3f244f2abce008e0b3be.tar.gz
ports-f5f6076279efd00a921a3f244f2abce008e0b3be.zip
shells/nushell: Add tests; Add DATAFRAME option
-rw-r--r--shells/nushell/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/shells/nushell/Makefile b/shells/nushell/Makefile
index f286f90f1ac2..a95fbebc4f63 100644
--- a/shells/nushell/Makefile
+++ b/shells/nushell/Makefile
@@ -1,5 +1,6 @@
PORTNAME= nushell
DISTVERSION= 0.73.0
+PORTREVISION= 1
CATEGORIES= shells
MAINTAINER= yuri@FreeBSD.org
@@ -9,7 +10,7 @@ WWW= https://www.nushell.sh/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cargo ssl
+USES= cargo localbase ssl
USE_GITHUB= yes
@@ -572,7 +573,16 @@ OPENSSLLIB= /usr/lib
PLIST_FILES= bin/nu
+OPTIONS_DEFINE= DATAFRAME
+
+DATAFRAME_DESC= Include the dataframe feature
+DATAFRAME_VARS= CARGO_BUILD_ARGS+=--features=dataframe
+DATAFRAME_BROKEN= see https://github.com/nushell/nushell/issues/7665
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/nu
+do-test:
+ @${CARGO_CARGO_RUN} test --workspace
+
.include <bsd.port.mk>