aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-01-05 11:19:16 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-01-05 11:19:16 +0000
commitf620082c13d85208d718bfcd2ae49f2a825e164b (patch)
tree054caaeacc51d4d8ca331c218725177b7fec495d
parent27a06e32a6497c9162b740d2c24f98ace53cd780 (diff)
downloadports-f620082c13d85208d718bfcd2ae49f2a825e164b.tar.gz
ports-f620082c13d85208d718bfcd2ae49f2a825e164b.zip
Fix runtime. The Makefile.PL version of the build is ignoring all the XS glue.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=376292
-rw-r--r--graphics/p5-GD/Makefile12
-rw-r--r--graphics/p5-GD/files/patch-Build.PL43
-rw-r--r--graphics/p5-GD/pkg-plist19
3 files changed, 57 insertions, 17 deletions
diff --git a/graphics/p5-GD/Makefile b/graphics/p5-GD/Makefile
index 39f4b48cbe0e..8e0c440409c3 100644
--- a/graphics/p5-GD/Makefile
+++ b/graphics/p5-GD/Makefile
@@ -2,6 +2,7 @@
PORTNAME= GD
PORTVERSION= 2.56
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,16 +15,7 @@ LICENSE_COMB= dual
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
-CONFIGURE_ENV= options="FT,GIF,JPEG,PNG,XPM" \
- lib_ft_path=${LOCALBASE} \
- lib_gd_path=${LOCALBASE} \
- lib_jpeg_path=${LOCALBASE} \
- lib_png_path=${LOCALBASE} \
- lib_zlib_path=/usr
USES= perl5
-USE_PERL5= configure
-
-post-patch:
- @${CHMOD} u+w ${WRKSRC}/bdf_scripts/bdf2gdfont.pl
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/graphics/p5-GD/files/patch-Build.PL b/graphics/p5-GD/files/patch-Build.PL
new file mode 100644
index 000000000000..a54ac5c7fa66
--- /dev/null
+++ b/graphics/p5-GD/files/patch-Build.PL
@@ -0,0 +1,43 @@
+--- Build.PL.orig 2014-10-28 01:34:54 UTC
++++ Build.PL
+@@ -28,40 +28,6 @@ if (-d '/usr/lib64') {
+ @LIBPATH = (@LIBPATH,@libs64);
+ }
+
+-#############################################################################################
+-# Build options passed in to script to support reproducible builds via Makefiles
+-#############################################################################################
+-my $result = GetOptions("options=s" => \$options,
+- "lib_gd_path=s" => \$lib_gd_path,
+- "lib_ft_path=s" => \$lib_ft_path,
+- "lib_png_path=s" => \$lib_png_path,
+- "lib_jpeg_path=s" => \$lib_jpeg_path,
+- "lib_xpm_path=s" => \$lib_xpm_path,
+- "lib_zlib_path=s" => \$lib_zlib_path,
+- );
+-unless ($result) {
+- die <<END;
+-Usage: perl Build.PL [options]
+-
+-Configure GD module.
+-
+- Options:
+- -options "JPEG,FT,PNG,GIF,XPM,ANIMGIF" feature options, separated by commas
+- -lib_gd_path path path to libgd
+- -lib_ft_path path path to Freetype library
+- -lib_png_path path path to libpng
+- -lib_jpeg_path path path to libjpeg
+- -lib_xpm_path path path to libxpm
+- -lib_zlib_path path path to libpng
+- -ignore_missing_gd Ignore missing or old libgd installations and try to compile anyway
+-
+-If no options are passed on the command line. The program will
+-attempt to autoconfigure itself with the gdlib-config program (present
+-in GD versions 2.0.27 or later). Otherwise it will prompt for these
+-values interactively.
+-END
+-}
+-
+ if( defined($options) )
+ {
+ print "Included Features: $options\n";
diff --git a/graphics/p5-GD/pkg-plist b/graphics/p5-GD/pkg-plist
index da9ae6fbb8cf..6efbb0cc08f4 100644
--- a/graphics/p5-GD/pkg-plist
+++ b/graphics/p5-GD/pkg-plist
@@ -1,14 +1,19 @@
+@comment bin/README
+@comment bin/bdf2gdfont.PLS
bin/bdf2gdfont.pl
-%%SITE_PERL%%/GD.pm
-%%SITE_PERL%%/GD/Group.pm
-%%SITE_PERL%%/GD/Image.pm
-%%SITE_PERL%%/GD/Polygon.pm
-%%SITE_PERL%%/GD/Polyline.pm
-%%SITE_PERL%%/GD/Simple.pm
-%%SITE_PERL%%/auto/GD/autosplit.ix
+bin/bdftogd
+@comment bin/cvtbdf.pl
+%%SITE_ARCH%%/GD.pm
+%%SITE_ARCH%%/GD/Group.pm
+%%SITE_ARCH%%/GD/Image.pm
+%%SITE_ARCH%%/GD/Polygon.pm
+%%SITE_ARCH%%/GD/Polyline.pm
+%%SITE_ARCH%%/GD/Simple.pm
+%%SITE_ARCH%%/auto/GD/GD.so
%%PERL5_MAN3%%/GD.3.gz
%%PERL5_MAN3%%/GD::Image.3.gz
%%PERL5_MAN3%%/GD::Polygon.3.gz
%%PERL5_MAN3%%/GD::Polyline.3.gz
%%PERL5_MAN3%%/GD::Simple.3.gz
+@comment man/man1/bdf2gdfont.PLS.1.gz
man/man1/bdf2gdfont.pl.1.gz