aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2023-12-22 07:01:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2023-12-22 07:01:36 +0000
commitf65dcbde97ed01982df5ce7c5152c4f862d3db05 (patch)
tree3e7cfb22ce154e311ae9f1201fdebcda05aabbe9
parentee17b111794643c9459b7cb223d0b68680a38bc3 (diff)
mail/sendmail-devel: Update to 8.18.0.2
-rw-r--r--mail/sendmail-devel/Makefile4
-rw-r--r--mail/sendmail-devel/distinfo6
-rw-r--r--mail/sendmail-devel/files/patch-sendmail.h16
-rw-r--r--mail/sendmail-devel/files/patch-srvrsmtp.c46
4 files changed, 41 insertions, 31 deletions
diff --git a/mail/sendmail-devel/Makefile b/mail/sendmail-devel/Makefile
index c75143cfacb3..453c1bfadba2 100644
--- a/mail/sendmail-devel/Makefile
+++ b/mail/sendmail-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sendmail
-PORTVERSION= 8.17.1.28
-PORTREVISION= 1
+PORTVERSION= 8.18.0.2
+PORTREVISION= 0
CATEGORIES= mail
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/snapshots/
PKGNAMESUFFIX?= -devel${PKGNAMESUFFIX2}
diff --git a/mail/sendmail-devel/distinfo b/mail/sendmail-devel/distinfo
index 88a311f408ed..f8e56900dee7 100644
--- a/mail/sendmail-devel/distinfo
+++ b/mail/sendmail-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1692158033
-SHA256 (sendmail.8.17.1.28.tar.gz) = 909c2a58772783aced1cd1be45f1a1af5b61b468775ca9d45c79568edca54719
-SIZE (sendmail.8.17.1.28.tar.gz) = 2312572
+TIMESTAMP = 1703097465
+SHA256 (sendmail.8.18.0.2.tar.gz) = b8f64c67f94dc6ff0f65498636f8f90b794e58ded15a05650a98115167b60773
+SIZE (sendmail.8.18.0.2.tar.gz) = 2330539
diff --git a/mail/sendmail-devel/files/patch-sendmail.h b/mail/sendmail-devel/files/patch-sendmail.h
index 448f0d15ddce..89a33cfff8a2 100644
--- a/mail/sendmail-devel/files/patch-sendmail.h
+++ b/mail/sendmail-devel/files/patch-sendmail.h
@@ -1,7 +1,7 @@
---- sendmail/sendmail.h.orig 2019-02-15 10:30:19 UTC
+--- sendmail/sendmail.h.orig 2023-12-05 09:53:22 UTC
+++ sendmail/sendmail.h
-@@ -61,6 +61,10 @@ SM_UNUSED(static char SmailId[]) = "@(#)
- #endif /* _DEFINE */
+@@ -73,6 +73,10 @@ SM_UNUSED(static char SmailId[]) = "@(#)$Id: sendmail.
+ #endif
#include "bf.h"
+#if USE_BLACKLIST
@@ -10,15 +10,15 @@
+#include "blacklist_client.h"
#include "timers.h"
#include <sm/exc.h>
- #include <sm/heap.h>
-@@ -2513,6 +2517,10 @@ EXTERN int Hacks; /* bit field of run-ti
+ #include <sm/gen.h>
+@@ -2734,6 +2738,10 @@ EXTERN int Hacks; /* bit field of run-time enabled "ha
+ #endif
EXTERN int ConnectionRateWindowSize;
-
++
+#if USE_BLACKLIST
+EXTERN bool UseBlacklist;
+#endif
-+
+
/*
** Declarations of useful functions
- */
diff --git a/mail/sendmail-devel/files/patch-srvrsmtp.c b/mail/sendmail-devel/files/patch-srvrsmtp.c
index 5ffa4eec4dbd..e4abbbf00a57 100644
--- a/mail/sendmail-devel/files/patch-srvrsmtp.c
+++ b/mail/sendmail-devel/files/patch-srvrsmtp.c
@@ -1,24 +1,34 @@
---- sendmail/srvrsmtp.c.orig 2019-02-15 10:30:19 UTC
+--- sendmail/srvrsmtp.c.orig 2023-12-05 09:53:22 UTC
+++ sendmail/srvrsmtp.c
-@@ -878,6 +878,9 @@ smtp(nullserver, d_flags, e)
- #if _FFR_BADRCPT_SHUTDOWN
- int n_badrcpts_adj;
+@@ -921,6 +921,9 @@ do \
+ # define SHOWCMDINREPLY(inp) inp
+ # define SHOWSHRTCMDINREPLY(inp) shortenstring(inp, MAXSHORTSTR)
#endif
+#ifdef USE_BLACKLIST
+ int saved_bl_fd;
+#endif
- RESET_AUTH_FAIL_LOG_USER;
- SevenBitInput_Saved = SevenBitInput;
-@@ -1377,6 +1380,7 @@ smtp(nullserver, d_flags, e)
- (int) tp.tv_sec +
- (tp.tv_usec >= 500000 ? 1 : 0)
+ void
+ smtp(nullserver, d_flags, e)
+@@ -1504,6 +1507,8 @@ smtp(nullserver, d_flags, e)
+ /* check if data is on the socket during the pause */
+ if ((tp = channel_readable(InChannel, msecs)) != NULL)
+ {
++ int fd;
++
+ greetcode = "554";
+ nullserver = "Command rejected";
+ sm_syslog(LOG_INFO, e->e_id,
+@@ -1513,6 +1518,8 @@ smtp(nullserver, d_flags, e)
+ (int) tp->tv_sec +
+ (tp->tv_usec >= 500000 ? 1 : 0)
);
++ fd = sm_io_getinfo(InChannel, SM_IO_WHAT_FD, NULL);
+ BLACKLIST_NOTIFY(BLACKLIST_AUTH_FAIL, fd, "pre-greeting traffic");
}
}
}
-@@ -1479,6 +1483,10 @@ smtp(nullserver, d_flags, e)
+@@ -1631,6 +1638,10 @@ smtp(nullserver, d_flags, e)
SmtpPhase = "server cmd read";
sm_setproctitle(true, e, "server %s cmd read", CurSmtpClient);
@@ -29,7 +39,7 @@
/* handle errors */
if (sm_io_error(OutChannel) ||
(p = sfgets(inp, sizeof(inp), InChannel,
-@@ -1792,8 +1800,11 @@ smtp(nullserver, d_flags, e)
+@@ -1944,8 +1955,11 @@ smtp(nullserver, d_flags, e)
#define LOGAUTHFAIL \
do \
{ \
@@ -41,7 +51,7 @@
if (LogLevel >= 9) \
sm_syslog(LOG_WARNING, e->e_id, \
"AUTH failure (%s): %s (%d) %s%s%.*s, relay=%.100s", \
-@@ -1943,6 +1954,9 @@ smtp(nullserver, d_flags, e)
+@@ -2095,6 +2109,9 @@ smtp(nullserver, d_flags, e)
DELAY_CONN("AUTH");
if (!sasl_ok || n_mechs <= 0)
{
@@ -51,7 +61,7 @@
message("503 5.3.3 AUTH not available");
break;
}
-@@ -3546,10 +3560,17 @@ doquit:
+@@ -3836,10 +3853,17 @@ smtp(nullserver, d_flags, e)
** timeouts for the same connection.
*/
@@ -69,7 +79,7 @@
if (tTd(93, 100))
{
/* return to handle next connection */
-@@ -3607,7 +3628,10 @@ doquit:
+@@ -3921,7 +3945,10 @@ smtp(nullserver, d_flags, e)
#if MAXBADCOMMANDS > 0
if (++n_badcmds > MAXBADCOMMANDS)
{
@@ -80,13 +90,13 @@
message("421 4.7.0 %s Too many bad commands; closing connection",
MyHostName);
-@@ -3659,6 +3683,9 @@ doquit:
+@@ -3975,6 +4002,9 @@ smtp(nullserver, d_flags, e)
+ }
#if SASL
}
- #endif
++#endif
+#ifdef USE_BLACKLIST
+ close(saved_bl_fd);
-+#endif
+ #endif
}
SM_EXCEPT(exc, "[!F]*")
- {