aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 18:10:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 18:25:11 +0000
commitf6a177696981ec69f8d3181863d50590594b1d86 (patch)
tree0ff3f411a33d5044b23bf266655ccb93dc85a9bd
parentb0b6c960682cd256cfe227b648971b66ef1f2038 (diff)
downloadports-f6a177696981ec69f8d3181863d50590594b1d86.tar.gz
ports-f6a177696981ec69f8d3181863d50590594b1d86.zip
net/speedtest: Mark CONFLICTS with net/py-speedtest-cli
Reported by: nivit
-rw-r--r--net/py-speedtest-cli/Makefile2
-rw-r--r--net/speedtest/Makefile2
2 files changed, 4 insertions, 0 deletions
diff --git a/net/py-speedtest-cli/Makefile b/net/py-speedtest-cli/Makefile
index 63f665a13501..cc2e19a2d6df 100644
--- a/net/py-speedtest-cli/Makefile
+++ b/net/py-speedtest-cli/Makefile
@@ -16,6 +16,8 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
+CONFLICTS_INSTALL= speedtest # bin/speedtest
+
OPTIONS_DEFINE= DOCS
PORTDOCS= README.rst
diff --git a/net/speedtest/Makefile b/net/speedtest/Makefile
index a2ecc77cf43d..d0b61aca533b 100644
--- a/net/speedtest/Makefile
+++ b/net/speedtest/Makefile
@@ -21,6 +21,8 @@ NO_WRKSUBDIR= yes
PLIST_FILES= bin/speedtest \
share/man/man5/speedtest.5.gz
+CONFLICTS_INSTALL= py*-speedtest-cli # bin/speedtest
+
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/bin/ ${STAGEDIR}${PREFIX}/share/man/man5/
${INSTALL_PROGRAM} ${WRKSRC}/usr/local/bin/speedtest ${STAGEDIR}${PREFIX}/bin/speedtest