aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-12-10 19:46:46 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-12-10 23:52:50 +0000
commitf6c8d421d3e9455a7ac291db237b93cce6c712d1 (patch)
tree231866fe4c120fc626ae8f426d3531910b61611f
parentc309175787d4a31edda219575bc6d944bc5fff68 (diff)
downloadports-f6c8d421d3e9455a7ac291db237b93cce6c712d1.tar.gz
ports-f6c8d421d3e9455a7ac291db237b93cce6c712d1.zip
x11/plasma5-plasma-workspace: fix errors in Wayland-script
These are fairly basic and silly shell-script errors in the startplasma-wayland.sh script (which might not even be needed, if you start KDE Plasma-wayland some other way). Derpy hat to me.
-rw-r--r--x11/plasma5-plasma-workspace/Makefile1
-rwxr-xr-xx11/plasma5-plasma-workspace/files/startplasma-wayland.sh4
2 files changed, 3 insertions, 2 deletions
diff --git a/x11/plasma5-plasma-workspace/Makefile b/x11/plasma5-plasma-workspace/Makefile
index 17602450cfbb..52f5b6beb89b 100644
--- a/x11/plasma5-plasma-workspace/Makefile
+++ b/x11/plasma5-plasma-workspace/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-workspace
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
diff --git a/x11/plasma5-plasma-workspace/files/startplasma-wayland.sh b/x11/plasma5-plasma-workspace/files/startplasma-wayland.sh
index b94c59f82efa..7f91ce9a10d5 100755
--- a/x11/plasma5-plasma-workspace/files/startplasma-wayland.sh
+++ b/x11/plasma5-plasma-workspace/files/startplasma-wayland.sh
@@ -52,7 +52,7 @@ fi
startup_dir=`/usr/bin/dirname "$0"`
startup_exe=`/usr/bin/basename "$0" .sh`
-if [ -z "$LOGFILE" ] ; then
+if [ -n "$LOGFILE" ] ; then
{
echo "Starting KDE Plasma Wayland from PID $$"
echo "XDG_RUNTIME_DIR=$XDG_RUNTIME_DIR"
@@ -60,7 +60,7 @@ if [ -z "$LOGFILE" ] ; then
echo "startup=$startup_dir/$startup_exe"
} > $LOGFILE
- exec $scaffolding $startup_dir/$startup_exe 2>&1 | tee -a $LOG
+ exec $scaffolding $startup_dir/$startup_exe 2>&1 | tee -a $LOGFILE
else
exec $scaffolding $startup_dir/$startup_exe
fi