aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2021-04-28 15:48:06 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2021-04-28 15:50:53 +0000
commitf6cdaa3c18cd9649f7928f6d7189545d56ed636c (patch)
tree0cf32dc3df54a0b24aa24bd68329b8b22f2e89fb
parent995b8d03bb276d0ade969c8a5a634ff86336fcc7 (diff)
downloadports-f6cdaa3c18cd9649f7928f6d7189545d56ed636c.tar.gz
ports-f6cdaa3c18cd9649f7928f6d7189545d56ed636c.zip
Update to 0.18.0
-rw-r--r--www/varnish-modules/Makefile6
-rw-r--r--www/varnish-modules/distinfo6
-rw-r--r--www/varnish-modules/files/patch-src_Makefile.am24
-rw-r--r--www/varnish-modules/pkg-plist4
4 files changed, 23 insertions, 17 deletions
diff --git a/www/varnish-modules/Makefile b/www/varnish-modules/Makefile
index 8f441433ed9e..08a27cf0e03f 100644
--- a/www/varnish-modules/Makefile
+++ b/www/varnish-modules/Makefile
@@ -1,7 +1,7 @@
# Created by: Mark Felder <feld@FreeBSD.org>
PORTNAME= varnish-modules
-PORTVERSION= 0.17.0
+PORTVERSION= 0.18.0
CATEGORIES= www
MAINTAINER= zi@FreeBSD.org
@@ -30,8 +30,10 @@ CFLAGS+= -Wno-error=deprecated-declarations
pre-configure:
cd ${WRKSRC} && ./bootstrap
+post-build-DOCS-on:
+ cd ${WRKSRC} && ${MAKE_CMD} rst-docs
+
post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} '-not -regex .*.man.rst'
.include <bsd.port.mk>
diff --git a/www/varnish-modules/distinfo b/www/varnish-modules/distinfo
index f7b26d5fa94c..dcdaa64a8e15 100644
--- a/www/varnish-modules/distinfo
+++ b/www/varnish-modules/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1605532253
-SHA256 (varnish-varnish-modules-0.17.0_GH0.tar.gz) = 5da9285ee2a746ea63d7f70f249613ff4de5936ae7b737bc80ea94b78a924cf4
-SIZE (varnish-varnish-modules-0.17.0_GH0.tar.gz) = 55591
+TIMESTAMP = 1619620789
+SHA256 (varnish-varnish-modules-0.18.0_GH0.tar.gz) = b226d3272bc92fb46175c417aca5a8c5f820baa2868961cae7d832b561fc159e
+SIZE (varnish-varnish-modules-0.18.0_GH0.tar.gz) = 53830
diff --git a/www/varnish-modules/files/patch-src_Makefile.am b/www/varnish-modules/files/patch-src_Makefile.am
index 6b80c2d9b0a6..b66acb9e9803 100644
--- a/www/varnish-modules/files/patch-src_Makefile.am
+++ b/www/varnish-modules/files/patch-src_Makefile.am
@@ -1,41 +1,41 @@
---- src/Makefile.am.orig 2020-11-16 14:55:16.098559000 +0100
-+++ src/Makefile.am 2020-11-16 15:00:45.451899000 +0100
-@@ -26,7 +26,6 @@ vmod_LTLIBRARIES = \
- libvmod_bodyaccess.la \
+--- src/Makefile.am.orig 2021-04-28 15:17:56 UTC
++++ src/Makefile.am
+@@ -28,7 +28,6 @@ vmod_LTLIBRARIES = \
libvmod_header.la \
libvmod_saintmode.la \
+ libvmod_str.la \
- libvmod_tcp.la \
libvmod_var.la \
libvmod_vsthrottle.la \
libvmod_xkey.la
-@@ -36,7 +35,6 @@ dist_man_MANS = \
- vmod_bodyaccess.3 \
+@@ -40,7 +39,6 @@ dist_man_MANS = \
vmod_header.3 \
vmod_saintmode.3 \
+ vmod_str.3 \
- vmod_tcp.3 \
vmod_var.3 \
vmod_vsthrottle.3 \
vmod_xkey.3
-@@ -48,7 +46,6 @@ libvmod_bodyaccess_la_SOURCES = vmod_bod
- libvmod_header_la_SOURCES = vmod_header.c
+@@ -54,7 +52,6 @@ libvmod_header_la_SOURCES = vmod_header.
libvmod_vsthrottle_la_SOURCES = vmod_vsthrottle.c
libvmod_saintmode_la_SOURCES = vmod_saintmode.c
+ libvmod_str_la_SOURCES = vmod_str.c
-libvmod_tcp_la_SOURCES = vmod_tcp.c
libvmod_var_la_SOURCES = vmod_var.c
libvmod_xkey_la_SOURCES = vmod_xkey.c
-@@ -56,7 +53,6 @@ nodist_libvmod_bodyaccess_la_SOURCES = v
- nodist_libvmod_header_la_SOURCES = vcc_header_if.c vcc_header_if.h
+@@ -64,7 +61,6 @@ nodist_libvmod_header_la_SOURCES = vcc_h
nodist_libvmod_vsthrottle_la_SOURCES = vcc_vsthrottle_if.c vcc_vsthrottle_if.h
nodist_libvmod_saintmode_la_SOURCES = vcc_saintmode_if.c vcc_saintmode_if.h
+ nodist_libvmod_str_la_SOURCES = vcc_str_if.c vcc_str_if.h
-nodist_libvmod_tcp_la_SOURCES = vcc_tcp_if.c vcc_tcp_if.h
nodist_libvmod_var_la_SOURCES = vcc_var_if.c vcc_var_if.h
nodist_libvmod_xkey_la_SOURCES = vcc_xkey_if.c vcc_xkey_if.h VSC_xkey.c VSC_xkey.h
-@@ -144,7 +140,6 @@ EXTRA_DIST = \
- vmod_bodyaccess.vcc \
+@@ -168,7 +164,6 @@ EXTRA_DIST = \
vmod_header.vcc \
vmod_saintmode.vcc \
+ vmod_str.vcc \
- vmod_tcp.vcc \
vmod_var.vcc \
vmod_vsthrottle.vcc \
diff --git a/www/varnish-modules/pkg-plist b/www/varnish-modules/pkg-plist
index eb7da221ff0d..a7ce95c4dd4c 100644
--- a/www/varnish-modules/pkg-plist
+++ b/www/varnish-modules/pkg-plist
@@ -1,12 +1,16 @@
+lib/varnish/vmods/libvmod_accept.so
lib/varnish/vmods/libvmod_bodyaccess.so
lib/varnish/vmods/libvmod_header.so
lib/varnish/vmods/libvmod_saintmode.so
+lib/varnish/vmods/libvmod_str.so
lib/varnish/vmods/libvmod_var.so
lib/varnish/vmods/libvmod_vsthrottle.so
lib/varnish/vmods/libvmod_xkey.so
+man/man3/vmod_accept.3.gz
man/man3/vmod_bodyaccess.3.gz
man/man3/vmod_header.3.gz
man/man3/vmod_saintmode.3.gz
+man/man3/vmod_str.3.gz
man/man3/vmod_var.3.gz
man/man3/vmod_vsthrottle.3.gz
man/man3/vmod_xkey.3.gz