aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-15 12:34:49 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-02-15 12:34:49 +0000
commitf6e7f26602a0e7b744f2023d058596324ca164e8 (patch)
treebf19f32ea6808c09829f1a5d7bde66757b0d8790
parent87573cd4ed13f0339deb204f9319f03445049b61 (diff)
downloadports-f6e7f26602a0e7b744f2023d058596324ca164e8.tar.gz
ports-f6e7f26602a0e7b744f2023d058596324ca164e8.zip
devel/boost-python-libs got forgotten in the python flavorization, fix
this oversight. Reviewed by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14368
Notes
Notes: svn path=/head/; revision=461885
-rw-r--r--MOVED1
-rw-r--r--Mk/Uses/python.mk7
-rw-r--r--audio/py-tagpy/Makefile4
-rw-r--r--cad/freecad/Makefile2
-rw-r--r--cad/linuxcnc-devel/Makefile2
-rw-r--r--comms/gnuradio/Makefile2
-rw-r--r--comms/uhd/Makefile2
-rw-r--r--comms/usrp/Makefile2
-rw-r--r--devel/Makefile1
-rw-r--r--devel/boost-all/Makefile2
-rw-r--r--devel/boost-libs/pkg-descr2
-rw-r--r--devel/boost-python-libs/Makefile8
-rw-r--r--devel/boost-python-libs/pkg-descr3
-rw-r--r--devel/boost-python3-libs/Makefile10
-rw-r--r--devel/eblob/Makefile2
-rw-r--r--devel/libarea/Makefile2
-rw-r--r--devel/luabind/Makefile4
-rw-r--r--devel/py-pyopencl/Makefile4
-rw-r--r--devel/uatraits/Makefile2
-rw-r--r--devel/vera++/Makefile2
-rw-r--r--devel/youcompleteme/Makefile2
-rw-r--r--games/vegastrike/Makefile2
-rw-r--r--graphics/caffe/Makefile2
-rw-r--r--graphics/cegui/Makefile2
-rw-r--r--graphics/gsculpt/Makefile2
-rw-r--r--graphics/luxrender/Makefile2
-rw-r--r--graphics/openimageio/Makefile2
-rw-r--r--graphics/py-exiv2/Makefile2
-rw-r--r--graphics/vigra/Makefile2
-rw-r--r--math/cadabra2/Makefile2
-rw-r--r--math/kig/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar-python/Makefile2
-rw-r--r--net/ceph-devel/Makefile2
-rw-r--r--net/ceph/Makefile2
-rw-r--r--science/avogadro/Makefile2
-rw-r--r--science/tfel/Makefile2
-rw-r--r--sysutils/condor/Makefile2
37 files changed, 47 insertions, 51 deletions
diff --git a/MOVED b/MOVED
index 22d04cb5d9c1..48ae0163777c 100644
--- a/MOVED
+++ b/MOVED
@@ -9964,3 +9964,4 @@ games/lolcat|games/rubygem-lolcat|2018-02-13|Rename to match our rubygems naming
net-mgmt/prometheus|net-mgmt/prometheus1|2018-02-14|Rename to include major version number in the portname
textproc/rubygem-tidy||2018-02-14|Has expired: No longer needed and not maintained
www/rubygem-scrapi||2018-02-14|Has expired: No longer maintained upstream
+devel/boost-python3-libs|devel/boost-python-libs@py36|2018-02-15|Flavorize
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 767a26d44b7b..ac9cb699c386 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -671,6 +671,13 @@ PY_FUTURES= ${PYTHON_PKGNAMEPREFIX}futures>0:devel/py-futures@${PY_FLAVOR}
PY_FUTURES=
.endif
+.if ${PYTHON_REL} < 3000
+PY_BOOST_LIB= boost_python
+.else
+PY_BOOST_LIB= boost_python3
+.endif
+PY_BOOST= lib${PY_BOOST_LIB}.so:devel/boost-python-libs@${PY_FLAVOR}
+
# dependencies
.for _stage in PATCH BUILD RUN TEST
. if defined(_PYTHON_${_stage}_DEP)
diff --git a/audio/py-tagpy/Makefile b/audio/py-tagpy/Makefile
index fdc92ee22e83..66ea6b1992bb 100644
--- a/audio/py-tagpy/Makefile
+++ b/audio/py-tagpy/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python bindings for Scott Wheeler's TagLib
LICENSE= MIT
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
+LIB_DEPENDS= ${PY_BOOST} \
libtag.so:audio/taglib
USES= compiler:c++11-lang python shebangfix
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --taglib-inc-dir="${LOCALBASE}/include/taglib" \
--taglib-lib-dir="${LOCALBASE}/lib" \
--boost-inc-dir="${PYTHON_INCLUDEDIR},${LOCALBASE}/include" \
--boost-lib-dir="${PYTHON_LIBDIR},${LOCALBASE}/lib" \
- --boost-python-libname="boost_python"
+ --boost-python-libname="${PY_BOOST_LIB}"
SHEBANG_FILES= configure.py
USE_PYTHON= distutils autoplist
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index d9cfd40550ef..db0748ad625b 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= pyside-rcc:devel/pyside-tools \
swig3.0:devel/swig30
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
- libboost_python.so:devel/boost-python-libs \
+ ${PY_BOOST} \
libpyside-python2.7.so:devel/pyside@${PY_FLAVOR} \
libCoin.so:graphics/Coin \
libpng.so:graphics/png \
diff --git a/cad/linuxcnc-devel/Makefile b/cad/linuxcnc-devel/Makefile
index 5203c2231ea0..6e33912ed459 100644
--- a/cad/linuxcnc-devel/Makefile
+++ b/cad/linuxcnc-devel/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
BROKEN= wrong DEPENDS
LIB_DEPENDS= libBLT25.so:x11-toolkits/blt \
- libboost_python.so:devel/boost-python-libs \
+ ${PY_BOOST} \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libmodbus.so:comms/libmodbus \
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index d326cd682d7d..1c910ad08d16 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= libcppunit.so:devel/cppunit \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
libqwt.so:x11-toolkits/qwt5 \
- libboost_python.so:devel/boost-python-libs \
+ ${PY_BOOST} \
libportaudio.so:audio/portaudio \
libjack.so:audio/jack \
libasound.so:audio/alsa-lib \
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index 7fda63c6696e..3c0a61a37430 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -11,7 +11,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= mr@FreeBSD.org
COMMENT= Ettus Research UHD driver framework
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+LIB_DEPENDS= ${PY_BOOST}
BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs \
cheetah-analyze:devel/py-cheetah@${PY_FLAVOR} \
rst2html:textproc/py-docutils \
diff --git a/comms/usrp/Makefile b/comms/usrp/Makefile
index 3e1bd6d9a6c0..274bdf01cdba 100644
--- a/comms/usrp/Makefile
+++ b/comms/usrp/Makefile
@@ -12,7 +12,7 @@ COMMENT= Ettus Research USRP driver framework
BROKEN= fails to build with boost 1.66, see bug 224088
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+LIB_DEPENDS= ${PY_BOOST}
BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs \
cheetah-analyze:devel/py-cheetah \
rst2html:textproc/py-docutils \
diff --git a/devel/Makefile b/devel/Makefile
index 57269c984009..0e209245929f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -216,7 +216,6 @@
SUBDIR += boost-jam
SUBDIR += boost-libs
SUBDIR += boost-python-libs
- SUBDIR += boost-python3-libs
SUBDIR += boost_build
SUBDIR += bossa
SUBDIR += bouml-doc
diff --git a/devel/boost-all/Makefile b/devel/boost-all/Makefile
index 20afde0070e5..f87004e4fa7f 100644
--- a/devel/boost-all/Makefile
+++ b/devel/boost-all/Makefile
@@ -17,7 +17,7 @@ PYTHON_DESC= Boost.Python - interfacing Python and C++
LIBRARIES_RUN_DEPENDS= ${LOCALBASE}/lib/libboost_thread.so:devel/boost-libs
JAM_RUN_DEPENDS= ${LOCALBASE}/bin/bjam:devel/boost-jam
-PYTHON_RUN_DEPENDS= ${LOCALBASE}/lib/libboost_python.so:devel/boost-python-libs
+PYTHON_RUN_DEPENDS= ${LOCALBASE}/lib/${PY_BOOST}
DOCS_RUN_DEPENDS= ${LOCALBASE}/share/doc/boost/doc/html/index.html:devel/boost-docs
.include <bsd.port.mk>
diff --git a/devel/boost-libs/pkg-descr b/devel/boost-libs/pkg-descr
index 27c09e9d7451..9b1f0f2da5e5 100644
--- a/devel/boost-libs/pkg-descr
+++ b/devel/boost-libs/pkg-descr
@@ -14,6 +14,6 @@ several more Boost libraries in addition to those from TR1. More Boost
libraries are proposed for TR2.
NOTE: This package does not contain Boost.Python, it's in
-devel/boost-python-libs (python 2) and devel/boost-python3-libs (python 3).
+devel/boost-python-libs.
WWW: http://www.boost.org/
diff --git a/devel/boost-python-libs/Makefile b/devel/boost-python-libs/Makefile
index a5de7a423fc7..e8b8d720bbe8 100644
--- a/devel/boost-python-libs/Makefile
+++ b/devel/boost-python-libs/Makefile
@@ -1,10 +1,12 @@
# Created by: Alexander Churanov <churanov.port.maintainer@gmail.com>
# $FreeBSD$
-PORTNAME?= boost-python-libs
-COMMENT?= Framework for interfacing Python 2 and C++
+PORTNAME= boost-libs
+COMMENT= Framework for interfacing Python 2 and C++
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-USES?= python:2.7
+USES= python
+USE_PYTHON= flavors
OPTIONS_DEFINE= DEBUG OPTIMIZED_CFLAGS
diff --git a/devel/boost-python-libs/pkg-descr b/devel/boost-python-libs/pkg-descr
index bdf180b5ce1a..3d1e94382663 100644
--- a/devel/boost-python-libs/pkg-descr
+++ b/devel/boost-python-libs/pkg-descr
@@ -3,7 +3,4 @@ C++. It allows you to quickly and seamlessly expose C++ classes
functions and objects to Python, and vice-versa, using no special
tools -- just your C++ compiler.
-The python 2 port is called boost-python-libs
-The python 3 port is called boost-python3-libs
-
WWW: http://www.boost.org/
diff --git a/devel/boost-python3-libs/Makefile b/devel/boost-python3-libs/Makefile
deleted file mode 100644
index a15cf9104c3e..000000000000
--- a/devel/boost-python3-libs/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= boost-python3-libs
-COMMENT= Framework for interfacing Python 3 and C++
-
-USES= python:3.3+
-
-MASTERDIR= ${.CURDIR}/../../devel/boost-python-libs
-
-.include "${MASTERDIR}/Makefile"
diff --git a/devel/eblob/Makefile b/devel/eblob/Makefile
index 20b6fb5305b7..1d3a1074e74b 100644
--- a/devel/eblob/Makefile
+++ b/devel/eblob/Makefile
@@ -33,7 +33,7 @@ CMAKE_ARGS+= -DWITH_ASSERTS=OFF
.endif
.if ${PORT_OPTIONS:MPYTHON}
-LIB_DEPENDS+= libboost_python.so:devel/boost-python-libs
+LIB_DEPENDS+= ${PY_BOOST}
USES+= python:2.7
CMAKE_ARGS+= -DWITH_PYTHON=ON
PLIST_SUB+= PYTHON="" PYTHON_VER=${PYTHON_VER}
diff --git a/devel/libarea/Makefile b/devel/libarea/Makefile
index 3dedb8785890..6e19eec6e3cc 100644
--- a/devel/libarea/Makefile
+++ b/devel/libarea/Makefile
@@ -11,7 +11,7 @@ COMMENT= CAM-related software for profile and pocketing operations
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+LIB_DEPENDS= ${PY_BOOST}
USE_GITHUB= yes
GH_ACCOUNT= Heeks
diff --git a/devel/luabind/Makefile b/devel/luabind/Makefile
index c5ef428b4136..07f9c90b6b72 100644
--- a/devel/luabind/Makefile
+++ b/devel/luabind/Makefile
@@ -13,9 +13,9 @@ COMMENT= Library that helps you create bindings between C++ and Lua
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+LIB_DEPENDS= ${PY_BOOST}
-USES= lua:51
+USES= lua:51 python:env
USE_LDCONFIG= yes
CPPFLAGS+= -I.. -I${LUA_INCDIR} -I${LOCALBASE}/include
diff --git a/devel/py-pyopencl/Makefile b/devel/py-pyopencl/Makefile
index ffd5f17fa5ba..d92c886c4d17 100644
--- a/devel/py-pyopencl/Makefile
+++ b/devel/py-pyopencl/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/CL/cl.h:devel/opencl \
${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py-cffi@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=0:math/py-numpy@${FLAVOR}
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
+LIB_DEPENDS= ${PY_BOOST} \
libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.0:devel/py-appdirs@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py-cffi@${FLAVOR} \
@@ -28,7 +28,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.0:devel/py-appdirs@${FLAVOR} \
CONFIGURE_ARGS= BOOST_INC_DIR="${LOCALBASE}/include" \
BOOST_LIB_DIR="${LOCALBASE}/lib" \
- BOOST_PYTHON_LIBNAME=boost_python \
+ BOOST_PYTHON_LIBNAME=${PY_BOOST_LIB} \
CL_INC_DIR="${LOCALBASE}/include" \
CL_LIB_DIR="${LOCALBASE}/lib" \
USE_SHIPPED_BOOST=False
diff --git a/devel/uatraits/Makefile b/devel/uatraits/Makefile
index 762f805e76fa..516b7b5f62ff 100644
--- a/devel/uatraits/Makefile
+++ b/devel/uatraits/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://people.freebsd.org/~demon/
MAINTAINER= demon@FreeBSD.org
COMMENT= User-Agent detection library
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
+LIB_DEPENDS= ${PY_BOOST} \
libpcre.so:devel/pcre \
libxml2.so:textproc/libxml2
diff --git a/devel/vera++/Makefile b/devel/vera++/Makefile
index 0414e86e020f..4a5208ec451f 100644
--- a/devel/vera++/Makefile
+++ b/devel/vera++/Makefile
@@ -34,7 +34,7 @@ OPTIONS_DEFAULT= LUA PYTHON
PYTHON_CMAKE_OFF= -DVERA_PYTHON:BOOL=OFF
PYTHON_CMAKE_ON= -DVERA_PYTHON:BOOL=ON
-PYTHON_LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+PYTHON_LIB_DEPENDS= ${PY_BOOST}
LUA_CMAKE_OFF= -DVERA_LUA:BOOL=OFF
LUA_CMAKE_ON= -DVERA_LUA:BOOL=ON
LUA_LIB_DEPENDS= libluabind.so:devel/luabind
diff --git a/devel/youcompleteme/Makefile b/devel/youcompleteme/Makefile
index c9b09bdf4edb..8cf62155d392 100644
--- a/devel/youcompleteme/Makefile
+++ b/devel/youcompleteme/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING.txt
RUN_DEPENDS= vim:editors/vim \
${LOCALBASE}/lib/libboost_thread.so:devel/boost-libs \
- ${LOCALBASE}/lib/libboost_python.so:devel/boost-python-libs \
+ ${LOCALBASE}/lib/${PY_BOOST} \
${PYTHON_PKGNAMEPREFIX}argparse>0:devel/py-argparse@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bottle>0:www/py-bottle@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}frozendict>0:devel/py-frozendict@${PY_FLAVOR} \
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index 637dfd32dd8a..aa1972515963 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${LOCALBASE}/${DATADIR_REL}/vegastrike.ico:games/vegastrike-data
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
+LIB_DEPENDS= ${PY_BOOST} \
libexpat.so:textproc/expat2 \
libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg
diff --git a/graphics/caffe/Makefile b/graphics/caffe/Makefile
index e41c9f2f9ac3..d7c1d554700d 100644
--- a/graphics/caffe/Makefile
+++ b/graphics/caffe/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libsnappy.so:archivers/snappy \
libleveldb.so:databases/leveldb \
liblmdb.so:databases/lmdb \
libboost_system.so:devel/boost-libs \
- libboost_python.so:devel/boost-python-libs \
+ ${PY_BOOST} \
libgflags.so:devel/gflags \
libglog.so:devel/glog \
libprotobuf.so:devel/protobuf \
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
index 694ff5a31705..858bd99c9861 100644
--- a/graphics/cegui/Makefile
+++ b/graphics/cegui/Makefile
@@ -46,7 +46,7 @@ LUA_CMAKE_ON= -DCEGUI_BUILD_LUA_MODULE=ON -DCEGUI_BUILD_LUA_GENERATOR=ON
LUA_CMAKE_OFF= -DCEGUI_BUILD_LUA_MODULE=OFF -DCEGUI_BUILD_LUA_GENERATOR=OFF
# this option is not currently used as it doesn't compile (see also CMAKE_ARGS below)
PYTHON_USES= python:2.7
-PYTHON_LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+PYTHON_LIB_DEPENDS= ${PY_BOOST}
PYTHON_CMAKE_ON= -DCEGUI_BUILD_PYTHON_MODULES=ON
PYTHON_CMAKE_OFF= -DCEGUI_BUILD_PYTHON_MODULES=OFF
FRIBIDI_LIB_DEPENDS= libfribidi.so:converters/fribidi
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index 210d97359f0f..ff4d298212a6 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -14,7 +14,7 @@ COMMENT= Opensource 3D modelling application
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+LIB_DEPENDS= ${PY_BOOST}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PyOpenGL>0:graphics/py-PyOpenGL@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gtkglext>0:x11-toolkits/py-gtkglext@${PY_FLAVOR}
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index c019776de92c..b322140ad79d 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -16,7 +16,7 @@ COMMENT= Physically based and unbiased rendering system
LICENSE= GPLv3
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
+LIB_DEPENDS= ${PY_BOOST} \
libfftw3.so:math/fftw3 \
libOpenImageIO.so:graphics/openimageio
.if ${DISTVERSION} != 1.4
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index d03c64fa73fe..0892e058d83b 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -94,7 +94,7 @@ CMAKE_ARGS+= -DUSE_PYTHON:BOOL=OFF -DUSE_PYTHON3:BOOL=OFF \
-DOIIO_BUILD_TOOLS:BOOL=ON
.else
LIB_DEPENDS+= libOpenImageIO.so:graphics/openimageio \
- libboost_python.so:devel/boost-python-libs
+ ${PY_BOOST}
PLIST= ${PKGDIR}/pkg-plist-pybind
#while oiio supports py3, ports doesn't have py3 support for boost-python yet
USES+= python:2
diff --git a/graphics/py-exiv2/Makefile b/graphics/py-exiv2/Makefile
index d8bc28c31148..2bcf6014f382 100644
--- a/graphics/py-exiv2/Makefile
+++ b/graphics/py-exiv2/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= Python bindings for exiv2
LIB_DEPENDS= libexiv2.so:graphics/exiv2\
- libboost_python.so:devel/boost-python-libs
+ ${PY_BOOST}
USES= python:2 scons tar:bzip2
USE_PYTHON= flavors
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index ae000428d11a..ffee856370db 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -49,7 +49,7 @@ NUMPY_BUILD_DEPENDS= nosetests:devel/py-nose \
f2py:math/py-numpy
NUMPY_RUN_DEPENDS= nosetests:devel/py-nose \
f2py:math/py-numpy
-NUMPY_LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+NUMPY_LIB_DEPENDS= ${PY_BOOST}
# On FreeBSD < 11 libc++ lacks support for sized delete operators.
# GCC dropped the builtin version of these operators in 6+ by
# defaulting to gnu++14. Force c++11 instead.
diff --git a/math/cadabra2/Makefile b/math/cadabra2/Makefile
index 06a172b10258..b244867e8860 100644
--- a/math/cadabra2/Makefile
+++ b/math/cadabra2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/doc/license.txt
PATCH_DEPENDS= ${NONEXISTENT}:devel/boost-libs:extract \
${NONEXISTENT}:devel/websocketpp:extract
BUILD_DEPENDS= ${LOCALBASE}/include/websocketpp/client.hpp:devel/websocketpp
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
+LIB_DEPENDS= ${PY_BOOST} \
libboost_system.so:devel/boost-libs \
libpcrecpp.so:devel/pcre \
libjsoncpp.so:devel/jsoncpp \
diff --git a/math/kig/Makefile b/math/kig/Makefile
index 0825ca336e3a..2329ebc8b62c 100644
--- a/math/kig/Makefile
+++ b/math/kig/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= math kde kde-kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 interactive geometry application
-LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+LIB_DEPENDS= ${PY_BOOST}
USES= cmake:outsource compiler:c++11-lib kde:4 python:run \
shebangfix tar:xz
diff --git a/net-p2p/libtorrent-rasterbar-python/Makefile b/net-p2p/libtorrent-rasterbar-python/Makefile
index 058fc66f102a..a2ac28b24083 100644
--- a/net-p2p/libtorrent-rasterbar-python/Makefile
+++ b/net-p2p/libtorrent-rasterbar-python/Makefile
@@ -7,7 +7,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
COMMENT= Python bindings for libtorrent-rasterbar
LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
- libboost_python.so:devel/boost-python-libs
+ ${PY_BOOST}
MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar
diff --git a/net/ceph-devel/Makefile b/net/ceph-devel/Makefile
index cf1751da143b..6723629c7b98 100644
--- a/net/ceph-devel/Makefile
+++ b/net/ceph-devel/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= \
${LOCALBASE}/lib/libatomic_ops.a:devel/libatomic_ops \
gperf:devel/gperf
LIB_DEPENDS= \
- libboost_python.so:devel/boost-python-libs \
+ ${PY_BOOST} \
libboost_thread.so:devel/boost-libs \
libleveldb.so:databases/leveldb \
libldap.so:net/openldap24-client \
diff --git a/net/ceph/Makefile b/net/ceph/Makefile
index 9005a115b0fb..2c1320a60e1d 100644
--- a/net/ceph/Makefile
+++ b/net/ceph/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS= \
gperf:devel/gperf \
${LOCALBASE}/lib/libatomic_ops.a:devel/libatomic_ops
LIB_DEPENDS= \
- libboost_python.so:devel/boost-python-libs \
+ ${PY_BOOST} \
libboost_thread.so:devel/boost-libs \
libleveldb.so:databases/leveldb \
libldap.so:net/openldap24-client \
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 6bf6fe78a910..9934c6533334 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -37,7 +37,7 @@ OPTIONS_SUB= yes
PYTHON_USES= python:2
PYTHON_BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:devel/py-sip@${PY_FLAVOR}
-PYTHON_LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+PYTHON_LIB_DEPENDS= ${PY_BOOST}
PYTHON_RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:devel/py-sip@${PY_FLAVOR}
PYTHON_CMAKE_ON= -DENABLE_PYTHON=ON \
diff --git a/science/tfel/Makefile b/science/tfel/Makefile
index c9e42c92e094..b8c82e40b722 100644
--- a/science/tfel/Makefile
+++ b/science/tfel/Makefile
@@ -22,7 +22,7 @@ OPTIONS_SUB= yes
GNUPLOT_BUILD_DEPENDS= gnuplot:math/gnuplot
GNUPLOT_RUN_DEPENDS= gnuplot:math/gnuplot
-PYTHON_LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+PYTHON_LIB_DEPENDS= ${PY_BOOST}
PYTHON_USES= localbase python:2.7
PYTHON_CONFIGURE_ARGS= --enable-python-bindings
PYTHON_CONFIGURE_WITH= boost=${LOCALBASE}
diff --git a/sysutils/condor/Makefile b/sysutils/condor/Makefile
index 9c7abde9aaf7..326b4d997566 100644
--- a/sysutils/condor/Makefile
+++ b/sysutils/condor/Makefile
@@ -20,7 +20,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE-2.0.txt
LIB_DEPENDS+= libkrb5support.so:security/krb5 \
libpcre.so:devel/pcre \
libcurl.so:ftp/curl \
- libboost_python.so:devel/boost-python-libs \
+ ${PY_BOOST} \
libexpat.so:textproc/expat2
WRKSRC= ${WRKDIR}/condor-${PORTVERSION}