aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2024-06-22 21:09:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-06-23 12:58:40 +0000
commitf70288a8520770f80e566c67d36b2ac5e5321aa2 (patch)
tree46577fa82ffe871136adb441057a33c46895ef88
parent298551c2dc60383093f6687648519222b7127a5a (diff)
downloadports-f70288a8520770f80e566c67d36b2ac5e5321aa2.tar.gz
ports-f70288a8520770f80e566c67d36b2ac5e5321aa2.zip
science/mmg: new port, bidimensional and tridimensional remeshing
Used by Gmsh, and also it could be used by elmerfem.
-rw-r--r--science/mmg/Makefile30
-rw-r--r--science/mmg/distinfo3
-rw-r--r--science/mmg/pkg-descr14
-rw-r--r--science/mmg/pkg-plist41
4 files changed, 88 insertions, 0 deletions
diff --git a/science/mmg/Makefile b/science/mmg/Makefile
new file mode 100644
index 000000000000..9d7280445d4a
--- /dev/null
+++ b/science/mmg/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= mmg
+PORTVERSION= 5.7.3
+DISTVERSIONPREFIX= v
+CATEGORIES= science
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Bidimensional and tridimensional remeshing
+WWW= https://www.mmgtools.org/
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= git:devel/git \
+ bash:shells/bash
+LIB_DEPENDS= libscotch.so:cad/scotch \
+ libElas.so:science/linearelasticity \
+ libvtksys-${VTK_VER}.so:math/vtk${VTK_VER:R}
+
+USES= cmake:testing perl5 shebangfix
+USE_PERL5= build
+SHEBANG_FILES= scripts/*.sh
+
+USE_GITHUB= yes
+GH_ACCOUNT= MmgTools
+
+CMAKE_ON= BUILD_SHARED_LIBS
+USE_LDCONFIG= yes
+
+.include <../../math/vtk9/Makefile.version>
+.include <bsd.port.mk>
diff --git a/science/mmg/distinfo b/science/mmg/distinfo
new file mode 100644
index 000000000000..8b9062f46ae9
--- /dev/null
+++ b/science/mmg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1718986408
+SHA256 (MmgTools-mmg-v5.7.3_GH0.tar.gz) = b0a9c5ad6789df369a68f94295df5b324b6348020b73bcc395d32fdd44abe706
+SIZE (MmgTools-mmg-v5.7.3_GH0.tar.gz) = 9645997
diff --git a/science/mmg/pkg-descr b/science/mmg/pkg-descr
new file mode 100644
index 000000000000..94c22fa37676
--- /dev/null
+++ b/science/mmg/pkg-descr
@@ -0,0 +1,14 @@
+Mmg is an open source software for simplicial remeshing. It provides 3
+applications and 4 libraries:
+
+- the mmg2d application and the libmmg2d library: adaptation and optimization of
+ a two-dimensional triangulation and generation of a triangulation from a set
+ of points or from given boundary edges;
+
+- the mmgs application and the libmmgs library: adaptation and optimization of a
+ surface triangulation and isovalue discretization;
+
+- the mmg3d application and the libmmg3d library: adaptation and optimization of
+ a tetrahedral mesh and implicit domain meshing;
+
+- the libmmg library gathering the libmmg2d, libmmgs and libmmg3d libraries.
diff --git a/science/mmg/pkg-plist b/science/mmg/pkg-plist
new file mode 100644
index 000000000000..80ad5b0c74ef
--- /dev/null
+++ b/science/mmg/pkg-plist
@@ -0,0 +1,41 @@
+bin/mmg2d_O3
+bin/mmg3d_O3
+bin/mmgs_O3
+include/mmg/common/git_log_mmg.h
+include/mmg/common/libmmgtypes.h
+include/mmg/common/libmmgtypesf.h
+include/mmg/common/mmg_export.h
+include/mmg/common/mmgcmakedefines.h
+include/mmg/common/mmgcmakedefinesf.h
+include/mmg/common/mmgversion.h
+include/mmg/libmmg.h
+include/mmg/libmmgf.h
+include/mmg/mmg2d/libmmg2d.h
+include/mmg/mmg2d/libmmg2df.h
+include/mmg/mmg2d/mmg2d_export.h
+include/mmg/mmg3d/libmmg3d.h
+include/mmg/mmg3d/libmmg3df.h
+include/mmg/mmg3d/mmg3d_export.h
+include/mmg/mmgs/libmmgs.h
+include/mmg/mmgs/libmmgsf.h
+include/mmg/mmgs/mmgs_export.h
+lib/cmake/mmg/FindElas.cmake
+lib/cmake/mmg/FindSCOTCH.cmake
+lib/cmake/mmg/MmgTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/mmg/MmgTargets.cmake
+lib/cmake/mmg/mmgConfig.cmake
+lib/libmmg.so
+lib/libmmg.so.5
+lib/libmmg.so.5.7.0
+lib/libmmg2d.so
+lib/libmmg2d.so.5
+lib/libmmg2d.so.5.7.0
+lib/libmmg3d.so
+lib/libmmg3d.so.5
+lib/libmmg3d.so.5.7.0
+lib/libmmgs.so
+lib/libmmgs.so.5
+lib/libmmgs.so.5.7.0
+share/man/man1/mmg2d.1.gz
+share/man/man1/mmg3d.1.gz
+share/man/man1/mmgs.1.gz