aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-25 08:16:20 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-25 08:18:44 +0000
commitf75fc16179629b51725274bb82aac362fe6e41e5 (patch)
tree8b8b2bea536f29158d1a722a24adb018294e926e
parente316451d37e1454bd32e03d3a0ffb0b094ceb63f (diff)
downloadports-f75fc16179629b51725274bb82aac362fe6e41e5.tar.gz
ports-f75fc16179629b51725274bb82aac362fe6e41e5.zip
www/lighttpd: fix listening on IPv6 addresses
PR: 271335
-rw-r--r--www/lighttpd/Makefile1
-rw-r--r--www/lighttpd/files/patch-src_sock__addr.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 94f4aac98136..1d6e9701314a 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -1,5 +1,6 @@
PORTNAME?= lighttpd
PORTVERSION= 1.4.70
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES?= https://download.lighttpd.net/lighttpd/releases-1.4.x/
diff --git a/www/lighttpd/files/patch-src_sock__addr.c b/www/lighttpd/files/patch-src_sock__addr.c
new file mode 100644
index 000000000000..9917b52a0ef2
--- /dev/null
+++ b/www/lighttpd/files/patch-src_sock__addr.c
@@ -0,0 +1,11 @@
+--- src/sock_addr.c.orig 2023-05-15 15:41:44 UTC
++++ src/sock_addr.c
+@@ -496,7 +496,7 @@ int sock_addr_from_str_hints(sock_addr * const restric
+ if (0 != (rc = getaddrinfo(str, NULL, &hints, &res))) {
+ hints.ai_family = AF_INET;
+ if (
+- #ifdef EAI_ADDRFAMILY
++ #if defined(__GLIBC__) && defined(EAI_ADDRFAMILY)
+ EAI_ADDRFAMILY == rc &&
+ #endif
+ 0 == getaddrinfo(str, NULL, &hints, &res)) {