aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2024-06-23 04:12:24 +0000
committerPhilip Paeps <philip@FreeBSD.org>2024-06-23 04:12:24 +0000
commitf77077d7974847b80e96a436dddd33bb961f7503 (patch)
tree547ff69dac138505ef0ad36ba680a8959e14062d
parentd8d25fa814d6b22eb6c415691e583adf5d8e940b (diff)
downloadports-f77077d7974847b80e96a436dddd33bb961f7503.tar.gz
ports-f77077d7974847b80e96a436dddd33bb961f7503.zip
net/fort: Update to 1.6.2
- Update to 1.6.2 - Changelog: https://github.com/NICMx/FORT-validator/releases/tag/1.6.2 While here, fix building with libxml2 2.13.1 [1]. This patch will be in the next upstream release. Approved by: Toni Kalombo <toni@devboks.com> (maintainer, implicit) Reported by: diizzy [1] PR: 279898 [1]
-rw-r--r--net/fort/Makefile3
-rw-r--r--net/fort/distinfo6
-rw-r--r--net/fort/files/patch-src_Makefile.am8
-rw-r--r--net/fort/files/patch-src_xml_relax__ng.c19
4 files changed, 27 insertions, 9 deletions
diff --git a/net/fort/Makefile b/net/fort/Makefile
index ed7d500c8d38..9729473d8cf8 100644
--- a/net/fort/Makefile
+++ b/net/fort/Makefile
@@ -1,6 +1,5 @@
PORTNAME= fort
-DISTVERSION= 1.6.1
-PORTREVISION= 1
+DISTVERSION= 1.6.2
CATEGORIES= net
MAINTAINER= toni@devboks.com
diff --git a/net/fort/distinfo b/net/fort/distinfo
index 1eae28584c55..0c852fdede0e 100644
--- a/net/fort/distinfo
+++ b/net/fort/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1707198406
-SHA256 (NICMx-FORT-validator-1.6.1_GH0.tar.gz) = 0bed82f75bd6c4fffa4f5dc4118a706560f5eab27d85b9704380e570db8ff050
-SIZE (NICMx-FORT-validator-1.6.1_GH0.tar.gz) = 455892
+TIMESTAMP = 1719114666
+SHA256 (NICMx-FORT-validator-1.6.2_GH0.tar.gz) = aa6149256b0557e617cb0ff7f290464ee5fd930a02e7f9169f42ce157db025bf
+SIZE (NICMx-FORT-validator-1.6.2_GH0.tar.gz) = 397203
diff --git a/net/fort/files/patch-src_Makefile.am b/net/fort/files/patch-src_Makefile.am
index 0066f76f3587..b57ee7a99f05 100644
--- a/net/fort/files/patch-src_Makefile.am
+++ b/net/fort/files/patch-src_Makefile.am
@@ -1,9 +1,9 @@
---- src/Makefile.am.orig 2023-12-14 01:43:09 UTC
+--- src/Makefile.am.orig 2024-06-23 03:52:55 UTC
+++ src/Makefile.am
-@@ -118,7 +118,7 @@ fort_CFLAGS = -Wall -Wpedantic
- # Feel free to temporarily remove this one if you're not using gcc 7.3.0.
+@@ -118,7 +118,7 @@ fort_SOURCES += $(ASN_MODULE_SRCS) $(ASN_MODULE_HDRS)
+ fort_CFLAGS = -Wall -Wpedantic
#fort_CFLAGS += $(GCC_WARNS)
- fort_CFLAGS += -std=c99 -D_POSIX_C_SOURCE=200809 -D_XOPEN_SOURCE=700
+ fort_CFLAGS += -std=c99 -D_DEFAULT_SOURCE=1 -D_XOPEN_SOURCE=700 -D_BSD_SOURCE=1
-fort_CFLAGS += -O2 -g $(FORT_FLAGS) ${XML2_CFLAGS}
+fort_CFLAGS += -O2 -g $(FORT_FLAGS) ${XML2_CFLAGS} ${JANSSON_CFLAGS}
if BACKTRACE_ENABLED
diff --git a/net/fort/files/patch-src_xml_relax__ng.c b/net/fort/files/patch-src_xml_relax__ng.c
new file mode 100644
index 000000000000..952d7b59a197
--- /dev/null
+++ b/net/fort/files/patch-src_xml_relax__ng.c
@@ -0,0 +1,19 @@
+--- src/xml/relax_ng.c.orig 2024-06-23 04:09:22 UTC
++++ src/xml/relax_ng.c
+@@ -35,8 +35,15 @@ relax_ng_log_warn(void *ctx, const char *msg, ...)
+ VLOG_MSG(warn)
+ }
+
++/* Signature changed at libxml2 commit 61034116d0a3c8b295c6137956adc3ae55720. */
++#if LIBXML_VERSION >= 21200
++#define XMLERROR_PARAMTYPE const xmlError *
++#else
++#define XMLERROR_PARAMTYPE xmlErrorPtr
++#endif
++
+ static void
+-relax_ng_log_str_err(void *userData, xmlErrorPtr error)
++relax_ng_log_str_err(void *userData, XMLERROR_PARAMTYPE error)
+ {
+ char *ptr;
+