aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-03-05 08:02:50 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-03-05 08:02:50 +0000
commitf7831115d69602fdc3a72d789d5969b4eaae9693 (patch)
tree4798fd484be77f7bf207a2728537138b319b6c9c
parent07ca0beba339b3972452ca663115007e45c4e3ed (diff)
downloadports-f7831115d69602fdc3a72d789d5969b4eaae9693.tar.gz
ports-f7831115d69602fdc3a72d789d5969b4eaae9693.zip
security/git-credential-gopass: Add new port
Manage git credentials using gopass
-rw-r--r--security/Makefile1
-rw-r--r--security/git-credential-gopass/Makefile22
-rw-r--r--security/git-credential-gopass/distinfo7
-rw-r--r--security/git-credential-gopass/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3d77703aba8c..82f5bea371f6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -179,6 +179,7 @@
SUBDIR += fwlogwatch
SUBDIR += gcr
SUBDIR += gef
+ SUBDIR += git-credential-gopass
SUBDIR += git-crypt
SUBDIR += git-remote-gcrypt
SUBDIR += git-secret
diff --git a/security/git-credential-gopass/Makefile b/security/git-credential-gopass/Makefile
new file mode 100644
index 000000000000..2ff8d9018a05
--- /dev/null
+++ b/security/git-credential-gopass/Makefile
@@ -0,0 +1,22 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+
+PORTNAME= git-credential-gopass
+PORTVERSION= 1.12.0
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Manage git credentials using gopass
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= gopasspw
+
+GO_MODULE= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/git-credential-gopass
+
+.include <bsd.port.mk>
diff --git a/security/git-credential-gopass/distinfo b/security/git-credential-gopass/distinfo
new file mode 100644
index 000000000000..21b12b24e5e6
--- /dev/null
+++ b/security/git-credential-gopass/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1646465668
+SHA256 (go/security_git-credential-gopass/gopasspw-git-credential-gopass-v1.12.0_GH0/v1.12.0.mod) = 2be6f8619ab28b46409c6895781706fd33f6ff6ea07683a79f40c65990d98bb8
+SIZE (go/security_git-credential-gopass/gopasspw-git-credential-gopass-v1.12.0_GH0/v1.12.0.mod) = 237
+SHA256 (go/security_git-credential-gopass/gopasspw-git-credential-gopass-v1.12.0_GH0/v1.12.0.zip) = 5d771195075b71836bf16ec51ea2394d1dc740a747537bb4f8bbca9321fff0e6
+SIZE (go/security_git-credential-gopass/gopasspw-git-credential-gopass-v1.12.0_GH0/v1.12.0.zip) = 18024
+SHA256 (go/security_git-credential-gopass/gopasspw-git-credential-gopass-v1.12.0_GH0/gopasspw-git-credential-gopass-v1.12.0_GH0.tar.gz) = 277f2c42ebb8430f2c6a6b9b1d29f55479723dbb8cc01f30bf070395379ebcda
+SIZE (go/security_git-credential-gopass/gopasspw-git-credential-gopass-v1.12.0_GH0/gopasspw-git-credential-gopass-v1.12.0_GH0.tar.gz) = 15572
diff --git a/security/git-credential-gopass/pkg-descr b/security/git-credential-gopass/pkg-descr
new file mode 100644
index 000000000000..682d88f92698
--- /dev/null
+++ b/security/git-credential-gopass/pkg-descr
@@ -0,0 +1,4 @@
+This git credential helper allows you to cache your git-credentials with
+gopass.
+
+WWW: https://github.com/gopasspw/git-credential-gopass