aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-04-01 22:29:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-04-01 22:31:08 +0000
commitf822df7855c0d52e8a41c686a9dd1baf4b2abb29 (patch)
tree22109e830224fd7b1fa0d1bad577bd39a93b89f3
parenta6a9d23c5098d1898665312c3a858cd9eac31ba4 (diff)
downloadports-f822df7855c0d52e8a41c686a9dd1baf4b2abb29.tar.gz
ports-f822df7855c0d52e8a41c686a9dd1baf4b2abb29.zip
graphics/{,py-}f3d: update 2.2.1 → 2.3.1
Reported by: portscout
-rw-r--r--graphics/f3d/Makefile11
-rw-r--r--graphics/f3d/distinfo6
-rw-r--r--graphics/py-f3d/Makefile4
-rw-r--r--graphics/py-f3d/distinfo6
-rw-r--r--graphics/py-f3d/files/patch-CMakeLists.txt17
5 files changed, 15 insertions, 29 deletions
diff --git a/graphics/f3d/Makefile b/graphics/f3d/Makefile
index 482fcc314e1f..c2cdec098793 100644
--- a/graphics/f3d/Makefile
+++ b/graphics/f3d/Makefile
@@ -1,30 +1,25 @@
PORTNAME= f3d
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.0
+DISTVERSION= 2.3.1
CATEGORIES= graphics
MAINTAINER= yuri@FreeBSD.org
COMMENT= Fast and minimalist 3D viewer
-WWW= https://f3d-app.github.io/f3d/
+WWW= https://f3d.app/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg4 \
- libexpat.so:textproc/expat2 \
libfontconfig.so:x11-fonts/fontconfig \
libfreeimage.so:graphics/freeimage \
libfreetype.so:print/freetype2 \
libhdf5.so:science/hdf5 \
libImath-3_1.so:math/Imath \
- libjpeg.so:graphics/jpeg-turbo \
libnetcdf.so:science/netcdf \
- libpng.so:graphics/png \
- libtbbmalloc.so:devel/onetbb \
- libtiff.so:graphics/tiff \
libvtkCommonMisc-${VTK_VER}.so:math/vtk${VTK_VER:R}
-USES= cmake:testing compiler:c++17-lang desktop-file-utils gl mpi \
+USES= cmake:testing compiler:c++17-lang desktop-file-utils gl \
shared-mime-info tcl tk xorg
USE_GL= gl glu
USE_XORG= ice sm x11 xt
diff --git a/graphics/f3d/distinfo b/graphics/f3d/distinfo
index 3560f0ee0555..43031ac59e5d 100644
--- a/graphics/f3d/distinfo
+++ b/graphics/f3d/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1709891821
-SHA256 (f3d-app-f3d-v2.3.0_GH0.tar.gz) = 9c2906b62f3066f075effbabd6501964391e8a8ffad6ed773c33db12580cc466
-SIZE (f3d-app-f3d-v2.3.0_GH0.tar.gz) = 40606315
+TIMESTAMP = 1711990779
+SHA256 (f3d-app-f3d-v2.3.1_GH0.tar.gz) = e6ada89851cd27c84117b5b73dd69475fa7442f05e1dbf2fa76e1dc34d2c0006
+SIZE (f3d-app-f3d-v2.3.1_GH0.tar.gz) = 40726219
diff --git a/graphics/py-f3d/Makefile b/graphics/py-f3d/Makefile
index f3b9768b1c81..4377719512ef 100644
--- a/graphics/py-f3d/Makefile
+++ b/graphics/py-f3d/Makefile
@@ -1,12 +1,12 @@
PORTNAME= f3d
DISTVERSIONPREFIX= v
-DISTVERSION= 2.2.1
+DISTVERSION= 2.3.1
CATEGORIES= graphics
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Fast and minimalist 3D viewer
-WWW= https://f3d-app.github.io/f3d/
+WWW= https://f3d.app/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/../LICENSE.md
diff --git a/graphics/py-f3d/distinfo b/graphics/py-f3d/distinfo
index 174b9aef2db8..be58a4847de1 100644
--- a/graphics/py-f3d/distinfo
+++ b/graphics/py-f3d/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1704772200
-SHA256 (f3d-app-f3d-v2.2.1_GH0.tar.gz) = 4d3a73b0107c8db7f0556107c74087d3748232a73981f65f7c5186ac1003ec8d
-SIZE (f3d-app-f3d-v2.2.1_GH0.tar.gz) = 29785716
+TIMESTAMP = 1712010259
+SHA256 (f3d-app-f3d-v2.3.1_GH0.tar.gz) = e6ada89851cd27c84117b5b73dd69475fa7442f05e1dbf2fa76e1dc34d2c0006
+SIZE (f3d-app-f3d-v2.3.1_GH0.tar.gz) = 40726219
diff --git a/graphics/py-f3d/files/patch-CMakeLists.txt b/graphics/py-f3d/files/patch-CMakeLists.txt
index 68c0fa0f90d4..af6b519205ed 100644
--- a/graphics/py-f3d/files/patch-CMakeLists.txt
+++ b/graphics/py-f3d/files/patch-CMakeLists.txt
@@ -1,20 +1,11 @@
---- CMakeLists.txt.orig 2023-10-04 06:49:20 UTC
+--- CMakeLists.txt.orig 2024-03-29 06:17:35 UTC
+++ CMakeLists.txt
-@@ -5,7 +5,7 @@ include(f3dPython)
- list(INSERT CMAKE_MODULE_PATH 0 "${CMAKE_CURRENT_LIST_DIR}/cmake")
+@@ -6,7 +6,7 @@ include(f3dPython)
+ include(GNUInstallDirs)
include(f3dPython)
--find_package(Python 3.6 COMPONENTS Interpreter Development)
+-find_package(Python 3.8 COMPONENTS Interpreter Development)
+find_package(Python ${FREEBSD_PYTHON_VER} EXACT COMPONENTS Interpreter Development)
find_package(pybind11 2.2 REQUIRED)
pybind11_add_module(pyf3d MODULE F3DPythonBindings.cxx)
-@@ -21,7 +21,7 @@ set(f3d_python_package_suffix "python${Python_VERSION_
-
- set(f3d_python_package_name "f3d")
- set(f3d_python_package_suffix "python${Python_VERSION_MAJOR}.${Python_VERSION_MINOR}/site-packages")
--set(f3d_module_dir "${CMAKE_BINARY_DIR}$<${F3D_MULTI_CONFIG_GENERATOR}:/$<CONFIG>>/${f3d_python_package_name}")
-+set(f3d_module_dir "${CMAKE_BINARY_DIR}/${f3d_python_package_name}") # workaround for https://github.com/f3d-app/f3d/issues/1149
-
- set_target_properties(pyf3d PROPERTIES
- CXX_STANDARD 14