aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-10 21:11:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-10 21:11:24 +0000
commitf83b34b741cf3b63a8bd069695a3716c61e941d5 (patch)
treeca33e8ef1623b45839b76b5cb334d0dbf9c59746
parentdd522563f0d8b1350036a13d35ee15d09e4a249f (diff)
downloadports-f83b34b741cf3b63a8bd069695a3716c61e941d5.tar.gz
ports-f83b34b741cf3b63a8bd069695a3716c61e941d5.zip
Fix pure by removing the useless pre.mk/post.mk dancing
Convert to USES=gmake Reported by: marino
Notes
Notes: svn path=/head/; revision=322733
-rw-r--r--audio/pure-audio/Makefile9
-rw-r--r--databases/pure-sql3/Makefile9
-rw-r--r--devel/pure-gen/Makefile9
-rw-r--r--devel/pure-readline/Makefile9
-rw-r--r--devel/pure-stldict/Makefile9
-rw-r--r--devel/pure-stlvec/Makefile10
-rw-r--r--graphics/pure-gl/Makefile9
-rw-r--r--lang/pure/bsd.pure.mk2
-rw-r--r--math/pure-mpfr/Makefile9
-rw-r--r--math/pure-rational/Makefile9
-rw-r--r--net/pure-sockets/Makefile9
-rw-r--r--textproc/pure-csv/Makefile9
-rw-r--r--textproc/pure-xml/Makefile9
-rw-r--r--x11-toolkits/pure-tk/Makefile3
14 files changed, 26 insertions, 88 deletions
diff --git a/audio/pure-audio/Makefile b/audio/pure-audio/Makefile
index 09fe2cb64e8f..0703b5e24574 100644
--- a/audio/pure-audio/Makefile
+++ b/audio/pure-audio/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-gtk
-# Date created: 2011-03-18
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-audio
PORTVERSION= 0.5
@@ -25,6 +21,5 @@ post-patch:
-e "s|portaudio.h|portaudio2/portaudio.h|g" \
${WRKSRC}/Makefile
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pure-sql3/Makefile b/databases/pure-sql3/Makefile
index 2b7fe7b0e251..3d3b6b884d6c 100644
--- a/databases/pure-sql3/Makefile
+++ b/databases/pure-sql3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-sql3
-# Date created: 2011-03-18
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-sql3
PORTVERSION= 0.4
@@ -20,6 +16,5 @@ USE_PURE= yes
PLIST_FILES= lib/pure/sql3.pure \
lib/pure/sql3util.so
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pure-gen/Makefile b/devel/pure-gen/Makefile
index c481458b658e..bb2a267b528e 100644
--- a/devel/pure-gen/Makefile
+++ b/devel/pure-gen/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-sql3
-# Date created: 2011-03-18
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-gen
PORTVERSION= 0.15
@@ -21,6 +17,5 @@ MAN1= pure-gen.1
CC= gcc
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pure-readline/Makefile b/devel/pure-readline/Makefile
index 69751b2e3f77..be5399f49c1d 100644
--- a/devel/pure-readline/Makefile
+++ b/devel/pure-readline/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-readline
-# Date created: 2011-10-21
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-readline
PORTVERSION= 0.1
@@ -18,6 +14,5 @@ NO_PURE_EXAMPLES= yes
PLIST_FILES= lib/pure/readline.pure \
lib/pure/readline.so
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pure-stldict/Makefile b/devel/pure-stldict/Makefile
index c85ccf85736a..16e34b4abdd4 100644
--- a/devel/pure-stldict/Makefile
+++ b/devel/pure-stldict/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-stldict
-# Date created: 2011-12-05
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-stldict
PORTVERSION= 0.5
@@ -18,6 +14,5 @@ USE_GCC= 4.6+
CXX= g++${GCC_DEFAULT_V}
CXXFLAGS+= -std=c++0x -DHAVE_STD_IS_PERMUTATION
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pure-stlvec/Makefile b/devel/pure-stlvec/Makefile
index 3172d3c5c07a..545fd99a6a68 100644
--- a/devel/pure-stlvec/Makefile
+++ b/devel/pure-stlvec/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-stlvec
-# Date created: 2011-10-19
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-stlvec
PORTVERSION= 0.2
@@ -14,12 +10,10 @@ COMMENT= Pure interface to C++ STL vector
USE_PURE= yes
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e \
's|^PROD_FLAGS =.*|PROD_FLAGS = $$(CPPFLAGS) $$(CFLAGS) $$(LDFLAGS)|' \
${WRKSRC}/Makefile
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/pure-gl/Makefile b/graphics/pure-gl/Makefile
index 4931863ca86d..8b830ac130a2 100644
--- a/graphics/pure-gl/Makefile
+++ b/graphics/pure-gl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-gtk
-# Date created: 2011-03-18
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-gl
PORTVERSION= 0.8
@@ -20,6 +16,5 @@ USE_GL= glut
MAKE_ARGS+= LinkGL="-lglut -lGLU -lGL"
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/pure/bsd.pure.mk b/lang/pure/bsd.pure.mk
index be2f154fb186..4d3758e026e6 100644
--- a/lang/pure/bsd.pure.mk
+++ b/lang/pure/bsd.pure.mk
@@ -22,7 +22,7 @@ PURE_include= bsd.pure.mk
MASTER_SITES?= http://pure-lang.googlecode.com/files/
DIST_SUBDIR= pure
-USE_GMAKE= yes
+USES+= gmake
_PURE_audio_cat= audio
_PURE_csv_cat= textproc
diff --git a/math/pure-mpfr/Makefile b/math/pure-mpfr/Makefile
index a2979b844843..c90f7b29b662 100644
--- a/math/pure-mpfr/Makefile
+++ b/math/pure-mpfr/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-mpfr
-# Date created: 2011-10-19
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-mpfr
PORTVERSION= 0.4
@@ -19,6 +15,5 @@ PLIST_FILES= lib/pure/mpfr.pure \
MAKE_ARGS+= libdir="${PREFIX}/lib"
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/pure-rational/Makefile b/math/pure-rational/Makefile
index 84b38a919a9d..bc0ea1098cbf 100644
--- a/math/pure-rational/Makefile
+++ b/math/pure-rational/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-rational
-# Date created: 2011-10-09
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-rational
PORTVERSION= 0.1
@@ -21,6 +17,5 @@ NO_PURE_EXAMPLES= yes
PLIST_FILES= lib/pure/rational.pure \
lib/pure/rat_interval.pure
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pure-sockets/Makefile b/net/pure-sockets/Makefile
index d6e78e23e7a5..562641d28743 100644
--- a/net/pure-sockets/Makefile
+++ b/net/pure-sockets/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-sockets
-# Date created: 2011-03-18
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-sockets
PORTVERSION= 0.6
@@ -17,6 +13,5 @@ USE_PURE= yes
PLIST_FILES= lib/pure/sockets.pure \
lib/pure/sockets.so
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pure-csv/Makefile b/textproc/pure-csv/Makefile
index 6be64e2fd7c5..e7c7569da23d 100644
--- a/textproc/pure-csv/Makefile
+++ b/textproc/pure-csv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-csv
-# Date created: 2011-03-18
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-csv
PORTVERSION= 1.5
@@ -18,6 +14,5 @@ NO_PURE_EXAMPLES= yes
PLIST_FILES= lib/pure/csv.pure \
lib/pure/csv.so
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/pure-xml/Makefile b/textproc/pure-xml/Makefile
index 1e9bbf7dbc07..52d8607d1d67 100644
--- a/textproc/pure-xml/Makefile
+++ b/textproc/pure-xml/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pure-xml
-# Date created: 2011-03-18
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= pure-xml
PORTVERSION= 0.6
@@ -19,6 +15,5 @@ USE_GNOME= libxml2 libxslt
PLIST_FILES= lib/pure/xml.pure \
lib/pure/xml.so
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/pure-tk/Makefile b/x11-toolkits/pure-tk/Makefile
index d6fbcf37dc4c..aff2094c4e32 100644
--- a/x11-toolkits/pure-tk/Makefile
+++ b/x11-toolkits/pure-tk/Makefile
@@ -25,6 +25,5 @@ post-patch:
-e "s|-ltk\$$(tclvers)|-ltk${SHORT_TCL_VER}|" \
${WRKSRC}/Makefile
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>