aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-08-04 20:46:15 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-08-04 20:46:15 +0000
commitf8c3c7e74e2ddbbb814b4915dee473f3c4c90279 (patch)
tree6dfc6528b30e5494efc60e49d8b0cf2268f94757
parent5820b02993d06c0f091d8af675a3ee61f220c78b (diff)
downloadports-f8c3c7e74e2ddbbb814b4915dee473f3c4c90279.tar.gz
ports-f8c3c7e74e2ddbbb814b4915dee473f3c4c90279.zip
games/openmw: update to 0.48.0 release (+)
OpenMW 0.48.0 Released! Release notes: https://openmw.org/2023/openmw-0-48-0-released/
-rw-r--r--games/openmw/Makefile15
-rw-r--r--games/openmw/distinfo8
-rw-r--r--games/openmw/files/patch-cmake_FindFFmpeg.cmake11
-rw-r--r--games/openmw/files/patch-extern_CMakeLists.txt24
-rw-r--r--games/openmw/pkg-plist302
5 files changed, 225 insertions, 135 deletions
diff --git a/games/openmw/Makefile b/games/openmw/Makefile
index 88588dc0dbae..18f0dc8c6b96 100644
--- a/games/openmw/Makefile
+++ b/games/openmw/Makefile
@@ -1,7 +1,6 @@
PORTNAME= openmw
-PORTREVISION= 7
DISTVERSIONPREFIX= openmw-
-DISTVERSION= 0.47.0
+DISTVERSION= 0.48.0
CATEGORIES= games
MAINTAINER= fluffy@FreeBSD.org
@@ -11,16 +10,19 @@ WWW= https://openmw.org/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libavcodec.so.58:multimedia/ffmpeg4 \
+LIB_DEPENDS= libavcodec.so.60:multimedia/ffmpeg \
libboost_thread.so:devel/boost-libs \
libMyGUIEngine.so:x11-toolkits/mygui \
libBulletCollision.so:devel/bullet@double \
libosg.so:graphics/osg \
libRecast.so:graphics/recastnavigation \
libunshield.so:archivers/unshield \
- liblz4.so:archivers/liblz4
+ liblz4.so:archivers/liblz4 \
+ libicui18n.so:devel/icu \
+ libyaml-cpp.so:devel/yaml-cpp
-USES= cmake compiler:c++17-lang gl openal pkgconfig qt:5 sdl xorg
+USES= cmake compiler:c++17-lang desktop-file-utils gl luajit openal \
+ pkgconfig qt:5 sdl sqlite xorg
USE_GITHUB= yes
GH_ACCOUNT= OpenMW
USE_GL= gl
@@ -44,9 +46,6 @@ DOCS_USES= python:build
PORTDOCS= *
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${PATCH_WRKSRC}/cmake/FindFFmpeg.cmake
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
diff --git a/games/openmw/distinfo b/games/openmw/distinfo
index 11db8e44b399..0bddd8c28421 100644
--- a/games/openmw/distinfo
+++ b/games/openmw/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1639405346
-SHA256 (OpenMW-openmw-openmw-0.47.0_GH0.tar.gz) = bd7f77e1527c2180e9b0dfcbe401d6fb48f24dbb37701dac7747697873d6edb4
-SIZE (OpenMW-openmw-openmw-0.47.0_GH0.tar.gz) = 5156857
-SHA256 (recastnavigation-recastnavigation-e75adf86f91eb3082220085e42dda62679f9a3ea_GH0.tar.gz) = c647e307d6cc62ba00bfd888e82da83844bf1e72f2c98bed2f1d95bac229b950
-SIZE (recastnavigation-recastnavigation-e75adf86f91eb3082220085e42dda62679f9a3ea_GH0.tar.gz) = 1542425
+TIMESTAMP = 1690136917
+SHA256 (OpenMW-openmw-openmw-0.48.0_GH0.tar.gz) = ebcc1e217479306a92036aabf6f8225a3d228759eef6255cda57fb8566b9d388
+SIZE (OpenMW-openmw-openmw-0.48.0_GH0.tar.gz) = 6020423
diff --git a/games/openmw/files/patch-cmake_FindFFmpeg.cmake b/games/openmw/files/patch-cmake_FindFFmpeg.cmake
deleted file mode 100644
index cbedcb816345..000000000000
--- a/games/openmw/files/patch-cmake_FindFFmpeg.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/FindFFmpeg.cmake.orig 2023-04-24 10:57:53 UTC
-+++ cmake/FindFFmpeg.cmake
-@@ -33,6 +33,8 @@
- # Redistribution and use is allowed according to the terms of the BSD license.
- # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
-
-+set(CMAKE_PREFIX_PATH "%%LOCALBASE%%/ffmpeg4;%%LOCALBASE%%/ffmpeg4/libexec")
-+
- include(LibFindMacros)
- include(FindPackageHandleStandardArgs)
-
diff --git a/games/openmw/files/patch-extern_CMakeLists.txt b/games/openmw/files/patch-extern_CMakeLists.txt
deleted file mode 100644
index 113ff8d49ee5..000000000000
--- a/games/openmw/files/patch-extern_CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
---- extern/CMakeLists.txt.orig 2021-10-10 16:17:03 UTC
-+++ extern/CMakeLists.txt
-@@ -178,11 +178,14 @@ if(NOT OPENMW_USE_SYSTEM_RECASTNAVIGATION)
- set(RECASTNAVIGATION_EXAMPLES OFF CACHE BOOL "")
-
- # master on 15 Feb 2021
-- include(FetchContent)
-- FetchContent_Declare(recastnavigation
-- URL https://github.com/recastnavigation/recastnavigation/archive/e75adf86f91eb3082220085e42dda62679f9a3ea.zip
-- URL_HASH MD5=af905d121ef9d1cdfa979b0495cba059
-- SOURCE_DIR fetched/recastnavigation
-- )
-- FetchContent_MakeAvailableExcludeFromAll(recastnavigation)
-+# include(FetchContent)
-+# FetchContent_Declare(recastnavigation
-+# URL https://github.com/recastnavigation/recastnavigation/archive/e75adf86f91eb3082220085e42dda62679f9a3ea.zip
-+# URL_HASH MD5=af905d121ef9d1cdfa979b0495cba059
-+# SOURCE_DIR fetched/recastnavigation
-+# )
-+# FetchContent_MakeAvailableExcludeFromAll(recastnavigation)
-+
-+ add_subdirectory("fetched/recastnavigation")
-+
- endif()
diff --git a/games/openmw/pkg-plist b/games/openmw/pkg-plist
index 95e1944497ed..25e2b3c2791c 100644
--- a/games/openmw/pkg-plist
+++ b/games/openmw/pkg-plist
@@ -2,10 +2,12 @@ bin/bsatool
bin/esmtool
bin/niftest
bin/openmw
+bin/openmw-bulletobjecttool
bin/openmw-cs
bin/openmw-essimporter
bin/openmw-iniimporter
bin/openmw-launcher
+bin/openmw-navmeshtool
bin/openmw-wizard
%%ETCDIR%%/defaults-cs.bin
%%ETCDIR%%/defaults.bin
@@ -16,103 +18,55 @@ share/applications/org.openmw.cs.desktop
share/applications/org.openmw.launcher.desktop
share/metainfo/openmw.appdata.xml
%%DATADIR%%/resources/defaultfilters
-%%DATADIR%%/resources/mygui/DejaVuLGCSansMono.ttf
-%%DATADIR%%/resources/mygui/OpenMWResourcePlugin.xml
-%%DATADIR%%/resources/mygui/core.skin
-%%DATADIR%%/resources/mygui/core.xml
-%%DATADIR%%/resources/mygui/core_layouteditor.xml
-%%DATADIR%%/resources/mygui/openmw.png
-%%DATADIR%%/resources/mygui/openmw_alchemy_window.layout
-%%DATADIR%%/resources/mygui/openmw_book.layout
-%%DATADIR%%/resources/mygui/openmw_box.skin.xml
-%%DATADIR%%/resources/mygui/openmw_button.skin.xml
-%%DATADIR%%/resources/mygui/openmw_chargen_birth.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_class.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_class_description.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_create_class.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_generate_class_result.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_race.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_review.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_select_attribute.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_select_skill.layout
-%%DATADIR%%/resources/mygui/openmw_chargen_select_specialization.layout
-%%DATADIR%%/resources/mygui/openmw_companion_window.layout
-%%DATADIR%%/resources/mygui/openmw_confirmation_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_console.layout
-%%DATADIR%%/resources/mygui/openmw_console.skin.xml
-%%DATADIR%%/resources/mygui/openmw_container_window.layout
-%%DATADIR%%/resources/mygui/openmw_count_window.layout
-%%DATADIR%%/resources/mygui/openmw_debug_window.layout
-%%DATADIR%%/resources/mygui/openmw_debug_window.skin.xml
-%%DATADIR%%/resources/mygui/openmw_dialogue_window.layout
-%%DATADIR%%/resources/mygui/openmw_dialogue_window.skin.xml
-%%DATADIR%%/resources/mygui/openmw_edit.skin.xml
-%%DATADIR%%/resources/mygui/openmw_edit_effect.layout
-%%DATADIR%%/resources/mygui/openmw_edit_note.layout
-%%DATADIR%%/resources/mygui/openmw_enchanting_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_font.xml
-%%DATADIR%%/resources/mygui/openmw_hud.layout
-%%DATADIR%%/resources/mygui/openmw_hud_box.skin.xml
-%%DATADIR%%/resources/mygui/openmw_hud_energybar.skin.xml
-%%DATADIR%%/resources/mygui/openmw_infobox.layout
-%%DATADIR%%/resources/mygui/openmw_interactive_messagebox.layout
-%%DATADIR%%/resources/mygui/openmw_interactive_messagebox_notransp.layout
-%%DATADIR%%/resources/mygui/openmw_inventory_window.layout
-%%DATADIR%%/resources/mygui/openmw_itemselection_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_jail_screen.layout
-%%DATADIR%%/resources/mygui/openmw_journal.layout
-%%DATADIR%%/resources/mygui/openmw_journal.skin.xml
-%%DATADIR%%/resources/mygui/openmw_layers.xml
-%%DATADIR%%/resources/mygui/openmw_levelup_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_list.skin.xml
-%%DATADIR%%/resources/mygui/openmw_loading_screen.layout
-%%DATADIR%%/resources/mygui/openmw_magicselection_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_mainmenu.layout
-%%DATADIR%%/resources/mygui/openmw_mainmenu.skin.xml
-%%DATADIR%%/resources/mygui/openmw_map_window.layout
-%%DATADIR%%/resources/mygui/openmw_map_window.skin.xml
-%%DATADIR%%/resources/mygui/openmw_merchantrepair.layout
-%%DATADIR%%/resources/mygui/openmw_messagebox.layout
-%%DATADIR%%/resources/mygui/openmw_persuasion_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_pointer.xml
-%%DATADIR%%/resources/mygui/openmw_progress.skin.xml
-%%DATADIR%%/resources/mygui/openmw_quickkeys_menu.layout
-%%DATADIR%%/resources/mygui/openmw_quickkeys_menu_assign.layout
-%%DATADIR%%/resources/mygui/openmw_recharge_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_repair.layout
-%%DATADIR%%/resources/mygui/openmw_resources.xml
-%%DATADIR%%/resources/mygui/openmw_savegame_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_screen_fader.layout
-%%DATADIR%%/resources/mygui/openmw_screen_fader_hit.layout
-%%DATADIR%%/resources/mygui/openmw_scroll.layout
-%%DATADIR%%/resources/mygui/openmw_scroll.skin.xml
-%%DATADIR%%/resources/mygui/openmw_settings.xml
-%%DATADIR%%/resources/mygui/openmw_settings_window.layout
-%%DATADIR%%/resources/mygui/openmw_spell_buying_window.layout
-%%DATADIR%%/resources/mygui/openmw_spell_window.layout
-%%DATADIR%%/resources/mygui/openmw_spellcreation_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_stats_window.layout
-%%DATADIR%%/resources/mygui/openmw_text.skin.xml
-%%DATADIR%%/resources/mygui/openmw_text_input.layout
-%%DATADIR%%/resources/mygui/openmw_tooltips.layout
-%%DATADIR%%/resources/mygui/openmw_trade_window.layout
-%%DATADIR%%/resources/mygui/openmw_trainingwindow.layout
-%%DATADIR%%/resources/mygui/openmw_travel_window.layout
-%%DATADIR%%/resources/mygui/openmw_wait_dialog.layout
-%%DATADIR%%/resources/mygui/openmw_wait_dialog_progressbar.layout
-%%DATADIR%%/resources/mygui/openmw_windows.skin.xml
-%%DATADIR%%/resources/mygui/skins.xml
+%%DATADIR%%/resources/lua_api/README.md
+%%DATADIR%%/resources/lua_api/coroutine.doclua
+%%DATADIR%%/resources/lua_api/global.doclua
+%%DATADIR%%/resources/lua_api/math.doclua
+%%DATADIR%%/resources/lua_api/openmw/async.lua
+%%DATADIR%%/resources/lua_api/openmw/core.lua
+%%DATADIR%%/resources/lua_api/openmw/debug.lua
+%%DATADIR%%/resources/lua_api/openmw/nearby.lua
+%%DATADIR%%/resources/lua_api/openmw/postprocessing.lua
+%%DATADIR%%/resources/lua_api/openmw/self.lua
+%%DATADIR%%/resources/lua_api/openmw/types.lua
+%%DATADIR%%/resources/lua_api/openmw/ui.lua
+%%DATADIR%%/resources/lua_api/openmw/util.lua
+%%DATADIR%%/resources/lua_api/openmw/world.lua
+%%DATADIR%%/resources/lua_api/string.doclua
+%%DATADIR%%/resources/lua_api/table.doclua
+%%DATADIR%%/resources/lua_libs/content.lua
+%%DATADIR%%/resources/openmw.png
%%DATADIR%%/resources/shaders/alpha.glsl
+%%DATADIR%%/resources/shaders/blended_depth_postpass_fragment.glsl
+%%DATADIR%%/resources/shaders/blended_depth_postpass_vertex.glsl
+%%DATADIR%%/resources/shaders/debug_fragment.glsl
+%%DATADIR%%/resources/shaders/debug_vertex.glsl
+%%DATADIR%%/resources/shaders/depth.glsl
+%%DATADIR%%/resources/shaders/fog.glsl
+%%DATADIR%%/resources/shaders/fullscreen_tri_fragment.glsl
+%%DATADIR%%/resources/shaders/fullscreen_tri_vertex.glsl
%%DATADIR%%/resources/shaders/groundcover_fragment.glsl
%%DATADIR%%/resources/shaders/groundcover_vertex.glsl
-%%DATADIR%%/resources/shaders/lighting_util.glsl
+%%DATADIR%%/resources/shaders/gui_fragment.glsl
+%%DATADIR%%/resources/shaders/gui_vertex.glsl
+%%DATADIR%%/resources/shaders/hdr_luminance_fragment.glsl
+%%DATADIR%%/resources/shaders/hdr_resolve_fragment.glsl
%%DATADIR%%/resources/shaders/lighting.glsl
+%%DATADIR%%/resources/shaders/lighting_util.glsl
+%%DATADIR%%/resources/shaders/multiview_resolve_fragment.glsl
+%%DATADIR%%/resources/shaders/multiview_resolve_vertex.glsl
%%DATADIR%%/resources/shaders/nv_default_fragment.glsl
%%DATADIR%%/resources/shaders/nv_default_vertex.glsl
%%DATADIR%%/resources/shaders/nv_nolighting_fragment.glsl
%%DATADIR%%/resources/shaders/nv_nolighting_vertex.glsl
%%DATADIR%%/resources/shaders/objects_fragment.glsl
%%DATADIR%%/resources/shaders/objects_vertex.glsl
+%%DATADIR%%/resources/shaders/openmw_fragment.glsl
+%%DATADIR%%/resources/shaders/openmw_fragment.h.glsl
+%%DATADIR%%/resources/shaders/openmw_fragment_multiview.glsl
+%%DATADIR%%/resources/shaders/openmw_vertex.glsl
+%%DATADIR%%/resources/shaders/openmw_vertex.h.glsl
+%%DATADIR%%/resources/shaders/openmw_vertex_multiview.glsl
%%DATADIR%%/resources/shaders/parallax.glsl
%%DATADIR%%/resources/shaders/s360_fragment.glsl
%%DATADIR%%/resources/shaders/s360_vertex.glsl
@@ -120,6 +74,10 @@ share/metainfo/openmw.appdata.xml
%%DATADIR%%/resources/shaders/shadowcasting_vertex.glsl
%%DATADIR%%/resources/shaders/shadows_fragment.glsl
%%DATADIR%%/resources/shaders/shadows_vertex.glsl
+%%DATADIR%%/resources/shaders/sky_fragment.glsl
+%%DATADIR%%/resources/shaders/sky_vertex.glsl
+%%DATADIR%%/resources/shaders/skypasses.glsl
+%%DATADIR%%/resources/shaders/softparticles.glsl
%%DATADIR%%/resources/shaders/terrain_fragment.glsl
%%DATADIR%%/resources/shaders/terrain_vertex.glsl
%%DATADIR%%/resources/shaders/vertexcolors.glsl
@@ -127,6 +85,176 @@ share/metainfo/openmw.appdata.xml
%%DATADIR%%/resources/shaders/water_nm.png
%%DATADIR%%/resources/shaders/water_vertex.glsl
%%DATADIR%%/resources/version
+%%DATADIR%%/resources/vfs/builtin.omwscripts
+%%DATADIR%%/resources/vfs/fonts/DejaVuFontLicense.txt
+%%DATADIR%%/resources/vfs/fonts/DejaVuLGCSansMono.omwfont
+%%DATADIR%%/resources/vfs/fonts/DejaVuLGCSansMono.ttf
+%%DATADIR%%/resources/vfs/fonts/DemonicLetters.omwfont
+%%DATADIR%%/resources/vfs/fonts/DemonicLetters.ttf
+%%DATADIR%%/resources/vfs/fonts/DemonicLettersFontLicense.txt
+%%DATADIR%%/resources/vfs/fonts/MysticCards.omwfont
+%%DATADIR%%/resources/vfs/fonts/MysticCards.ttf
+%%DATADIR%%/resources/vfs/fonts/MysticCardsFontLicense.txt
+%%DATADIR%%/resources/vfs/l10n/BuiltInShaders/de.yaml
+%%DATADIR%%/resources/vfs/l10n/BuiltInShaders/en.yaml
+%%DATADIR%%/resources/vfs/l10n/BuiltInShaders/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/BuiltInShaders/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/BuiltInShaders/sv.yaml
+%%DATADIR%%/resources/vfs/l10n/Calendar/de.yaml
+%%DATADIR%%/resources/vfs/l10n/Calendar/en.yaml
+%%DATADIR%%/resources/vfs/l10n/Calendar/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/Calendar/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/Calendar/sv.yaml
+%%DATADIR%%/resources/vfs/l10n/DebugMenu/de.yaml
+%%DATADIR%%/resources/vfs/l10n/DebugMenu/en.yaml
+%%DATADIR%%/resources/vfs/l10n/DebugMenu/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/DebugMenu/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/DebugMenu/sv.yaml
+%%DATADIR%%/resources/vfs/l10n/Interface/de.yaml
+%%DATADIR%%/resources/vfs/l10n/Interface/en.yaml
+%%DATADIR%%/resources/vfs/l10n/Interface/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/Interface/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/Interface/sv.yaml
+%%DATADIR%%/resources/vfs/l10n/Navigation/de.yaml
+%%DATADIR%%/resources/vfs/l10n/Navigation/en.yaml
+%%DATADIR%%/resources/vfs/l10n/Navigation/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/Navigation/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/Navigation/sv.yaml
+%%DATADIR%%/resources/vfs/l10n/OMWCamera/de.yaml
+%%DATADIR%%/resources/vfs/l10n/OMWCamera/en.yaml
+%%DATADIR%%/resources/vfs/l10n/OMWCamera/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/OMWCamera/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/OMWCamera/sv.yaml
+%%DATADIR%%/resources/vfs/l10n/PostProcessing/de.yaml
+%%DATADIR%%/resources/vfs/l10n/PostProcessing/en.yaml
+%%DATADIR%%/resources/vfs/l10n/PostProcessing/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/PostProcessing/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/PostProcessing/sv.yaml
+%%DATADIR%%/resources/vfs/l10n/SavegameMenu/de.yaml
+%%DATADIR%%/resources/vfs/l10n/SavegameMenu/en.yaml
+%%DATADIR%%/resources/vfs/l10n/SavegameMenu/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/SavegameMenu/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/SavegameMenu/sv.yaml
+%%DATADIR%%/resources/vfs/l10n/SettingsMenu/de.yaml
+%%DATADIR%%/resources/vfs/l10n/SettingsMenu/en.yaml
+%%DATADIR%%/resources/vfs/l10n/SettingsMenu/fr.yaml
+%%DATADIR%%/resources/vfs/l10n/SettingsMenu/ru.yaml
+%%DATADIR%%/resources/vfs/l10n/SettingsMenu/sv.yaml
+%%DATADIR%%/resources/vfs/mygui/OpenMWResourcePlugin.xml
+%%DATADIR%%/resources/vfs/mygui/core.skin
+%%DATADIR%%/resources/vfs/mygui/core.xml
+%%DATADIR%%/resources/vfs/mygui/core_layouteditor.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_alchemy_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_book.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_box.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_button.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_birth.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_class.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_class_description.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_create_class.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_generate_class_result.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_race.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_review.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_select_attribute.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_select_skill.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_chargen_select_specialization.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_companion_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_confirmation_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_console.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_console.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_container_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_count_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_debug_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_debug_window.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_dialogue_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_dialogue_window.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_edit.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_edit_effect.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_edit_note.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_enchanting_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_hud.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_hud_box.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_hud_energybar.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_infobox.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_interactive_messagebox.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_interactive_messagebox_notransp.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_inventory_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_itemselection_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_jail_screen.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_journal.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_journal.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_layers.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_levelup_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_list.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_loading_screen.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_lua.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_magicselection_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_mainmenu.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_mainmenu.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_map_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_map_window.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_merchantrepair.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_messagebox.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_persuasion_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_pointer.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_postprocessor_hud.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_postprocessor_hud.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_progress.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_quickkeys_menu.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_quickkeys_menu_assign.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_recharge_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_repair.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_resources.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_savegame_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_screen_fader.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_screen_fader_hit.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_scroll.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_scroll.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_settings.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_settings_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_spell_buying_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_spell_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_spellcreation_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_stats_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_text.skin.xml
+%%DATADIR%%/resources/vfs/mygui/openmw_text_input.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_tooltips.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_trade_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_trainingwindow.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_travel_window.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_wait_dialog.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_wait_dialog_progressbar.layout
+%%DATADIR%%/resources/vfs/mygui/openmw_windows.skin.xml
+%%DATADIR%%/resources/vfs/mygui/skins.xml
+%%DATADIR%%/resources/vfs/openmw_aux/calendar.lua
+%%DATADIR%%/resources/vfs/openmw_aux/time.lua
+%%DATADIR%%/resources/vfs/openmw_aux/ui.lua
+%%DATADIR%%/resources/vfs/openmw_aux/util.lua
+%%DATADIR%%/resources/vfs/scripts/omw/ai.lua
+%%DATADIR%%/resources/vfs/scripts/omw/camera/camera.lua
+%%DATADIR%%/resources/vfs/scripts/omw/camera/first_person_auto_switch.lua
+%%DATADIR%%/resources/vfs/scripts/omw/camera/head_bobbing.lua
+%%DATADIR%%/resources/vfs/scripts/omw/camera/move360.lua
+%%DATADIR%%/resources/vfs/scripts/omw/camera/settings.lua
+%%DATADIR%%/resources/vfs/scripts/omw/camera/third_person.lua
+%%DATADIR%%/resources/vfs/scripts/omw/console/global.lua
+%%DATADIR%%/resources/vfs/scripts/omw/console/local.lua
+%%DATADIR%%/resources/vfs/scripts/omw/console/player.lua
+%%DATADIR%%/resources/vfs/scripts/omw/mwui/borders.lua
+%%DATADIR%%/resources/vfs/scripts/omw/mwui/constants.lua
+%%DATADIR%%/resources/vfs/scripts/omw/mwui/filters.lua
+%%DATADIR%%/resources/vfs/scripts/omw/mwui/init.lua
+%%DATADIR%%/resources/vfs/scripts/omw/mwui/space.lua
+%%DATADIR%%/resources/vfs/scripts/omw/mwui/text.lua
+%%DATADIR%%/resources/vfs/scripts/omw/mwui/textEdit.lua
+%%DATADIR%%/resources/vfs/scripts/omw/settings/common.lua
+%%DATADIR%%/resources/vfs/scripts/omw/settings/global.lua
+%%DATADIR%%/resources/vfs/scripts/omw/settings/player.lua
+%%DATADIR%%/resources/vfs/scripts/omw/settings/render.lua
+%%DATADIR%%/resources/vfs/scripts/omw/settings/renderers.lua
+%%DATADIR%%/resources/vfs/shaders/adjustments.omwfx
+%%DATADIR%%/resources/vfs/shaders/bloomlinear.omwfx
+%%DATADIR%%/resources/vfs/shaders/debug.omwfx
%%DATADIR%%/resources/vfs/textures/omw_menu_scroll_center_h.dds
%%DATADIR%%/resources/vfs/textures/omw_menu_scroll_center_v.dds
%%DATADIR%%/resources/vfs/textures/omw_menu_scroll_down.dds