aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2024-06-23 18:52:28 +0000
committerLars Engels <lme@FreeBSD.org>2024-06-23 19:39:31 +0000
commitf91f4d5699d7ed27d3285aceab5590ec90591d62 (patch)
tree0c828123f2dbca2187cad7f37ee0362788661369
parent69b9985efab0745e392fd6d1c46bc23bb2e252b8 (diff)
downloadports-f91f4d5699d7ed27d3285aceab5590ec90591d62.tar.gz
ports-f91f4d5699d7ed27d3285aceab5590ec90591d62.zip
deskutils/ausweisapp2: Update to 2.1.1
-rw-r--r--deskutils/ausweisapp2/Makefile16
-rw-r--r--deskutils/ausweisapp2/distinfo6
-rw-r--r--deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake33
-rw-r--r--deskutils/ausweisapp2/pkg-plist10
4 files changed, 40 insertions, 25 deletions
diff --git a/deskutils/ausweisapp2/Makefile b/deskutils/ausweisapp2/Makefile
index 6902b286439c..63e57112a0f0 100644
--- a/deskutils/ausweisapp2/Makefile
+++ b/deskutils/ausweisapp2/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ausweisapp2
-DISTVERSION= 1.24.2
+DISTVERSION= 2.1.1
CATEGORIES= deskutils security
MAINTAINER= freebsd@sysctl.cz
@@ -11,19 +11,21 @@ LICENSE_NAME= European Union Public Licence V. 1.2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= pcsc-lite>0:devel/pcsc-lite \
+BUILD_DEPENDS= libglvnd>0:graphics/libglvnd \
+ pcsc-lite>0:devel/pcsc-lite \
qt5-declarative-test>0:x11-toolkits/qt5-declarative-test
+
LIB_DEPENDS= libhttp_parser.so:www/http-parser \
libpcsclite.so:devel/pcsc-lite \
libudev.so:devel/libudev-devd
-USES= cmake compiler:c++17-lang pkgconfig qmake qt:5 ssl
+USES= cmake compiler:c++17-lang pkgconfig qmake qt:6 ssl
+USE_GL+= gl opengl
USE_GITHUB= yes
GH_ACCOUNT= Governikus
-GH_PROJECT= AusweisApp2
-USE_QT= concurrent core declarative graphicaleffects gui network \
- quickcontrols2 svg websockets widgets \
- buildtools linguisttools
+GH_PROJECT= AusweisApp
+USE_QT= base connectivity declarative scxml shadertools svg tools \
+ websockets
# The VENDOR variable controls the name of the directory in ${PREFIX}/share.
CMAKE_ARGS= -DVENDOR=${PORTNAME}
diff --git a/deskutils/ausweisapp2/distinfo b/deskutils/ausweisapp2/distinfo
index ad087c34a26e..d7418a6a9388 100644
--- a/deskutils/ausweisapp2/distinfo
+++ b/deskutils/ausweisapp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1664903413
-SHA256 (Governikus-AusweisApp2-1.24.2_GH0.tar.gz) = bb92f2e73e352921878000cd5ec81fcd8924c8d360059bf09b70707e06d35f05
-SIZE (Governikus-AusweisApp2-1.24.2_GH0.tar.gz) = 11478273
+TIMESTAMP = 1718018776
+SHA256 (Governikus-AusweisApp-2.1.1_GH0.tar.gz) = 131b49b8b17fbde2c7c5671721462fff1685725d9b02d244de85a782f3849562
+SIZE (Governikus-AusweisApp-2.1.1_GH0.tar.gz) = 5878477
diff --git a/deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake b/deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake
index 2cfe616a9e1b..31013b98049c 100644
--- a/deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake
+++ b/deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake
@@ -1,11 +1,24 @@
---- cmake/Libraries.cmake.orig 2022-09-06 11:32:26 UTC
+--- cmake/Libraries.cmake.orig 2024-04-10 11:44:19 UTC
+++ cmake/Libraries.cmake
-@@ -144,7 +144,7 @@ elseif(MAC)
- find_library(OSX_FOUNDATION Foundation)
- find_library(OSX_SERVICEMANAGEMENT ServiceManagement)
- elseif(UNIX)
-- if(LINUX)
-+ if(LINUX OR BSD)
- find_package(PkgConfig REQUIRED)
- pkg_check_modules(UDEV IMPORTED_TARGET libudev)
- if(NOT TARGET PkgConfig::UDEV)
+@@ -147,12 +147,12 @@ if(QT_COMPONENTS)
+ find_package(${Qt} ${MIN_QT_VERSION} COMPONENTS ${QT_COMPONENTS} REQUIRED)
+ endif()
+
+-if(LINUX OR BSD)
+- try_run(testResult compileResult "${CMAKE_BINARY_DIR}" "${CMAKE_DIR}/tests/openssl.cpp"
+- CMAKE_FLAGS INSTALL_RPATH_USE_LINK_PATH:BOOL=ON
+- LINK_LIBRARIES ${Qt}::Network OpenSSL::Crypto OpenSSL::SSL
+- OUTPUT_VARIABLE runResult)
+- if(NOT testResult EQUAL 0)
+- message(FATAL_ERROR "Your OpenSSL library looks incompatible: ${testResult}\n${runResult}")
+- endif()
+-endif()
++#if(LINUX OR BSD)
++# try_run(testResult compileResult "${CMAKE_BINARY_DIR}" "${CMAKE_DIR}/tests/openssl.cpp"
++# CMAKE_FLAGS INSTALL_RPATH_USE_LINK_PATH:BOOL=ON
++# LINK_LIBRARIES ${Qt}::Network OpenSSL::Crypto OpenSSL::SSL
++# OUTPUT_VARIABLE runResult)
++# if(NOT testResult EQUAL 0)
++# message(FATAL_ERROR "Your OpenSSL library looks incompatible: ${testResult}\n${runResult}")
++# endif()
++#endif()
diff --git a/deskutils/ausweisapp2/pkg-plist b/deskutils/ausweisapp2/pkg-plist
index 546fcb6b7d13..654eb58aa168 100644
--- a/deskutils/ausweisapp2/pkg-plist
+++ b/deskutils/ausweisapp2/pkg-plist
@@ -1,7 +1,7 @@
-bin/AusweisApp2
-share/man/man1/AusweisApp2.1.gz
+bin/AusweisApp
share/applications/com.governikus.ausweisapp2.desktop
-share/icons/hicolor/96x96/apps/AusweisApp2.png
-share/icons/hicolor/scalable/apps/AusweisApp2.svg
+%%DATADIR%%/AusweisApp/AusweisApp.rcc
+share/icons/hicolor/96x96/apps/AusweisApp.png
+share/icons/hicolor/scalable/apps/AusweisApp.svg
+share/man/man1/AusweisApp.1.gz
share/metainfo/com.governikus.ausweisapp2.metainfo.xml
-%%DATADIR%%/AusweisApp2/AusweisApp2.rcc