aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-01-04 16:38:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-01-04 16:38:44 +0000
commitf98f93005f1e3f6ac2e6dedd0df5394cc1f9d61f (patch)
treeae861a9031669e8bfc99fadf7877d926875a6a81
parent19e5c89e9e46002dc8d41dff397101211cbf2085 (diff)
downloadports-f98f93005f1e3f6ac2e6dedd0df5394cc1f9d61f.tar.gz
ports-f98f93005f1e3f6ac2e6dedd0df5394cc1f9d61f.zip
games/vcmi: the port had been updated to version 1.1.0
- Replace LAUNCHER option with more generic QT as it now controls the build of Qt-based game launcher and map editor programs - Disable build of LUA/ERM scripting modules as scripting support is far from "production ready" and not something that should be offered to end-users for the time being - Add a couple of missing Oxford commas while I'm at it Reported by: portscout
-rw-r--r--games/vcmi/Makefile22
-rw-r--r--games/vcmi/distinfo6
-rw-r--r--games/vcmi/files/patch-lib_CModHandler.h11
-rw-r--r--games/vcmi/pkg-descr2
-rw-r--r--games/vcmi/pkg-message4
-rw-r--r--games/vcmi/pkg-plist94
6 files changed, 86 insertions, 53 deletions
diff --git a/games/vcmi/Makefile b/games/vcmi/Makefile
index 47ee932dfe58..1c083d5a6a09 100644
--- a/games/vcmi/Makefile
+++ b/games/vcmi/Makefile
@@ -1,6 +1,5 @@
PORTNAME= vcmi
-PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTVERSION= 1.1.0
CATEGORIES= games
MAINTAINER= danfe@FreeBSD.org
@@ -12,12 +11,11 @@ LICENSE= GPLv2+
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libboost_atomic.so:devel/boost-libs \
libfuzzylite.so:devel/fuzzylite \
- libluajit-5.1.so:lang/luajit \
libminizip.so:archivers/minizip \
libtbb.so:devel/onetbb
RUN_DEPENDS= bash:shells/bash
-USES= cmake sdl shebangfix
+USES= cmake pkgconfig sdl shebangfix
USE_GITHUB= yes
USE_SDL= image2 mixer2 sdl2 ttf2
SHEBANG_FILES= vcmibuilder
@@ -28,17 +26,17 @@ CMAKE_ARGS= -DCMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=ON \
PORTDOCS= AUTHORS ChangeLog README.md
-OPTIONS_DEFINE= DOCS LAUNCHER
-OPTIONS_DEFAULT=LAUNCHER
+OPTIONS_DEFINE= DOCS QT
+OPTIONS_DEFAULT= QT
OPTIONS_SUB= yes
-LAUNCHER_DESC= Build Qt-based game launcher
-LAUNCHER_USES= qt:5
-LAUNCHER_USE= QT=buildtools:build,qmake:build,core,gui,network,widgets
-LAUNCHER_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF
+QT_DESC= Build Qt-based game launcher and map editor
+QT_USES= qt:5
+QT_USE= QT=buildtools:build,qmake:build,core,gui,network,widgets
+QT_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF -DENABLE_EDITOR:BOOL=OFF
post-configure:
- ${SED} -e 's,@GIT_SHA1@,cedc9a9,' ${WRKSRC}/Version.cpp.in \
+ ${SED} -e 's,@GIT_SHA1@,5278271,' ${WRKSRC}/Version.cpp.in \
> ${BUILD_WRKSRC}/Version.cpp
post-install-DOCS-on:
@@ -46,3 +44,5 @@ post-install-DOCS-on:
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
+
+PATCH_ARGS+= -l
diff --git a/games/vcmi/distinfo b/games/vcmi/distinfo
index 70c12c46bbd7..dea8d6a9dc6d 100644
--- a/games/vcmi/distinfo
+++ b/games/vcmi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1662892941
-SHA256 (vcmi-vcmi-1.0.0_GH0.tar.gz) = 1033f69c55f2f7d071ea5f278f41d5f97abe9087e339718569681a3f46a0e7d0
-SIZE (vcmi-vcmi-1.0.0_GH0.tar.gz) = 5885358
+TIMESTAMP = 1671792720
+SHA256 (vcmi-vcmi-1.1.0_GH0.tar.gz) = 39db3ac7a2d1e386be1982957c0746e4e47f0d6a57268a57e65df9c95c967474
+SIZE (vcmi-vcmi-1.1.0_GH0.tar.gz) = 6412813
diff --git a/games/vcmi/files/patch-lib_CModHandler.h b/games/vcmi/files/patch-lib_CModHandler.h
new file mode 100644
index 000000000000..ba043fb9066f
--- /dev/null
+++ b/games/vcmi/files/patch-lib_CModHandler.h
@@ -0,0 +1,11 @@
+--- lib/CModHandler.h.orig 2022-12-23 10:52:00 UTC
++++ lib/CModHandler.h
+@@ -182,6 +182,8 @@ class DLL_LINKAGE CModInfo (public)
+
+ struct Version
+ {
++#undef major
++#undef minor
+ int major = 0;
+ int minor = 0;
+ int patch = 0;
diff --git a/games/vcmi/pkg-descr b/games/vcmi/pkg-descr
index d7e5bf7527c2..894795e89c6c 100644
--- a/games/vcmi/pkg-descr
+++ b/games/vcmi/pkg-descr
@@ -8,7 +8,7 @@ features are:
- Many GUI improvements: high resolutions, stack queue,
creature window
- Advanced and easy modding support -- add new towns, creatures,
- heroes, artifacts and spells without limits or conflicts
+ heroes, artifacts, and spells without limits or conflicts
- Launcher for easy configuration -- download mods from our
server and install them immediately!
- Random map generator that supports objects added by mods
diff --git a/games/vcmi/pkg-message b/games/vcmi/pkg-message
index 9eaa0c437db2..0baf387eb861 100644
--- a/games/vcmi/pkg-message
+++ b/games/vcmi/pkg-message
@@ -6,8 +6,8 @@ of Death or Complete editions. Data files from native GNU/Linux port made
by Loki Entertainment Software (The Restoration of Erathia) will not work.
Install the game in Wine or manually unpack GOG installer, and copy "Data",
-"Maps" and "Mp3" from Heroes III to /home/$USER/.local/share/vcmi/ or, if
-$XDG_DATA_HOME is set, to $XDG_DATA_HOME/vcmi/.
+"Maps", and "MP3" directories from the installation to ~/.local/share/vcmi/
+or, if XDG_DATA_HOME environment variable is set, to $XDG_DATA_HOME/vcmi/.
EOM
}
]
diff --git a/games/vcmi/pkg-plist b/games/vcmi/pkg-plist
index e24de2005e48..c6ea89a52118 100644
--- a/games/vcmi/pkg-plist
+++ b/games/vcmi/pkg-plist
@@ -1,6 +1,7 @@
bin/vcmibuilder
bin/vcmiclient
-%%LAUNCHER%%bin/vcmilauncher
+%%QT%%bin/vcmieditor
+%%QT%%bin/vcmilauncher
bin/vcmiserver
lib/vcmi/AI/libBattleAI.so
lib/vcmi/AI/libEmptyAI.so
@@ -8,15 +9,19 @@ lib/vcmi/AI/libNullkiller.so
lib/vcmi/AI/libStupidAI.so
lib/vcmi/AI/libVCAI.so
lib/vcmi/libvcmi.so
-lib/vcmi/scripting/libvcmiERM.so
-lib/vcmi/scripting/libvcmiLua.so
share/applications/vcmiclient.desktop
-%%LAUNCHER%%share/applications/vcmilauncher.desktop
+%%QT%%share/applications/vcmieditor.desktop
+%%QT%%share/applications/vcmilauncher.desktop
share/icons/hicolor/256x256/apps/vcmiclient.png
share/icons/hicolor/32x32/apps/vcmiclient.png
share/icons/hicolor/48x48/apps/vcmiclient.png
share/icons/hicolor/64x64/apps/vcmiclient.png
-%%LAUNCHER%%share/metainfo/eu.vcmi.VCMI.metainfo.xml
+%%QT%%share/icons/hicolor/128x128/apps/vcmieditor.png
+%%QT%%share/icons/hicolor/256x256/apps/vcmieditor.png
+%%QT%%share/icons/hicolor/32x32/apps/vcmieditor.png
+%%QT%%share/icons/hicolor/48x48/apps/vcmieditor.png
+%%QT%%share/icons/hicolor/64x64/apps/vcmieditor.png
+%%QT%%share/metainfo/eu.vcmi.VCMI.metainfo.xml
%%DATADIR%%/Mods/vcmi/Data/QuickRecruitmentWindow/CreaturePurchaseCard.png
%%DATADIR%%/Mods/vcmi/Data/StackQueueLarge.png
%%DATADIR%%/Mods/vcmi/Data/StackQueueSmall.png
@@ -73,6 +78,10 @@ share/icons/hicolor/64x64/apps/vcmiclient.png
%%DATADIR%%/Mods/vcmi/Sprites/vcmi/battleQueue/statesSmall.json
%%DATADIR%%/Mods/vcmi/Sprites/vcmi/battleQueue/waitBig.png
%%DATADIR%%/Mods/vcmi/Sprites/vcmi/battleQueue/waitSmall.png
+%%DATADIR%%/Mods/vcmi/Sprites/vcmi/creatureIcons/towerLarge.png
+%%DATADIR%%/Mods/vcmi/Sprites/vcmi/creatureIcons/towerSmall.png
+%%DATADIR%%/Mods/vcmi/config/vcmi/towerCreature.json
+%%DATADIR%%/Mods/vcmi/config/vcmi/towerFactions.json
%%DATADIR%%/Mods/vcmi/mod.json
%%DATADIR%%/config/ERMU_to_picture.json
%%DATADIR%%/config/NEUTRAL.PAL
@@ -137,6 +146,8 @@ share/icons/hicolor/64x64/apps/vcmiclient.png
%%DATADIR%%/config/randomMap.json
%%DATADIR%%/config/resolutions.json
%%DATADIR%%/config/resources.json
+%%DATADIR%%/config/rivers.json
+%%DATADIR%%/config/roads.json
%%DATADIR%%/config/schemas/artifact.json
%%DATADIR%%/config/schemas/battlefield.json
%%DATADIR%%/config/schemas/bonus.json
@@ -149,11 +160,13 @@ share/icons/hicolor/64x64/apps/vcmiclient.png
%%DATADIR%%/config/schemas/object.json
%%DATADIR%%/config/schemas/objectTemplate.json
%%DATADIR%%/config/schemas/objectType.json
+%%DATADIR%%/config/schemas/obstacle.json
%%DATADIR%%/config/schemas/script.json
%%DATADIR%%/config/schemas/settings.json
%%DATADIR%%/config/schemas/skill.json
%%DATADIR%%/config/schemas/spell.json
%%DATADIR%%/config/schemas/template.json
+%%DATADIR%%/config/schemas/terrain.json
%%DATADIR%%/config/schemas/townBuilding.json
%%DATADIR%%/config/schemas/townSiege.json
%%DATADIR%%/config/schemas/townStructure.json
@@ -168,34 +181,43 @@ share/icons/hicolor/64x64/apps/vcmiclient.png
%%DATADIR%%/config/terrainViewPatterns.json
%%DATADIR%%/config/terrains.json
%%DATADIR%%/config/translate.json
-%%LAUNCHER%%%%DATADIR%%/launcher/icons/menu-game.png
-%%LAUNCHER%%%%DATADIR%%/launcher/icons/menu-mods.png
-%%LAUNCHER%%%%DATADIR%%/launcher/icons/menu-settings.png
-%%LAUNCHER%%%%DATADIR%%/launcher/icons/mod-delete.png
-%%LAUNCHER%%%%DATADIR%%/launcher/icons/mod-disabled.png
-%%LAUNCHER%%%%DATADIR%%/launcher/icons/mod-download.png
-%%LAUNCHER%%%%DATADIR%%/launcher/icons/mod-enabled.png
-%%LAUNCHER%%%%DATADIR%%/launcher/icons/mod-update.png
-%%DATADIR%%/scripts/lib/Metatype.lua
-%%DATADIR%%/scripts/lib/erm.lua
-%%DATADIR%%/scripts/lib/erm/BM.lua
-%%DATADIR%%/scripts/lib/erm/BU.lua
-%%DATADIR%%/scripts/lib/erm/DO.lua
-%%DATADIR%%/scripts/lib/erm/FU.lua
-%%DATADIR%%/scripts/lib/erm/FU_T.lua
-%%DATADIR%%/scripts/lib/erm/GM_T.lua
-%%DATADIR%%/scripts/lib/erm/HE.lua
-%%DATADIR%%/scripts/lib/erm/IF.lua
-%%DATADIR%%/scripts/lib/erm/MA.lua
-%%DATADIR%%/scripts/lib/erm/MF.lua
-%%DATADIR%%/scripts/lib/erm/MF_T.lua
-%%DATADIR%%/scripts/lib/erm/OB_T.lua
-%%DATADIR%%/scripts/lib/erm/OW.lua
-%%DATADIR%%/scripts/lib/erm/PI_T.lua
-%%DATADIR%%/scripts/lib/erm/ReceiverBase.lua
-%%DATADIR%%/scripts/lib/erm/TM.lua
-%%DATADIR%%/scripts/lib/erm/TM_T.lua
-%%DATADIR%%/scripts/lib/erm/TriggerBase.lua
-%%DATADIR%%/scripts/lib/erm/UN.lua
-%%DATADIR%%/scripts/lib/erm/VR.lua
-%%DATADIR%%/scripts/lib/verm.lua
+%%QT%%%%DATADIR%%/launcher/icons/menu-game.png
+%%QT%%%%DATADIR%%/launcher/icons/menu-lobby.png
+%%QT%%%%DATADIR%%/launcher/icons/menu-mods.png
+%%QT%%%%DATADIR%%/launcher/icons/menu-settings.png
+%%QT%%%%DATADIR%%/launcher/icons/mod-delete.png
+%%QT%%%%DATADIR%%/launcher/icons/mod-disabled.png
+%%QT%%%%DATADIR%%/launcher/icons/mod-download.png
+%%QT%%%%DATADIR%%/launcher/icons/mod-enabled.png
+%%QT%%%%DATADIR%%/launcher/icons/mod-update.png
+%%QT%%%%DATADIR%%/launcher/icons/room-private.png
+%%QT%%%%DATADIR%%/mapeditor/icons/brush-1.png
+%%QT%%%%DATADIR%%/mapeditor/icons/brush-2.png
+%%QT%%%%DATADIR%%/mapeditor/icons/brush-4.png
+%%QT%%%%DATADIR%%/mapeditor/icons/brush-5.png
+%%QT%%%%DATADIR%%/mapeditor/icons/document-new.png
+%%QT%%%%DATADIR%%/mapeditor/icons/document-open.png
+%%QT%%%%DATADIR%%/mapeditor/icons/document-save.png
+%%QT%%%%DATADIR%%/mapeditor/icons/edit-clear.png
+%%QT%%%%DATADIR%%/mapeditor/icons/edit-copy.png
+%%QT%%%%DATADIR%%/mapeditor/icons/edit-cut.png
+%%QT%%%%DATADIR%%/mapeditor/icons/edit-paste.png
+%%QT%%%%DATADIR%%/mapeditor/icons/edit-redo.png
+%%QT%%%%DATADIR%%/mapeditor/icons/edit-undo.png
+%%QT%%%%DATADIR%%/mapeditor/icons/fill-obstacles.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mapeditor.128x128.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mapeditor.256x256.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mapeditor.32x32.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mapeditor.48x48.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mapeditor.64x64.png
+%%QT%%%%DATADIR%%/mapeditor/icons/menu-game.png
+%%QT%%%%DATADIR%%/mapeditor/icons/menu-mods.png
+%%QT%%%%DATADIR%%/mapeditor/icons/menu-settings.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mod-delete.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mod-disabled.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mod-download.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mod-enabled.png
+%%QT%%%%DATADIR%%/mapeditor/icons/mod-update.png
+%%QT%%%%DATADIR%%/mapeditor/icons/toggle-grid.png
+%%QT%%%%DATADIR%%/mapeditor/icons/toggle-pass.png
+%%QT%%%%DATADIR%%/mapeditor/icons/toggle-underground.png